Centos 6.2 Perfect Server clamav/amavisd issues

Discussion in 'HOWTO-Related Questions' started by grturner, Apr 3, 2012.

  1. grturner

    grturner New Member

    Hello, I've been following the guide to the Perfect Server Centos 6.2 and I've encountered a problem with step 14, where I installing clamav amavisd and spamassassin. The problem relates to clamav and amavisd.

    Code:
    [root@vps1 init.d]# sa-update
    [root@vps1 init.d]# chkconfig --levels 235 amavisd on
    [root@vps1 init.d]# chkconfig --del clamd
    [root@vps1 init.d]# chkconfig --levels 235 clamd.amavisd on
    error reading information on service clamd.amavisd: No such file or directory
    
    There is simply no clamd.amavisd to be found. It's not present in /etc/init.d nor /etc/rc.d/init.d/ Has anyone else encountered this and might have some pointers?
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you see any errors or warnings when you run
    Code:
    yum install amavisd-new spamassassin clamav clamd unzip bzip2 unrar perl-DBD-mysql
    ?
     
  3. jorgeaaq

    jorgeaaq New Member

    file clamd.amavis not found

    Hi:

    i have the same problem

    i do not have errors in yum ... everything appears to be installed correctly


    yum install amavisd-new spamassassin clamav clamd unzip bzip2 unrar perl-DBD-mysql
    Setting up Install Process
    Package amavisd-new-2.6.6-2.el6.rf.x86_64 already installed and latest version
    Package spamassassin-3.3.1-2.el6.x86_64 already installed and latest version
    Package clamav-0.97.4-1.el6.rf.x86_64 already installed and latest version
    Package clamd-0.97.4-1.el6.rf.x86_64 already installed and latest version
    Package unzip-6.0-1.el6.x86_64 already installed and latest version
    Package bzip2-1.0.5-7.el6_0.x86_64 already installed and latest version
    Package unrar-4.1.4-1.el6.rf.x86_64 already installed and latest version
    Package perl-DBD-MySQL-4.013-3.el6.x86_64 already installed and latest version

    any ideas why clamd.amavis file is not created ???

    i am using
    CentOS release 6.2 (Final)
    Linux xxx 2.6.32-220.13.1.el6.x86_64 #1 SMP Tue Apr 17 23:56:34 BST 2012 x86_64 x86_64 x86_64 GNU/Linux

    thanks in advance
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the output of:

    ls -la /etc/init.d/
     
  5. jorgeaaq

    jorgeaaq New Member

    ls -la /etc/init.d

    total 228
    drwxr-xr-x. 2 root root 4096 Apr 19 09:18 .
    drwxr-xr-x. 10 root root 4096 Apr 18 17:11 ..
    -rwxr-xr-x 1 root root 2297 Jan 20 16:44 amavisd
    -rwxr-xr-x 1 root root 3378 Dec 7 19:14 auditd
    -rwxr-xr-x 1 root root 5470 Sep 23 2011 cgconfig
    -rwxr-xr-x 1 root root 3592 Sep 23 2011 cgred
    -rwxr-xr-x 1 root root 1292 Apr 14 2011 clamd
    -r-xr-xr-x 1 root root 893 Apr 18 21:38 courier-authlib
    -rwxr-xr-x 1 bin bin 2353 Apr 18 21:45 courier-imap
    -rwxr-xr-x 1 root root 2793 Jul 18 2011 crond
    -rw-r--r-- 1 root root 18171 Oct 7 2011 functions
    -rwxr-xr-x 1 root root 5629 Oct 7 2011 halt
    -rwxr-xr-x 1 root root 3371 Feb 13 16:33 httpd
    -rwxr-xr-x 1 root root 8727 Feb 24 23:26 ip6tables
    -rwxr-xr-x 1 root root 8630 Feb 24 23:26 iptables
    -rwxr-xr-x 1 root root 652 Oct 7 2011 killall
    -r-xr-xr-x 1 root root 2489 Dec 7 16:48 lvm2-monitor
    -rwxr-xr-x 1 root root 2200 Sep 23 2011 messagebus
    -rwxr-xr-x 1 root root 5509 Feb 8 15:39 mysqld
    -rwxr-xr-x 1 root root 6806 Jan 10 03:13 named
    -rwxr-xr-x 1 root root 2980 Oct 7 2011 netconsole
    -rwxr-xr-x 1 root root 5485 Oct 7 2011 netfs
    -rwxr-xr-x 1 root root 6502 Oct 7 2011 network
    -rwxr-xr-x 1 root root 1923 Oct 22 2009 ntpd
    -rwxr-xr-x 1 root root 1866 Oct 22 2009 ntpdate
    -rwxr-xr-x 1 root root 1866 Sep 23 2011 portreserve
    -rwxr-xr-x 1 root root 3852 Dec 2 23:00 postfix
    -rwxr-xr-x 1 root root 1534 Oct 5 2008 pure-ftpd
    -rwxr-xr-x 1 root root 2034 Feb 4 2011 quota_nld
    -rwxr-xr-x 1 root root 1559 May 19 2009 rdisc
    -rwxr-xr-x 1 root root 1815 Feb 14 15:49 restorecond
    -rwxr-xr-x 1 root root 2269 Aug 22 2011 rsyslog
    -rwxr-xr-x 1 root root 1698 Feb 14 15:49 sandbox
    -rwxr-xr-x 1 root root 2056 Apr 12 2010 saslauthd
    -rwxr-xr-x 1 root root 647 Oct 7 2011 single
    -rwxr-xr-x 1 root root 7263 Dec 7 15:48 slapd
    -rwxr-xr-x 1 root root 2162 Dec 19 14:46 snmpd
    -rwxr-xr-x 1 root root 1738 Dec 19 14:46 snmptrapd
    -rwxr-xr-x 1 root root 1664 Aug 22 2010 spamassassin
    -rwxr-xr-x 1 root root 4582 Jan 25 09:56 sshd
    -rwxr-xr-x 1 root root 2296 Dec 7 15:17 udev-post
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please see post #2.

    Did you enable all repos as shown in the tutorial?
     
  7. jorgeaaq

    jorgeaaq New Member

    yum-priorities

    Thanks Falco

    Solved!!!!

    you point me in the right direction !!!!

    my mistake, I overdo something...

    following your guide, I install rpmforge and epel repositories

    but!!!

    I put different priorities to every repository , instead of only put epel in priority 10

    and that was my problem, after that yum install amavis and some packages from rpmforge instead of epel

    I remove the priorities , run yum update and voila!! everything works according to your guide

    thanks for everything


    Jorge Arenas
     

Share This Page