Centos 5.x, SVN & Apache

Discussion in 'Server Operation' started by sfunk1x, Jan 25, 2012.

  1. sfunk1x

    sfunk1x New Member

    Hey all,

    I'm having a heck of a time getting subversion to work with my Centos 5.x & Apache setup. It seems as though I can import when I'm at console, but when I try to connect to the server form my workstation (to make a commit via subclipse), I get a lot of 403 errors showing up in the logs. let me break it down in steps:

    Version: 2.6.18-164.6.1.el5xen GNU/Linux


    LoadModule dav_svn_module     modules/mod_dav_svn.so
    LoadModule authz_svn_module   modules/mod_authz_svn.so
    <Location /repos>
           	DAV svn
            SVNParentPath /var/www/html/www.sfunk1x.com/svn
    #	SVNParentPath /svn/repos
            AuthType Basic
            AuthName "sfunk1x repos"
            AuthUserFile /var/www/html/www.sfunk1x.com/svn/repos/conf/passwd
            Require valid-user
    I used svnadmin to create the repos folder underneath /var/www/html/www.sfunk1x.com/svn. I chown'd apache.apache to svn -R. I also set chmod 775 to repos -R.

    I used htpasswd to create the passwd file in /var/www/html/www.sfunk1x.com/svn/repos/conf.

    When I attempt a checkin or checkout from http://www.sfunk1x.com/repos/Java1_Ch8, I get the following errors:

    svn: E000002: Unable to connect to a repository at URL 'http://www.sfunk1x.com/repos/Java1_Ch8'
    svn: E000002: Could not open the requested SVN filesystem
    When I perform a checkin or checkout locally (on the server) via the /tmp folder, everything works fine. The webserver seems to be working fine (all the virtual hosts are responding), so I'm at a loss as to what is wrong. Even when i disable the authentication, the same errors pop up.

    From the www.sfunk1x.com-error_log:

    [Sat Jan 21 20:39:25 2012] [error] [client] (20014)Internal error: Can't open file '/svn/repos/Java1_Ch8/format': No such file or directory
    [Sat Jan 21 20:39:25 2012] [error] [client] Could not fetch resource information.  [500, #0]
    [Sat Jan 21 20:39:25 2012] [error] [client] Could not open the requested SVN filesystem  [500, #2]
    [Sat Jan 21 20:39:25 2012] [error] [client] Could not open the requested SVN filesystem  [500, #2]
    From the www.sfunk1x.com-access_log:

    Code: - - [21/Jan/2012:20:39:18 -0800] "OPTIONS /repos/Java1_Ch8 HTTP/1.1" 401 481 - sfunk1x [21/Jan/2012:20:39:25 -0800] "OPTIONS /repos/Java1_Ch8 HTTP/1.1" 500 234
    I'm really at a loss here. Anyone have any ideas as to where I should start looking? I appreciate any help thrown my way!

Share This Page