CentOS 5.3 and ISPConfig 3.0.1.1

Discussion in 'Installation/Configuration' started by wires, May 4, 2009.

  1. wires

    wires New Member

    hi, i have a problem installing the latest ISPConfig package. I need to mention that this is a fresh install of CentOS 5.3 but I followed this guide http://www.howtoforge.com/perfect_setup_centos5.0 which ended up with no errors following the guide itself, the user who made the guide though did not mention on how to install ISPConfig, he just mentioned that he is using it.

    To get to the point, i have downloaded the package and did the installation using the provided install.php file (
    PHP:
    php -q install.php
    ) even though ISPConfig did not want to install at first because it doesn't know that i am running centos 5.3 and NOT centos 5.2, i had to edit file /tmp/ispconfig3_install/install/lib/install.lib.php as described here -> http://www.howtoforge.com/forums/showthread.php?t=33407&highlight=centos

    I got the installation till the end but there was an error with my httpd server, error i received was:

    [warn] NameVirtualHost *:443 has no VirtualHosts
    [warn] NameVirtualHost *:80 has no VirtualHosts
    Starting httpd: [FAILED]

    now, i am using a hostname provided by http://freedns.afraid.org/ and i guess that i need to configure appache to use my hostname but i did and it does not work either, httpd fails to start each time. The weird part is that i cannot stop it or restart it, i am running webmin and webmin is running fine and i can access it no problem. ISPConfig on port 8080 is NOT working at all.

    any suggestions on how i can fix this please, I have reisntalled ISPConfig but i get the same problem at the end. Please dont tell me that i have to follow the "official guide" since the official guide dont meet my needs as to the software to use, the official guide for me is only installing ISPConfig, please check the link i provided earlier.

    ISPConfig 3 said the Installation completed but i am not sure why it's not telling me why it can't add the VirtualHosts by himself.
    cheers
     
    Last edited: May 4, 2009
  2. RomaSvcs

    RomaSvcs New Member

    I got the installation till the end but there was an error with my httpd server, error i received was:

    [warn] NameVirtualHost *:443 has no VirtualHosts
    [warn] NameVirtualHost *:80 has no VirtualHosts
    Starting httpd: [FAILED]

    Do this:

    create the virtual server for _default_:80, *:80, etc as needed...
    with WEBMIN or open /etc/http/conf/httpd.conf and add
    NameVirtualHost *:80
    NameVirtualHost *:443
    <VirtualHost _default_:80>
    </VirtualHost>

    Done!!

    Carlos Barrera
     
  3. RomaSvcs

    RomaSvcs New Member

    Web-Server: Offline error or BUG?

    ERROR: @ Monitor/Server State/Show Services....
    Server: server.webserver.com
    State: error
    0 unknown | 0 info | 0 warning | 0 critical | 1 error

    ok:
    The state of your Hard-Disk space is ok [More...]
    Your Virus-protection is ok [More...]
    Your Mailq load is ok [More...]
    Your Server load is ok [More...]
    The System-Log is O.K. [More...]

    error:
    One or more needed Services are offline [More...]
    Web-Server: Offline http://www.howtoforge.com/forums/images/smilies/confused.gif
    FTP-Server: Online
    SMTP-Server: Offline
    POP3-Server: Online
    IMAP-Server: Online
    myDNS-Server: Online
    mySQL-Server: Online

    so I restarted the services:

    SMTP-Server: Online
    after /etc/init.d/postfix restart

    Web-Server: Offline
    after /etc/init.d/httpd restart

    I checked and the apache server is online...
    [user@server ~]$ su root
    Password: xxxxxxxxxxxxxx
    [root@server user]# /etc/init.d/httpd restart
    Stopping httpd: [ OK ]
    Starting httpd: [ OK ]
    [root@server user]# exit

    Any clues way ISPCONFIG 3.0.1.1 can not detect that the apache server is online??
    http://www.howtoforge.com/forums/images/smilies/eek.gif
    Thanks in advance

    Carlos Barrera
     
  4. wires

    wires New Member

    I did what you wrote and it works for the apache server problem not starting up. But also the problem is that i am unable to find if ISPConfig 3 is running or not, i tried connecting to the port i choosed when installing it but it doesn't come up in my browser.

     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please make sure that you are not running any firewals that block this port.
     
  6. wires

    wires New Member

    i am not running any firewalls. (system-config-securitylevel disabled)

    I followed the guide http://www.howtoforge.com/perfect-server-centos-5.2-ispconfig-3-p6 and installed every packages listed there besides PureFTPd. I disabled the firewall at the beginning of the tutorial and rebooted the system. But like before, ISPConfig 3 tells me it has been installed successfully but yet i cannot see any login page from the port i choosed in installation.

    I noticed this Apache error
    from fedora.lib.php the line contains the following
    PHP:
                foreach($records as $rec) {
    in
    PHP:
            // copy('tpl/apache_ispconfig.conf.master',$vhost_conf_dir.'/ispconfig.conf');
            
    $content rf("tpl/apache_ispconfig.conf.master");
            
    $records $this->db->queryAllRecords("SELECT * FROM server_ip WHERE server_id = ".$conf["server_id"]." AND virtualhost = 'y'");
            if(
    count($records) > 0) {
                foreach(
    $records as $rec) {
                    
    $content .= "NameVirtualHost ".$rec["ip_address"].":80\n";
                    
    $content .= "NameVirtualHost ".$rec["ip_address"].":443\n";
                }
            }
    my httpd.conf contains the following at the end
    any ideas ?

    ps:

    i added the following to the end of my httpd.conf file
    and now when i try to access ISPConfig login page using the domain name i choosed, internet explorer downloads a file named my domain.name[1] and inside that file i have this:

    PHP:
    <?php

    /*
    Copyright (c) 2007, Till Brehm, projektfarm Gmbh
    All rights reserved.

    Redistribution and use in source and binary forms, with or without modification,
    are permitted provided that the following conditions are met:

        * Redistributions of source code must retain the above copyright notice,
          this list of conditions and the following disclaimer.
        * Redistributions in binary form must reproduce the above copyright notice,
          this list of conditions and the following disclaimer in the documentation
          and/or other materials provided with the distribution.
        * Neither the name of ISPConfig nor the names of its contributors
          may be used to endorse or promote products derived from this software without
          specific prior written permission.

    THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
    ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
    WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
    IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
    INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
    BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
    DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
    OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
    NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
    EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    */

    error_reporting(E_ALL|E_STRICT);

    require_once(
    '../lib/config.inc.php');
    require_once(
    '../lib/app.inc.php');

    $app->uses('tpl');
    $app->tpl->newTemplate('main.tpl.htm');

    $app->tpl_defaults();
    $app->tpl->pparse();
    ?>
    i think apache isn't loading PHP scripts properly... i just checked phpmyadmin and it gives me a text page instead of the index page coded in php.
     
    Last edited: May 10, 2009

Share This Page