Centos 5.2: Time out while "Loading "fastestmirror" plugin"

Discussion in 'Server Operation' started by flameproof, Jan 26, 2009.

  1. flameproof

    flameproof Member

    I have a strange new problem. When I am SSH connected to my VPS and I do YUM .... whatever I get stuck at "Loading "fastestmirror" plugin"

    Nothings happen then and I need to close the SSH connection.

    That means that I can't update any packages now. Any idea were that problem could be?
  2. topdog

    topdog Active Member HowtoForge Supporter

    fastestmirror plugin is used to determine which is the best mirror to use, it is most likely that there is either a firewall/IPS or rate limiting that is blocking your http connections or limiting the number of connections you can make.

    Speak to your VPS provider and see what they say.
  3. flameproof

    flameproof Member

    I will asked them and wait for a reply. But since its worked so far I can't see any external issues.

    I tried now to reinstall YUM. WGET works, but I also get hung up on RPB. Something seems really wrong with my VPS....
  4. topdog

    topdog Active Member HowtoForge Supporter

    It is possible that your vps has been hacked and binaries have been modified.
  5. flameproof

    flameproof Member

    I doubt the "hacked", but it's likely somebody silly did modified something unintentionally. Most likely me.

    I think I do a complete re-install of the whole VPS. Worries me a little now since it's running with a few domains and email accounts.
  6. flameproof

    flameproof Member

    Suddenly if have that problem again..... To isolate the problem, how can I:

    Remove "fastestmirror plugin" ("Yum remove" will also load "fastestmirror plugin", means it hangs) (I did a "enabled = 0" in the yum conf, but putty still hangs, now without "Loading "fastestmirror" plugin")

    Display the repositories in putty

    PS: Now I use these repos, anything there that shouldn't?

    Last edited: Jul 6, 2009

Share This Page