centos 5.2, firefox wont start.

Discussion in 'HOWTO-Related Questions' started by Layla Nahar, Jun 11, 2010.

  1. Layla Nahar

    Layla Nahar New Member

    Hello

    I did the perfect server tutorial for Centos 5.2 (http://www.howtoforge.com/perfect-server-centos-5.2). I was able to start firefox and open web pages from the Internet.

    I made some changes*, and now when I try to start firefox, it fails to start. "Starting web browser" appears briefly in the taskbar but then it goes away. No error message displays.

    I was hoping someone can offer me suggestion on how to diagnose and repair this. I can ping google.com from this machine

    thank you very much
    LN

    *(I did ch 7 & ch 9 from this tutorial http://www.howtoforge.com/perfect-server-centos-5.2-ispconfig-3)
     
  2. falko

    falko Super Moderator

    So you have a desktop on your CentOS server?
    Any errors in your logs?
     
  3. Layla Nahar

    Layla Nahar New Member

    Hello Falko -

    thank you for your reply, and your suggestion to check my logs for errors. (yes, I have a desktop on my CentOS server).

    I tried to find log files by grepping in different directories for mozilla and firefox. I see a lot of install and configuration stuff. I only see the word error once /root/*.log* (It says: Installing libgpg-error-1.4-2.i386)

    I would be really grateful if you could give me some guidance about where to look for the right logs.

    thank you

    LN
     
  4. falko

    falko Super Moderator

    Maybe there was a faulty Firefox update? Can you try
    Code:
    yum update
    again?
     
  5. Layla Nahar

    Layla Nahar New Member

    Hello Falko

    Thank you very much for helping me out with this. When I did

    yum update

    I got an error. Below is what I saw. Is this significant?

    thanks again
    LN


    [root@server1 ~]# yum update
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * addons: centos.corenetworks.net
    * base: mirror.ubiquityservers.com
    * extras: mirror.team-cymru.org
    * rpmforge: apt.sw.be
    * updates: mirror.vcu.edu
    Setting up Update Process
    Error: Package tuple ('perl-Socket6', 'i386', '0', '0.23', '1.rh9.rf') could not be found in packagesack
    [root@server1 ~]#
     

Share This Page