Centos 4.4 ISPconfig I cant recive emails from out.

Discussion in 'General' started by polikarp, Mar 23, 2007.

  1. polikarp

    polikarp New Member


    I searc the forum but I can not find any answer or beter solutions for my problem.

    I installed Centos 4.4 with ISPconfig all services are working good.

    I have dinamic IP adress and I am using dyndns.org free domains.

    my domain like "myname.ath.cx"

    Server user can send and recive emails each others there is no problem. Like
    [email protected] can send and recive email from [email protected]
    Even both are can send email to other emails like hotmail or yahoo.

    My problem is;
    I can not recieve emails from other mail providers like yahoo etc.
    Mail log file have no any warning messages.

    What can I do?

    Thank you for your help.
  2. edge

    edge Active Member Moderator

    Sounds like a MX DNS problem.

    Test your domain at www.dnsreport.com , and report back any errors / fails.
    (enter your domain in the DNS report box)
  3. polikarp

    polikarp New Member

    Edge thank you for quick reply;
    I chcked and I that gat this message;
    ERROR: The parent servers say that the domain myname.ath.cx does not have any NS records (although they may have some other information on that zone). I can not do a DNS report on a hostname (such as mail.example.com) or a domain name that does not have its own zone.]

    How can I fix this or do you know can I do thhat with kind of free domain?
    Thanks again.
  4. edge

    edge Active Member Moderator

    No MX, no mail.. The MX record of a DNS is telling other servers where the mail should go to..

    You will need to creat a MX record in (your?) DNS server that is pointing to your mailserver.

    If you run your own DNS server, all you will need to do is within ISPconfig go to DNS manager > the-domain > Records, and click on New under MX.
    Enter in Host: @ and in Mailserver the 1st domain of your server**

    ** The one you set in Management > Server > Settings (the Domain)

    Aftert this do the dnsreport test again, and see if it's any better.
  5. polikarp

    polikarp New Member

    Thanks again;
    I tryed all what you say but still I am taking same messages.

    I reboot to computer. But nothing changed.
  6. edge

    edge Active Member Moderator

    If you are using dyndns.org, than you are not using your own dns!
    You will need to set the MX record at dyndns.org I think
  7. polikarp

    polikarp New Member

    ok thank you I will ask this them.
  8. polikarp

    polikarp New Member

    Hi Again;
    I talked with dyndns.org and they support mx recort free I seted neccessery install. Now I am accesing web site which before you gave me DNS report giving still problem but beside of that mail test giving exact report means that working.

    Do I have wait for dns record for some times like 12, 24, 48 hours or it must be effect immediet? Because still I can't receive email from out.

    Thanks again.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Please ask your provider if they block port 25 on your dsl or cable line where you host your server on.
  10. polikarp

    polikarp New Member

    Till thank you for answer;
    All neccesery ports are open and working. Include 110 and 25. And firewalls are turned off
    Last edited: Mar 24, 2007
  11. falko

    falko Super Moderator ISPConfig Developer

    Usually DynDNS records propagate very fast (a few seconds to minutes)...

    Did you ask your provider if they block port 25?

    Did you check with
    dig mx yourdomain.com
    if the MX record is correct?
  12. polikarp

    polikarp New Member

    Thank you Falko
    port is open I asked allready I did dig mx yourdomain.com all are in order not seems problem.
  13. falko

    falko Super Moderator ISPConfig Developer

    Please run
    tail -f /var/log/maillog
    and send a mail to your server (from an external account). Do you see any activity in the tail output?
  14. TexasTaz

    TexasTaz New Member

    Re: DynDNS

    I work for a hosting company. Usually when this happens it is because the Nameservers are not properly inserted at the registrar, You need to go to your registrar and make sure you have ns1.mydyndns.org and ns2.mydyndns.org as your nameservers here is alink for the actual nameservers. http://www.dyndns.com/support/services/custom/howto.html

    This should help you. If you want me to help you diagnose this problem I can just give me the domain name in this form your.domain.tld from dyndns.org and IWill diagnose and tell you how to fix it.

    Let me know,
  15. polikarp

    polikarp New Member

    Falko nothing happen with this.
    TexasTaz thank you for your help.

    I talked with dyndns.com their custom dns solutions is good for my own domain but I am using their sub domain like myname.ath.cx so it is a free of charge. They are giving MXrecord support for free domain. When I try to dig it seems ok. I think just mx record is enough for mail server. I dont need to pay for their custom dns because I dont need use my own domain.
  16. falko

    falko Super Moderator ISPConfig Developer

    This means that the mail doesn't even arrive at your server, so it's either because of wrong MX records or because port 25 is blocked (maybe a firewall?)...

    What's the value of inet_interfaces from /etc/postfix/main.cf?
  17. punto

    punto New Member

    From a network external to your server run the command:

    telnet myname.ath.cx 25

    If your mail server is working correctly you should see the following output

    220 myname.ath.cx ESMTP Postfix


  18. TexasTaz

    TexasTaz New Member

    Re: Your Problem

    What is the domain name involved let me help you with this. Once I get this I can find out what is going on and we can resolve it for you.

    See ya,

Share This Page