cc1: error: unrecognized command line option "-m486"

Discussion in 'Installation/Configuration' started by tensor, Sep 11, 2008.

  1. tensor

    tensor New Member

    Hello.
    I am trying to upgrade the 2.2.21 version to 2.2.25.
    The OS is Debian/lenny(testing).
    In the process of compilation I get
    Code:
    cc1: error: unrecognized command line option "-m486"
    Any tips on how to change the build process?

    And one more thing. If ./setup fails to upgrade, it wipes the whole /root/ispconfig directory. Luckily I have the whole filesystem under version control and could revert this directory easily.
     
  2. tensor

    tensor New Member

    The whole error message is as follows:
    Code:
    making all in crypto...
    make[1]: Entering directory `/root/install_ispconfig/compile_aps/openssl-0.9.7m/crypto'
    ( echo "#ifndef MK1MF_BUILD"; \
            echo '  /* auto-generated by crypto/Makefile for crypto/cversion.c */'; \
            echo '  #define CFLAGS "gcc -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_NO_KRB5 -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall -DSHA1_ASM -DMD5_ASM -DRMD160_ASM"'; \
            echo '  #define PLATFORM "linux-elf"'; \
            echo "  #define DATE \"`LC_ALL=C LC_TIME=C date`\""; \
            echo '#endif' ) >buildinf.h
    gcc -I. -I.. -I../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_NO_KRB5 -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall -DSHA1_ASM -DMD5_ASM -DRMD160_ASM   -c -o cryptlib.o cryptlib.c
    cc1: error: unrecognized command line option "-m486"
    make[1]: *** [cryptlib.o] Error 1
    make[1]: Leaving directory `/root/install_ispconfig/compile_aps/openssl-0.9.7m/crypto'
    make: *** [sub_all] Error 1
    ERROR: Could not make OpenSSL
    
     
  3. falko

    falko Super Moderator ISPConfig Developer

  4. castel

    castel New Member

    I seem to have the same problem. But I am using Fedora 9.

    Have followed the "Perfect Server" how to for seting everything up.

    Any clue?

    Thanks
    Daniel
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try the solution that falko posted above. The problem is related to the cpu in your server and not a specific linux distribution.
     
  6. castel

    castel New Member

    Allright hopefully that be the reason then.

    But, I am not sure what that post is meaning. Im real new to this linux.
    Maybe someone can explain little more than in that singel post?

    compile_apps?

    :)
    Thanks
     
  7. castel

    castel New Member

    Think I understand now.

    Will try...

    :)
     
  8. castel

    castel New Member

    It works!
    Thank you so much!
     

Share This Page