Catch all catches all (I've read all other posts but can't solve it)

Discussion in 'General' started by sik206, May 1, 2008.

  1. sik206

    sik206 New Member

    Hello,

    I've seen the post in the FAQ and made an mydomain entry in my main.cf and a technical domain called server.domain.nu.

    Still all mail goes to the adress with the catch all.

    My main.cf is:
    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    append_dot_mydomain = no
    
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    
    mydomain = server.domain.nu
    myhostname = server.domain.nu
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = server.domain.nu, localhost.domain.nu, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    My /etc/postfix/virtusertable is

    Code:
    ###################################
    #
    # ISPConfig virtusertable Configuration File
    #         Version 1.0
    #
    ###################################
    [email protected]    web1_wouter
    @domain.nu    web1_wouter
    [email protected]    web12_speedo
    [email protected]    web3_hans
    [email protected]    web13_karin
    [email protected]    web14_marijke
    [email protected]    web15_server
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    Does anyone know what I'm doing wrong?

    Thnxs Wouter
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you change the domain in /etc/mailname too and then restart postfix.
     
  3. sik206

    sik206 New Member

    My /etc/mailname is:

    server.domain.nu
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    A catchall address means that all email for any undefined email address goes to the catchall account. You have just one domain name configured yet, so it is normal that all email goes to this account except of the email addresses that you explicitely defined for other accounts.
     
  5. sik206

    sik206 New Member

    Thank you for you're reply.

    I thought all mail goes to the catch all account except for the users configured in /etc/postfix/virtusertable.

    Do you know how to define other users?

    I'll check the postfix documentation for some awnsers.

    Thnxs
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Login to ISPConfig, go to the website settings, click on the user & email tab and add additional mailboxes.
     
  7. sik206

    sik206 New Member

    I know what's wrong.:D

    For every user, I made a new entry instead of storing the subdomains within the main domain.

    Thanks for your help big time.

    Wouter
     
  8. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

  9. falko

    falko Super Moderator ISPConfig Developer

    Yes, but why create a catchAll account and set its size to 0 if you don't want to receive emails for non-existing email addresses? Without the catchAll address, Postfix will refuse to accept emails to non-existing addresses.
     
  10. tylerishappy

    tylerishappy New Member

    hello falko once again.

    I have created about 4 domains in ISPConfig.

    The nameservers point

    lorecesmasterpieces.com mx 10 lorecesmasterpieces.com
    pcsask.com mx 10 pcsask.com


    my server has been setup originally for pcsask.com


    I have created an email address [email protected] under my site and set that account as the catchall account

    I have created an email address [email protected] under her site and set that account as the catchall account

    Emails sent to [email protected] are being redirected to [email protected]...
     
  11. tylerishappy

    tylerishappy New Member

  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats exactly the cause and its always the same for this issue. And you claimed to have read all posts ;)
     
  13. tylerishappy

    tylerishappy New Member

    I did some searching and read a few other ppls issues... i figured id just ask the genius's

    Is there any fix for this issue? If not I can just add a ton of aliases.
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

  15. tylerishappy

    tylerishappy New Member

    Thank you VERY MUCH for the link.

    But doesn't the $mydomain variable show up in the header information when sending emails etc etc.?
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Yes, but imagine there was one dedicated mail server for each registered domain. It is normal that a mail server handles emails for multiple domains.
     

Share This Page