Captcha Images not displaying!

Discussion in 'HOWTO-Related Questions' started by justjim, Jun 13, 2006.

  1. justjim

    justjim New Member

    Hello,
    I have a web site with captcha enabled and everything works when I have the site hosted through my provider.

    However, when I set the site up on my Ubuntu "Perfect" system, the captcha images will not display. Does anyone have any ideas what might cause this.

    Thanks in advance!

    JustJim
     
  2. falko

    falko Super Moderator

    What is captcha? :confused:
    Any error messages in your logs?
     
  3. justjim

    justjim New Member

    Captcha Images not displaying

    Falko,

    Thanks for replying.
    Captcha images are those garbled images that are displayed when you need to confirm an item to prove that the request is by a human instead of being auto-generated.

    If you go to this page, you will see that everything works fine and the images are properly displayed. This is one of my sites that is professionally hosted.
    http://www.hairremovalsource.com/test2/partners_instr.php

    However, I'm running exacly the same script on my Ubuntu Perfect server, but the images will not display. Here is the link:
    http://www.greatgolfswing.com/partners_instr.php

    I've attached the README file for the captcha script. It mentions that the following is required:

    PHP >= 4.3.0
    GD >= 2.0.28
    FreeType (http://www.freetype.org/)
    Jpeg Support (ftp://ftp.uu.net/graphics/jpeg/)
    Png Support (http://www.libpng.org/pub/png/libpng.html)

    Can you assist?
    Thanks in advance!

    - Jim
     

    Attached Files:

  4. falko

    falko Super Moderator

    Did you install the php_gd module?
    Any errors in your Apache's error log?
     
  5. justjim

    justjim New Member

    Captcha Images not displaying

    I have installed php4-gd and php5-gd.

    Which log would I find errors concerning this?
    In /var/log/apahe2/error.log I am seeing a lot of errors saying:
    [error] an unknown filter was not added: php

    Any more ideas?
    Thanks again!

    - JustJim
     
  6. falko

    falko Super Moderator

    Is the php_gd extension enabled in your php.ini?

    The log is /var/log/apahe2/error.log.

    Are the other packages installed on your system?
     
  7. justjim

    justjim New Member

    Captcha images not displaying

    I removed the ";" symbol in from of the following line of the php.ini file:
    extension=php_gd2.dll

    As far as I can tell, the other packages are also installed.
    Any other ideas?

    Thanks again!
     
  8. justjim

    justjim New Member

    Captcha images not displaying

    I was able to get this problem resolved today!

    It was a path problem. The really odd thing about it was that the script that I was having problems with works perfectly on my other professionally hosted sites. The path problem only appears to take place on my Ubuntu server.

    Weird Huh?

    Either way, thanks for all of your help Falko! I really appreciate the time you spend answering questions!

    - JustJim
     
  9. falko

    falko Super Moderator

    Glad you sorted it out. Just wanted to tell you that this line
    is for Windows, not Linux.
    dll -> Windows
    so -> Linux
     
  10. qwer

    qwer New Member

    captcha not appearing in other pc or localhost

    Hi, can you tell me how to fix this..how to make sure the path is correct?..
    because, it seems that my problm is similar to yours.



     
  11. falko

    falko Super Moderator

    Any errors in Apache's error log?
     
  12. qwer

    qwer New Member

    Captcha error

    tq, for replying..

    mm...after checking the apache log error folder, that seems there is several error log with file.var..how to check the error and read this file..

    'qwer'
     

Share This Page