Can´t upload files to FTP from External access

Discussion in 'Installation/Configuration' started by trexen, Jul 7, 2008.

  1. trexen

    trexen Member

    I get access denied when i try to upload a file whit admin user of a web-dir

    drwxrwxr-x 4 web14_name web14 4096 2008-07-07 16:24 web/

    I also make a new direktory and chown 777, still can´t upload, any sugestion?

    i got Debian 4
    ISPc 2.2.x

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    were do you try to save the file? In the web dir or in another directory?
  3. trexen

    trexen Member

    Yes, in the web dir, and it say´s access denied , i also make a new dir outside Web and chmod it whit 777, but it didden´t work ither.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux distribution and FTP daemon do you use?
  5. trexen

    trexen Member

    Debian 4 etch - 2.6.18-5-686
  6. trexen

    trexen Member

    Cut from proftpd_ispconfig.conf

    # ISPConfig proftpd Configuration File
    # Version 1.0
    DefaultRoot ~
    AllowOverwrite on
    Umask 002

  7. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/proftpd.conf?
  8. trexen

    trexen Member

    I just cut the importand stuff

    # Includes DSO modules
    Include /etc/proftpd/modules.conf

    # Set off to disable IPv6 support which is annoying on IPv4 only boxes.
    UseIPv6 off

    ServerName "Debian"
    ServerType standalone
    DeferWelcome off

    MultilineRFC2228 on
    DefaultServer on
    ShowSymlinks on

    TimeoutNoTransfer 600
    TimeoutStalled 600
    TimeoutIdle 1200

    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    ListOptions "-l"

    DenyFilter \*.*/

    # Port 21 is the standard FTP port.
    Port 21

    MaxInstances 30

    # Set the user and group that the server normally runs at.
    User proftpd
    Group nogroup

    # Umask 022 is a good standard umask to prevent new files and dirs
    # (second parm) from being group and world writable.
    Umask 022 022
    # Normally, we want files to be overwriteable.
    AllowOverwrite on

    # Uncomment this if you are using NIS or LDAP to retrieve passwords:
    # PersistentPasswd off

    # Be warned: use of this directive impacts CPU average load!
    # Uncomment this if you like to see progress and transfer rate with ftpwho
    # in downloads. That is not needed for uploads rates.
    # UseSendFile off

    TransferLog /var/log/proftpd/xferlog
    SystemLog /var/log/proftpd/proftpd.log

    <IfModule mod_tls.c>
    TLSEngine off

    <IfModule mod_quota.c>
    QuotaEngine on

    <IfModule mod_ratio.c>
    Ratios on

    # It is on by default.
    <IfModule mod_delay.c>
    DelayEngine on

    <IfModule mod_ctrls.c>
    ControlsEngine on
    ControlsMaxClients 2
    ControlsLog /var/log/proftpd/controls.log
    ControlsInterval 5
    ControlsSocket /var/run/proftpd/proftpd.sock

    <IfModule mod_ctrls_admin.c>
    AdminControlsEngine on

    DefaultRoot ~
    IdentLookups off
    ServerIdent on "FTP Server ready."

    Include /etc/proftpd_ispconfig.conf
  9. trexen

    trexen Member

    Anyone: any sugestion where i should look, can it be chmod problem ore is it in the config.

    (i dont remember if it was Till ore falko that install this server for me, just whant it right from the start =) )
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to change the line:

    Include /etc/proftpd_ispconfig.conf


    # Include /etc/proftpd_ispconfig.conf

    in proftpd.conf and restart proftpd.

    If we setup the server for you and it is not working, you should contact us by email.
  11. trexen

    trexen Member

    sure, just try to solve it by my self first =)
    a Mail is on the way.

  12. trexen

    trexen Member

    I have just update my system to 2.2.24 sucsesfully but proftpd aint working from an ftp client outside.
    I can only upload files from contropanel, wich is not good for customers that use a external company to update and maintain websites.

    Anyone got any sugestion whare i should look och serch for error.

    It only tells me "Permission denyed" when try to upload.

  13. falko

    falko Super Moderator ISPConfig Developer

  14. trexen

    trexen Member

    Yepp youre right, i forgot to uncheck "Read-only" in my firewall Rule for FTP, now everything works wonderful.

    Sorry for that.


Share This Page