Can't update Joomla on ISPConfig

Discussion in 'Installation/Configuration' started by crazysky, Sep 29, 2014.

  1. crazysky

    crazysky New Member

    Hi! I'm installed Joomla 3.3.3 on ISPConfig and want to update it to 3.3.4. But when I'm trying to update, I have error: ERROR:
    AJAX Loading Error: Internal Server Error

    In logs:

    Code:
    tail ~/log/error.log
    
    Mon Sep 29 14:49:50.175528 2014] [fcgid:warn] [pid 19778] (104)Connection reset by peer: [client 89.169.143.161:42771] mod_fcgid: error reading data from FastCGI server, referer: https://sageit.ru/administrator/index.php?option=com_joomlaupdate&task=update.install
    [Mon Sep 29 14:49:50.175593 2014] [core:error] [pid 19778] [client 89.169.143.161:42771] End of script output before headers: restore.php, referer: https://sageit.ru/administrator/index.php?option=com_joomlaupdate&task=update.install
    
    If I install Joomla on LAMP without ISPConfig - Joomla updates correct.

    Please, help me this problem.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux distribution do you use? Are there any other errors in the error.log?
     
  3. crazysky

    crazysky New Member

    Ubuntu 14.04

    Other errors I don't see.

    I tried install fresh ISPConfig on VM and fresh Joomla - same error.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. crazysky

    crazysky New Member

    I tried this, but problem not fixed.

    Code:
    [email protected]:~# diff /etc/apache2/mods-available/fcgid.conf /etc/apache2/mods-available/fcgid.conf.2014.09.29 
    3d2
    <   MaxRequestLen 15728640
    If I install fresh Ubuntu with LAMP and fastcgi without ISPConfig - Joomla updates correct.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats quite easy to explain and just related to the php mode that you use and the file permisions that you used to install joomla, its not related to ispconfig as ispconfig is neither involved in running a php file on your server nor in serving the page with apache nor in the ubuntu update script.

    Are all files in the web folder owned by the web user and client group of that website?
     
  7. crazysky

    crazysky New Member

    Of course, all permissions correct
    Code:
    [email protected]:~$ ls -la | grep web
    drwxr-xr-x  2 web51 client8 4096 авг.  29 00:33 backup
    -rwxr-xr-x  1 web51 client8 8564 сент. 29 18:00 .bash_history
    drwxr-xr-x  2 web51 client8 4096 сент. 15 15:08 cgi-bin
    drwx--x---  2 web51 client8 4096 авг.  28 16:42 private
    drwxr-xr-x 19 web51 client8 4096 авг.  30 16:17 redmine
    drwx------  2 web51 client8 4096 сент. 29 01:49 .ssh
    drwxrwxrwx  2 web51 client8 4096 сент. 28 19:59 tmp
    drwxr-xr-x 21 web51 client8 4096 сент. 29 08:11 web
    drwxr-xr-x  2 web51 client8 4096 авг.  28 16:42 webdav
    
    [email protected]:~$ chown web51:client8 ./web -R
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe your server hits a timeout during update if it takes too long. try to set:

    FcgidIdleTimeout 3600

    in the apache directives field of the website.
     
  9. crazysky

    crazysky New Member

    Added, but same error.

    I can provide access for diagnostics on server
     
  10. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    After what time this error occurs? Some seconds or some minutes?
     
  11. crazysky

    crazysky New Member

    10 minutes. Yes, occur
     
  12. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    10 minutes... That means 600 seconds.
    So please raise the FcgidIOTimeout to 3600 just for testing.

    Code:
    FcgidIOTimeout 3600
     
  13. crazysky

    crazysky New Member

    I did. I have error after 1 second. I mean, that I wait 10 minutes after save Apache configuration in ISPConfig and tried update.
     
  14. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Ah okay.
    So have you checked your php.ini settings for the timeout settings?
    default_socket_timeout
    max_execution_time
    max_input_time

    Or the limit values for POST and other limits?
     
  15. crazysky

    crazysky New Member

    I have default values.

    Code:
    less /etc/php5/cgi/php.ini | grep default_socket_timeout
    default_socket_timeout = 60
    [email protected]:~# less /etc/php5/cgi/php.ini | grep max_execution_time
    max_execution_time = 30
    [email protected]:~# less /etc/php5/cgi/php.ini | grep max_input_time
    ; max_input_time
    max_input_time = 60
    [email protected]:~# less /etc/php5/cgi/php.ini | grep max_input_time
    ; max_input_time
    max_input_time = 60
    [email protected]:~# less /etc/php5/cgi/php.ini | grep max_input_time
    ; max_input_time
    max_input_time = 60
     
  16. crazysky

    crazysky New Member

  17. till

    till Super Moderator Staff Member ISPConfig Developer

    No, thats optional. It is just recommended to use a php cache in general to speed up your websites. If your joomla version is not compatible with xcache, then you might want to report that to the joomla devs as xcache is a widely used caching system.

    You can either uninstall xcache or try to replace it with apc.
     
  18. Curtis Maurand

    Curtis Maurand New Member

    Hello, I just encountered the same problem. php5-xcache was the culprit. I removed it and the Joomla site started working.
     

Share This Page