Cant start ISPConfig after dist-upgrade

Discussion in 'Installation/Configuration' started by cz-petrik, Mar 21, 2017.

  1. cz-petrik

    cz-petrik New Member

    Hi, can you help me with this big problem? Yesterday I upgrade my Debian from Wheezy on Jessie but ISPConfig not running, in etc/init.d/ I dont have ispconfig_server file, ispconfig is installed in dir usr/local/ispconfig/ , there in dir server is script server.sh, but if I run it wrote only Finished. After server restart I can connect on server with SSH, web with FTP, roundcube url works but pages & ispconfig not working. primary page on this server is eds.cz with roundcube url eds.cz/webmail


    Tue Mar 21 09:45:01 CET 2017
    Tue Mar 21 09:45:01 CET 2017
    Tue Mar 21 09:45:01 CET 2017 tabule1 does not exceed quota qize: 0 > 5781895
    Tue Mar 21 09:45:01 CET 2017 finished.
    Tue Mar 21 09:45:01 CET 2017 table2 does not exceed quota qize: 0 > 4358144
    Tue Mar 21 09:45:01 CET 2017 cucak does not exceed quota qize: 0 > 3293184
    Tue Mar 21 09:45:01 CET 2017 vter does not exceed quota qize: 0 > 19837
    Tue Mar 21 09:45:01 CET 2017 g2iop does not exceed quota qize: 0 > 638976
    Tue Mar 21 09:45:01 CET 2017 btres does not exceed quota qize: 0 > 11239424
    Tue Mar 21 09:45:01 CET 2017 tabjhf does not exceed quota qize: 0 > 4255888
    Tue Mar 21 09:45:01 CET 2017 uztre does not exceed quota qize: 0 > 4046848
    Tue Mar 21 09:45:01 CET 2017 c1c1 does not exceed quota qize: 0 > 127460
    Tue Mar 21 09:45:01 CET 2017 c2c3 does not exceed quota qize: 0 > 1024
    Tue Mar 21 09:45:01 CET 2017 grust does not exceed quota qize: 0 > 58468
    Tue Mar 21 09:45:01 CET 2017 8uztre does not exceed quota qize: 0 > 32768
    Tue Mar 21 09:45:01 CET 2017 bustewr does not exceed quota qize: 0 > 274569
    Tue Mar 21 09:45:01 CET 2017 kaps does not exceed quota qize: 0 > 4571136
    Tue Mar 21 09:45:02 CET 2017 /usr/bin/fail2ban-client
    Tue Mar 21 09:45:02 CET 2017 /sbin/iptables
    Tue Mar 21 09:45:02 CET 2017 /sbin/ip6tables
    Tue Mar 21 09:46:01 CET 2017
    Tue Mar 21 09:46:01 CET 2017

    Please help :) THX
     

    Attached Files:

  2. cz-petrik

    cz-petrik New Member

    Thank for you help
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig has no scripts in /etc/init.d and ISPConfig neither needs to be started nor restarted. ISPConfig is a website vhost in apache / nginx and gets started when you start apache or nginx. You seem to mix up ISPConfig 2 and 3 here btw, as the old ispconfig 2 had such a server script.
     
  4. cz-petrik

    cz-petrik New Member

    Thanks for your reply, i look on google and found how to start|restart|stop ISPConfig with script etc/init.d/ispconfig_server.sh, therefore I wrote about it.
    Apache2 works fine, problem must be in nginx :)

    # systemctl status nginx.service
    ‚óŹ nginx.service - A high performance web server and a reverse proxy server
    Loaded: loaded (/lib/systemd/system/nginx.service; enabled)
    Active: failed (Result: exit-code) since Tue 2017-03-21 11:12:35 CET; 32s ago
    Process: 6644 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=1/FAILURE)
    Process: 6641 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)

    Mar 21 11:12:33 server1.eds.cz nginx[6644]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
    Mar 21 11:12:33 server1.eds.cz nginx[6644]: nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
    Mar 21 11:12:34 server1.eds.cz nginx[6644]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
    Mar 21 11:12:34 server1.eds.cz nginx[6644]: nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
    Mar 21 11:12:34 server1.eds.cz nginx[6644]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
    Mar 21 11:12:34 server1.eds.cz nginx[6644]: nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
    Mar 21 11:12:35 server1.eds.cz nginx[6644]: nginx: [emerg] still could not bind()
    Mar 21 11:12:35 server1.eds.cz systemd[1]: nginx.service: control process exited, code=exited status=1
    Mar 21 11:12:35 server1.eds.cz systemd[1]: Failed to start A high performance web server and a reverse proxy server.
    Mar 21 11:12:35 server1.eds.cz systemd[1]: Unit nginx.service entered failed state.

    EDIT: now, if I try to visit url eds.cz, browser is redirected to /var/www/html/ dir
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not have apache and nginx at the same time on an ISPConfig system. if you have a nginx server, then stop apache and start nginx.
     
  6. cz-petrik

    cz-petrik New Member

    my bad, I stay at apache2 server... Now ISPConfig and all webs with roundcube works good
    Many thanks for all
     
    Last edited: Mar 21, 2017

Share This Page