Can't start apache, virtualhosts problem.

Discussion in 'Installation/Configuration' started by Xinil, May 30, 2007.

  1. Xinil

    Xinil New Member

    I've looked through the dozens of threads here and I just can't find what will fix this problem. I cannot get apache to start no matter what type of configuration I do. The install worked fine and everything was going great, but apparently I did something (no idea) and now it won't start any more.

    I try to start apache and this happens:

    Changed around a few things and I started getting this:
    Changed around some more and now I don't get any errors, just a failed:
    Any help would be appreciated. Here's what my Vhosts_ispconfig.conf contains:

    My server can be accessed at: dedicated145.krypt.com.
    IP: 66.186.60.50

    www.gysslerenterprises.com is where it's supposed to be online too. I guess I'm somewhat confused about what should be going in the:

    Hostname:
    Domain:
    IP Address:
    IP List:

    Right now, I have:
    Hostname: dedicated145
    Domain: krypt.com
    IP Address: 127.0.0.1
    IP List: 66.186.60.50

    --

    I've changed all those around to different things too in an attempt to fix it.

    Thanks in advance.
     
    Last edited: May 30, 2007
  2. TheMaximumWeasel

    TheMaximumWeasel New Member

    Are there any Virtual host entries in your httpd.conf file? Also is the NameVirtualHost 66.186.60.50:80 in httpd.conf I dont see it in your ispconfig's vhost file.

    Max
     
  3. Xinil

    Xinil New Member

  4. Xinil

    Xinil New Member

    Tried adding in:

    Neither worked. I still get errors like:

     
    Last edited: May 30, 2007
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    - Have you created a website in ISPConfig?
    - Is the file /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf empty?
     
  6. Xinil

    Xinil New Member

    Hi till, thanks for the response.

    I've created two websites.

    The /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf file isn't empty either. I've listed the contents of that file in my first post.

    Thanks.
     
  7. Xinil

    Xinil New Member

  8. falko

    falko Super Moderator ISPConfig Developer

    Yes, ISPConfig comes with its own Apache on port 81 so that you can still access ISPConfig even if the main Apache fails (like in your case).

    Why do you use 127.0.0.1 for your virtual hosts? That way, nobody can access your web sites...
    What's the output of
    Code:
    ifconfig
    ?
     
  9. Xinil

    Xinil New Member

    Thanks for the response falko, I appreciate it. I wiped my previous install and reinstalled everything. It's all fine now. No idea what was wrong in my previous config. Thanks for the help!

    I'm using my IP instead of 127.0.0.1 now too. Thanks.
     
  10. JRue

    JRue New Member

    I'm having the same issue as Xinil. Getting the same error.

    Everthing was working fine until we moved data centers.
    Now all of a sudden my virtualhost entries are overlapping? wtf?

    Note, I am using my external IP in the VirtualHost Directive.

    All my VirtualHost Directives are in /etc/apache2/vhosts/Vhosts_ispconfig.conf as I believe they should be.

    I changed the IP in Vhosts_ispconfig.conf last night and I think it changed back to the old address this morning....Wierd....


    There are no VirtualHost or NameVirtualHost entries in httpd.conf. Nor is there a NameVirtualHost directive in Vhosts_ispconfig.conf

    Code:
    # Include the virtual host configurations:
    Include /etc/apache2/sites-enabled/[^.#]*
    
    This directive in apache2.conf is confusing me...and it refers to file /etc/apache2/sites-enabled/default which has both NameVirtualHost *
    and <VirtualHost *>
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Not at all. Never change the file Vhosts_ispconfig.conf manually!

    Instead of changing the file, change the IP in ISPConfig under management > server > settings, then open every website settings, make sure that the correct IP is selected and click on the save button.
     

Share This Page