Can't send mails only to hotmail

Discussion in 'Installation/Configuration' started by sulfuric, Mar 28, 2007.

  1. sulfuric

    sulfuric ISPConfig Developer

    This is the mail delivery error:

    xxxx2hotmail.com: host mx1.hotmail.com[65.54.244.136] said: 550 Your
    e-mail was rejected for policy reasons on this gateway. Reasons for
    rejection may be related to content such as obscene language, graphics, or
    spam-like characteristics (or) other reputation problems. For sender
    troubleshooting information, please go to http://postmaster.msn.com.
    Please note: if you are an end-user please contact your E-mail/Internet
    Service Provider for assistance. (in reply to MAIL FROM command)

    yahoo, gmail and other services works fine.

    Some body has this problem before??

    Thanks
     
  2. iovo

    iovo New Member

    I've similar problem

    hello sulfuric,
    I've problems with hotmail too.

    Can't send mails only to hotmail, and strange is that my e-mail do not delivey to hotmail mailbox. I have no problems with gmail and yahoo. I'm seting and spf record. I thin that everithyng is ok, but for hotmail not.

    ...and onother strange thing....
    When i replay to a hotmail message, my e-mail is delivered!!!!!!

    Here is may mail log.
    Mar 28 19:56:37 maria postfix/smtp[27081]: 9AA092507C: to=<xxxxxx@hotmail.com>, relay=mx4.hotmail.com[65.54.245.104], delay=2, status=sent (250 <2960.xx.xx.xx.xxx.1175104595.squirrel@mail.domain.com> Queued mail for delivery)
    Mar 28 19:56:37 maria postfix/qmgr[17881]: 9AA092507C: removed

    If someone can help, pleace help
    Thank You!
     
    Last edited: Mar 28, 2007
  3. sulfuric

    sulfuric ISPConfig Developer

    Please, post your delivery system mail.
     
  4. iovo

    iovo New Member

    here is delivery

    Mar 28 21:04:46 maria postfix/smtpd[10327]: connect from bay0-omc3-s7.bay0.hotmail.com[65.54.246.207]
    Mar 28 21:04:47 maria postfix/smtpd[10327]: 33CF12472A: client=bay0-omc3-s7.bay0.hotmail.com[65.54.246.207]
    Mar 28 21:04:47 maria postfix/cleanup[10331]: 33CF12472A: message-id=<BAY13-F206EB403934D43971E4B69BD6D0@phx.gbl>
    Mar 28 21:04:47 maria postfix/qmgr[17881]: 33CF12472A: from=<xxxxx@hotmail.com>, size=1219, nrcpt=1 (queue active)
    Mar 28 21:04:47 maria postfix/smtpd[10327]: disconnect from bay0-omc3-s7.bay0.hotmail.com[65.54.246.207]
    Mar 28 21:04:48 maria postfix/pickup[3217]: 6A0A624F51: uid=10003 from=<xxxxxxx>
    Mar 28 21:04:48 maria postfix/cleanup[10331]: 6A0A624F51: message-id=<20070328190447.6A0A624F51@mail.domain.com>
    Mar 28 21:04:48 maria postfix/qmgr[17881]: 6A0A624F51: from=<xxxxxxx@mail.domain.com>, size=383, nrcpt=1 (queue active)
    Mar 28 21:04:48 maria postfix/local[10351]: 6A0A624F51: to=<admispconfig@localhost.localdomain>, relay=local, delay=1, status=sent (delivered to command: /usr/bin/procmail -f-)
    Mar 28 21:04:48 maria postfix/qmgr[17881]: 6A0A624F51: removed
     
    Last edited: Mar 28, 2007
  5. iovo

    iovo New Member

    look at this:

    Mar 28 21:08:38 maria postfix/anvil[10329]: statistics: max connection count 1 for (smtp:65.54.246.207) at Mar 28 21:04:46
    Mar 28 21:08:38 maria postfix/anvil[10329]: statistics: max cache size 2 at Mar 28 21:05:15
    What is that?
     
  6. edge

    edge HowtoForge Supporter

    Thats the IP addres of "bay0-omc3-s7.bay0.hotmail.com"


    Small quote from an email that I got some time ago from Hotmail.
    So.. basically you WILL need to contact the Hotmail team (it's called Windows Live Hotmail Domain Support), and ask if they add your domain to the SenderID program!

    More info: http://postmaster.live.com/
    When you are 100% sure that all is setup okay, use this form and ask if they add your domain to the SenderID program
     
  7. lordg

    lordg New Member


    I have the exact same problem! I cannot send emails to a hotmail address, however if I reply to a hotmail message, it gets delivered successfully.

    Weird isn't it? Did you manage to correct this problem yet?
     
  8. till

    till Super Moderator

    Did you do everything that edge described?
     
  9. lordg

    lordg New Member

    No I didn't. I was just wondering if the OP got it fixed.

    How do I check my SMTP logs? Is it in my cPanel?
     
  10. till

    till Super Moderator

    Your mail log(s) are in the folder /var/log/ and the mail logfile is name mail, maillog, mail.log or similar. To view the logfile, you may use the command:

    tail /path/to/your/logfile
     
  11. fraginhell

    fraginhell New Member

    hotmail have got very stricked rules about who can and cannot send mail to them, normally they don't like dhcp addresses etc etc. I had the same problem using a dhcp address even though my DNS names etc where up to date. I use a n SPF record for my domain which works fine, I have since updated to a static IP but you still need an SPF record (Sender Policy Framework)
     
  12. djantz

    djantz New Member

    This problem is spreading quite quickly. I too can reply, but not send emails to hotmail. What are they thinking?!?! I did publish a SenderID, but who knows how long that will take to be in effect, or if it will even correct the problem.

    Anybody find a definite solution yet?
     
  13. danf.1979

    danf.1979 ISPConfig Developer

    Yup, I'm experiencing the same problem. :(
     
  14. till

    till Super Moderator

    I'am wondering when the first poeple will start leaving hotmail because they dont get any mail...

    I think there is not much that can be done from our side to solve the problem except of creating spf records for the domains and join SenderID :(
     
  15. falko

    falko Super Moderator

    On the other side... I don't now anyone with a Hotmail account... ;)
     
  16. lordg

    lordg New Member

    Ok, I created a SPF record. How long will I have to wait before I can start sending emails to Hotmail, if this even works at all...
     
  17. danf.1979

    danf.1979 ISPConfig Developer

    The spf should work right away lordg...



    ....................

    Is this spf record good enough?

    domain.tld. TXT "v=spf1 a mx ~all"
     
  18. lordg

    lordg New Member

    Last edited: Apr 5, 2007
  19. fraginhell

    fraginhell New Member

    Mine is "v=spf1 a mx -all".
    I assume you can lookup your dns entry and reverse look it up too?
     
  20. falko

    falko Super Moderator

    It can take up to 72 hours until DNS changes propagate.
     

Share This Page