Can't send mail from ISPConfig box

Discussion in 'Installation/Configuration' started by demortes, May 20, 2007.

  1. demortes

    demortes New Member

    Greetings,

    I'll attempt to explain this as best as possible. I have two domain names. fireflythemud.com and serenity-tech.com which all host their sites fine, I received email outside of the network fine.

    Here's the kicker, any email sent from the box will not be received. I've narrowed down the reason. Simply put, my ISP is blocking all outgoing SMTP (port 25) traffic, except for their own mail servers traffic. This means that I can receive on port 25, but I can't send on port 25.

    My question is this. Is there ANY way I can have the capability of receiving mail through the mail server box I host, and send mail through the ISP's mail server. Perhaps a configuration of sorts? What might make it more complicated is I have to authenticate all outgoing mail with my ISP with my ISP user name and password(optional, but preferred).

    Thank you for the attention, hope to hear from you in the morning.

    Demortes
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It is possible to configure your postfix mail server to relay all emails trough the smtp server of your ISP with authentication. There must be some posts about this in the forum but I can not find them currently. Maybe someone else has the links at hand :)
     
  3. demortes

    demortes New Member

    I think it's fixed... or was.

    I tried searching the internet and didn't find anything. I posted here, which Till responded. I never tried the word relay in the search engines... I tried it today, and I found the variable needed, relayhost in main.cf (in my setup, /etc/postfix/main.cf). It didn't explain how to set up authentication for the relay host though.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. demortes

    demortes New Member

    OK, that fixed that, but for some reason when I send mail to a user on my domain, it delivers it locally, not the assigned mail server. I mean, I have it set up for google apps, which maintain my email on both domains. I set up ISPConfig to point to External Mailserver, and it's still delivering locally.

    Any insight?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you set all co-domains to external mailserver too and not only the website.
     
  7. demortes

    demortes New Member

    I have set all domains, co domains, everything as external. I only have the two domains, no sub domains, etc.
     
  8. demortes

    demortes New Member

    Any further ideas?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the domain still listed in the file /etc/postfix/local-host-names ?
     
  10. demortes

    demortes New Member

    Yes, it was. I removed it yesterday, sorry for not posting back. That took care of the issue. Thank you.
     
  11. demortes

    demortes New Member

    well, I deleted it from local-host-names... it recreates it upon any change in ISPConfig...

    How do I prevent it? External mailserver is set on everything. Please, help me.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    is the domain identical with the hostname of your server, the one that you get with the command:

    hostname

    or

    hostname -f
     
  13. demortes

    demortes New Member

    web1_kdethlefs@stserver:/etc/postfix$ hostname
    stserver.serenity-tech.com

    web1_kdethlefs@stserver:/etc/postfix$ hostname -f
    stserver.serenity-tech.com

    But why would that add fireflythemud.com?
     
  14. demortes

    demortes New Member

    web1_kdethlefs@stserver:/etc/postfix$ dnsdomainname
    serenity-tech.com
     
  15. demortes

    demortes New Member

    Any ideas?
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then fireflythemud.com is a co-domain of one of your websites. Open this co-domain and set it to external mailserver under options (I'am reading about the options of the co-domain, not the options of the website!).
     
  17. demortes

    demortes New Member

    As I have previously stated. Every domain, every item that has anything pointing to it, is set to external mail server. I don't understand the difference between domain and co-domain, but I do know that the domains I do have are set to be hosted by two seperate accounts, and are set both to external mailserver, since both use google Apps.
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Please execute the following SQL statement in your ISPConfig database (e.g. with phpmyadmin) and post the result:

     
  19. demortes

    demortes New Member


    Unneeded. I found my problem and I ought to be shot. Co-Domains is an actual setting in ISPConfig... I decided that I would check all settings, just to be sure I didn't miss it. Low and behold, there is a... *gasp* Co-domains tab. I clicked on each domain, clicked their only entries, and options, changed it to External Mailserver, like you told me in the first place. Problem solved. I really apologize Till, I know I was being a pain in the butt.

    Thank you for your help.
     

Share This Page