can't send local emails 2

Discussion in 'ISPConfig 3 Priority Support' started by jpcyrenne, Nov 26, 2013.

  1. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Good Day,

    New install on a new server and I seem to have a dovecot config problem?

    Followed the Perfect Install on CentOS 6.4
    # yum install dovecot dovecot-mysql
    # chkconfig --levels 235 dovecot on
    # /etc/init.d/dovecot start

    Installed ISPConfig 3

    # cd /etc/dovecot
    # mv dovecot.conf dovecot.conf_orig
    # ln -s ../dovecot.conf dovecot.conf
    # /etc/init.d/dovecot restart

    I get an error at restart. It can't stop the service because it can't launch.

    $ dovecot -n
    # 2.0.9: /etc/dovecot/dovecot.conf
    doveconf: Fatal: open(/etc/dovecot/dovecot.conf) failed: Too many levels of symbolic links (copy example configs from /usr/share/doc/dovecot-2.0.9/example-config/)

    Is this a simlink issue? never got this error before?

    Till once sent me a few commands to fix a sending issue and I get the same error:
    $ ln -s /etc/dovecot/dovecot.conf /etc/dovecot.conf
    ln: accessing `/etc/dovecot.conf': Too many levels of symbolic links

    Thanks ahead,

    JP
     
  2. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Fixed the simlik error by rewriting the /etc/dovecot.conf (whih was a simlink to the /etc/dovecot/dovecot.conf


    *** Still having sending issue. Not sure if it's a FQND error? A postfix network config?

    Nov 26 16:12:08 cl-t079-237cl postfix/pickup[5647]: 84024268091C: uid=0 from=<root>
    Nov 26 16:12:08 cl-t079-237cl postfix/cleanup[9962]: 84024268091C: message-id=<20131126211208.84024268091C@cl-t079-237cl.privatedns.com>
    Nov 26 16:12:08 cl-t079-237cl postfix/qmgr[5648]: 84024268091C: from=<root@cl-t079-237cl.privatedns.com>, size=471, nrcpt=1 (queue active)
    Nov 26 16:12:08 cl-t079-237cl postfix/smtp[9966]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Nov 26 16:12:08 cl-t079-237cl postfix/smtp[9966]: 84024268091C: to=<jp@officebookie.com>, relay=none, delay=0.12, delays=0.12/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Nov 26 16:15:01 cl-t079-237cl dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
    Nov 26 16:15:01 cl-t079-237cl postfix/smtpd[10206]: connect from localhost[::1]
    Nov 26 16:15:01 cl-t079-237cl postfix/smtpd[10206]: lost connection after CONNECT from localhost[::1]
    Nov 26 16:15:01 cl-t079-237cl postfix/smtpd[10206]: disconnect from localhost[::1]
    Nov 26 16:15:01 cl-t079-237cl dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
    Nov 26 16:15:23 cl-t079-237cl postfix/smtpd[10206]: connect from localhost[::1]
    Nov 26 16:15:23 cl-t079-237cl postfix/smtpd[10206]: warning: table "mysql:/etc/postfix/mysql-virtual_client.cf": empty query string -- ignored
    Nov 26 16:15:23 cl-t079-237cl postfix/smtpd[10206]: F0031268091D: client=localhost[::1]
    Nov 26 16:15:23 cl-t079-237cl postfix/cleanup[10265]: F0031268091D: message-id=<20131126204353.C34FF2680915@cl-t079-237cl.privatedns.com>
    Nov 26 16:15:24 cl-t079-237cl postfix/qmgr[5648]: F0031268091D: from=<mailman-loop@cl-t079-237cl.privatedns.com>, size=4580, nrcpt=1 (queue active)
    Nov 26 16:15:24 cl-t079-237cl postfix/smtpd[10206]: disconnect from localhost[::1]
    Nov 26 16:15:24 cl-t079-237cl postfix/smtp[10266]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Nov 26 16:15:24 cl-t079-237cl postfix/smtp[10266]: F0031268091D: to=<mailman@qctopmail.com>, relay=none, delay=0.09, delays=0.09/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

    No port 10024 as mentionned above ?
    $ netstat -nltp
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 5645/master
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 3177/mysqld
    tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 9609/dovecot
    tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 9609/dovecot
    tcp 0 0 184.107.14.103:53 0.0.0.0:* LISTEN 3492/named
    tcp 0 0 184.107.14.102:53 0.0.0.0:* LISTEN 3492/named
    tcp 0 0 184.107.14.101:53 0.0.0.0:* LISTEN 3492/named
    tcp 0 0 184.107.14.100:53 0.0.0.0:* LISTEN 3492/named
    tcp 0 0 67.205.102.108:53 0.0.0.0:* LISTEN 3492/named
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 3492/named
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 3356/pure-ftpd (SER
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1528/sshd
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 5645/master
    tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 3492/named
    tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 9609/dovecot
    tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 9609/dovecot
    tcp 0 0 :::110 :::* LISTEN 9609/dovecot
    tcp 0 0 :::143 :::* LISTEN 9609/dovecot
    tcp 0 0 :::8080 :::* LISTEN 4133/httpd
    tcp 0 0 :::80 :::* LISTEN 4133/httpd
    tcp 0 0 :::8081 :::* LISTEN 4133/httpd
    tcp 0 0 :::53 :::* LISTEN 3492/named
    tcp 0 0 :::21 :::* LISTEN 3356/pure-ftpd (SER
    tcp 0 0 :::22 :::* LISTEN 1528/sshd
    tcp 0 0 :::25 :::* LISTEN 5645/master
    tcp 0 0 ::1:953 :::* LISTEN 3492/named
    tcp 0 0 :::443 :::* LISTEN 4133/httpd
    tcp 0 0 :::993 :::* LISTEN 9609/dovecot
    tcp 0 0 :::995 :::* LISTEN 9609/dovecot
     
  3. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    A new trace. There is one thing I did not do like last time : I did not install amavisd and clam because it is a mass mailer... I didn't want to install it to remove it.

    Where would I go to change 10024 to I guess 10025?


    JP
     
  4. jhewit

    jhewit New Member

    Dovecot doesn't look like your issue, I had the same issue on CentOS. It was a configuration error with postfix. Have you done this:

    Open vi /etc/postfix/master.cf

    And uncomment the "submission" and "smtps" entries

    See for details: http://www.howtoforge.com/forums/showthread.php?t=63794&highlight=postfix&page=2

    Also some servers may reject e-mail from your server if you do not have your hostname configured correctly, and/or reverse PTR. All of which are issues I just had to get help with on my system (CentOS 6.4). Let me know if you got anymore questions I'll try and help.

    See all my questions and help from till: http://www.howtoforge.com/forums/showthread.php?t=64090
     
  5. jhewit

    jhewit New Member

  6. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Thanks for the tips Jhewit,

    I did change the hostname to a FQDN that has RDNS working. Removed the commented lines you mentioned in Postfix, restarted and I still have my problem.

    Thinking of reinstalling ISPConfig and regenerating new RSA cert.

    JP
     
  7. jhewit

    jhewit New Member

    A few questions that I'm curious about:

    1. How are you trying to send the e-mail (Web Form, Webmail, E-mail Client)?
    2. What type of authentication are you selecting for the connect?

    And honestly in my opinion re-installing ISPCONFIG won't solve the issues, you'll be starting from scratch without truly finding the problem.
    I'm always happy to help, I love ISPCONFIG.
     
  8. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    I reinstalled (php -q update.php), reinitialized everything and you're right, didn't work!

    I also went to correct my myhostname= in Postfix. reloaded postfix. Still no success.

    FQDN : mailx.gagnantminute.ca

    I use shell mail (mailx package)
    # mail jp@officebookie.com (it works well on another server CentOS6.4)

    tail -f /var/log/maillog:
    Nov 26 17:31:32 mailx postfix/pickup[5039]: DB4CF2680933: uid=0 from=<root>
    Nov 26 17:31:32 mailx postfix/cleanup[5842]: DB4CF2680933: message-id=<20131126223132.DB4CF2680933@mailx.gagnantminute.ca>
    Nov 26 17:31:32 mailx postfix/qmgr[5040]: DB4CF2680933: from=<root@mailx.gagnantminute.ca>, size=449, nrcpt=1 (queue active)
    Nov 26 17:31:32 mailx postfix/smtp[5846]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Nov 26 17:31:33 mailx postfix/smtp[5846]: DB4CF2680933: to=<jp@officebookie.com>, relay=none, delay=0.18, delays=0.17/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

    I get a connexion refused : [127.0.0.1]:10024: Connection refused

    I have no port 10024 running. Only 10025

    $ netstat -nltp
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 5032/master
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 4929/mysqld
    tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN 5032/master
    tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 5071/dovecot
    tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 5071/dovecot
    tcp 0 0 0.0.0.0:465 0.0.0.0:* LISTEN 5032/master
    tcp 0 0 184.107.14.103:53 0.0.0.0:* LISTEN 5149/named
    tcp 0 0 184.107.14.102:53 0.0.0.0:* LISTEN 5149/named
    tcp 0 0 184.107.14.101:53 0.0.0.0:* LISTEN 5149/named
    tcp 0 0 184.107.14.100:53 0.0.0.0:* LISTEN 5149/named
    tcp 0 0 67.205.102.108:53 0.0.0.0:* LISTEN 5149/named
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 5149/named
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 5122/pure-ftpd (SER
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1526/sshd
    tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 5149/named
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 5032/master
    tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 5071/dovecot
    tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 5071/dovecot
    tcp 0 0 :::587 :::* LISTEN 5032/master
    tcp 0 0 :::110 :::* LISTEN 5071/dovecot
    tcp 0 0 :::143 :::* LISTEN 5071/dovecot
    tcp 0 0 :::8080 :::* LISTEN 5098/httpd
    tcp 0 0 :::80 :::* LISTEN 5098/httpd
    tcp 0 0 :::8081 :::* LISTEN 5098/httpd
    tcp 0 0 :::465 :::* LISTEN 5032/master
    tcp 0 0 :::53 :::* LISTEN 5149/named
    tcp 0 0 :::21 :::* LISTEN 5122/pure-ftpd (SER
    tcp 0 0 :::22 :::* LISTEN 1526/sshd
    tcp 0 0 ::1:953 :::* LISTEN 5149/named
    tcp 0 0 :::25 :::* LISTEN 5032/master
    tcp 0 0 :::443 :::* LISTEN 5098/httpd
    tcp 0 0 :::993 :::* LISTEN 5071/dovecot
    tcp 0 0 :::995 :::* LISTEN 5071/dovecot
     
  9. jhewit

    jhewit New Member

    This may sound silly, but have you attempted sending an email with webmail or other method to see if maybe you just need to add an and open another port for postfix?

    Also your myhostname should be set to the hostname of your server. (if your used the guide it's exampe was server1.domain.com), and your mydomain should equal domain.com basically the primary domain that governs your server host name...

    myhostname=hostname5.domain.com
    mydomain=domain.com

    Also have you setup the DNS Zone information in ISPCONFIG for the primary domain?
     
  10. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Thanks. I'll set the domain. I didn't think I had to set domain if mydomain was set?

    I installed the 'Amavisd-new, SpamAssassin And ClamAV', port 10024 appeared and it started working...

    netstat:
    tcp 0 0 127.0.0.1:10024 0.0.0.0:* LISTEN 10834/amavisd (mast

    The thing is I want to run a Mass Mailer and don't want to filter 500K OUTBOUND emails a day. Maybe this can be disabled for outbound?

    I will try this uninstall (recommended by Till) without removing amavisd (port 10024)
    http://www.faqforge.com/linux/contr...ilter-and-antivirus-functions-in-ispconfig-3/

    Might get to use amavisd with DKIM:
    http://www.faqforge.com/linux/how-to-enable-dkim-email-signatures-in-amavisd-new-and-ispconfig-3/

    We'll see what happens...

    JP
     
  11. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Thanks for the support Jhewit. Nice not to feel alone when things aren't working the way we expect.

    ---Problem solved---

    Finally, All I had to do is read this right from the begining:

    Edit postfix main.cf file
    vi /etc/postfix/main.cf
    and comment out these lines by adding a “#” in front of them:
    # content_filter = amavis:[127.0.0.1]:10024
    # receive_override_options = no_address_mappings

    from the site I mentioned:
    http://www.faqforge.com/linux/contr...ilter-and-antivirus-functions-in-ispconfig-3/

    Solved my port 10024 issue.

    Maybe set when ISPConfig script runs??? Not a setting I configured.

    Thanks again,

    JP
     
  12. jhewit

    jhewit New Member

    Anytime happy to help where I can :)
     

Share This Page