Can't send external emails, can receive both internal and external

Discussion in 'General' started by spacepills, May 27, 2016.

  1. spacepills

    spacepills Member

    Hi,
    So my situationist is a bit frustrating,
    I've just set up a new multiserver on ubuntu 14.04 and everying is good, except, sending to a domain that is on a different server
    May 27 04:31:27 vps5 postfix/smtpd[23024]: connect from localhost[127.0.0.1]
    May 27 04:31:27 vps5 postfix/smtpd[23024]: D9C9C1481457: client=localhost[127.0.0.1]
    May 27 04:31:27 vps5 postfix/cleanup[23020]: D9C9C1481457: message-id=<[email protected]>
    May 27 04:31:27 vps5 postfix/qmgr[17056]: D9C9C1481457: from=<[email protected]>, size=2533, nrcpt=1 (queue active)
    May 27 04:31:27 vps5 postfix/smtpd[23024]: disconnect from localhost[127.0.0.1]
    May 27 04:31:27 vps5 amavis[27325]: (27325-10) Passed CLEAN {RelayedOpenRelay}, [x.x.x.x]:51862 [x.x.x.x] <[email protected]> -> <[email protected]>, Queue-ID: 6AF7D148142F, Message-ID: <[email protected]>, mail_id: RZiV4q2q-w5h, Hits: 0.793, size: 2075, queued_as: D9C9C1481457, 378 ms
    May 27 04:31:27 vps5 postfix/smtp[23021]: 6AF7D148142F: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.53, delays=0.14/0.01/0.01/0.38, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as D9C9C1481457)
    May 27 04:31:27 vps5 postfix/qmgr[17056]: 6AF7D148142F: removed
    May 27 04:31:27 vps5 dovecot: lda([email protected]): sieve: msgid=<[email protected]>: stored mail into mailbox 'INBOX'
    May 27 04:31:27 vps5 postfix/pipe[23025]: D9C9C1481457: to=<[email protected]>, relay=dovecot, delay=0.05, delays=0.02/0.01/0/0.02, dsn=2.0.0, status=sent (delivered via dovecot service)
    May 27 04:31:27 vps5 postfix/qmgr[17056]: D9C9C1481457: removed

    outdomain is the server the mail is (trying to) be sent from and indomain is another server I have set up with ispconfig working perfectly fine
    I can send and receive emails to an email address on the same outdomain with no problem, I can also receive emails from any domain, I can't however send an email to any address that isn't on the same server..

    Also a weird thing, is that the mail log isn't going to /var/log/mail.log it's going into the syslog

    something is real weird here and I'm baffled..

    Thanks
     
    Last edited: May 27, 2016
  2. Jesse Norell

    Jesse Norell Active Member

    That's local delivery succeeding, your server is configured with indomain.co.uk, which is why it won't deliver to the external server (if I understand your problem description correctly).

    If you can't send to *any* other domain, then perhaps your default transport is set wrong, what does this show:
    Code:
    postconf default_transport
    and what do you have set in ISPConfig under Email > Email Routing?

    That's your syslog configuration, you'll need to determine what syslog system you're using (I think rsyslog is the default on debian nowadays) and check it's config (eg. /etc/rsyslog.conf and /etc/rsyslog.d/* for rsyslog).
     

Share This Page