Can't send emails with newer version of Postfix

Discussion in 'General' started by PepinCZ, May 31, 2016.

  1. PepinCZ

    PepinCZ New Member

    Hello,
    I'm running CentOS7. All stuff was great and working, but then postfix was updated and now I'm unable to send emails. I have currently installed Postfix 2.10.1.
    Because I did not find a way how to use code tag, I uploaded log & configs on Pastebin.

    This is log I'm getting it /var/log/maillog when I'm sending email:
    http://pastebin.com/e4e19721

    Of course the example.tld domain & [email protected] is in ISPConfig. (I faked them because I don't want spam...)

    This is my Postfix main.cf configuration file @ /etc/postfix/main.cf:
    http://pastebin.com/UMngkq35
    This is my Postfix master.cf configuration file @ /etc/postfix/master.cf:
    http://pastebin.com/c363dx0J
    And in case Amavisd is also problem, there is Amavisd configuration file @ /etc/amavisd/amavisd.conf (I have it symlinked on /etc/amavisd.conf)
    http://pastebin.com/1yE8kAzJ

    Thank you.
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Remove the marked parts from smtpd_helo_restrictions = permit_sasl_authenticated, permit_mynetworks, check_helo_access regexp:/etc/postfix/helo_access, reject_invalid_hostname, reject_non_fqdn_hostname, check_helo_access regexp:/etc/postfix/blacklist_helo and restart postfix
     
  3. PepinCZ

    PepinCZ New Member

    Ok, So I deleted the smtpd_helo_restrictions line, however I have still same problem.
    //EDIT: After I readed my respond I finaly saw the marked parts (they are not visible in normal reply), so I deleted them, but still the same problem.
     
    Last edited: May 31, 2016
  4. PepinCZ

    PepinCZ New Member

    Can somebody help me please?
     
  5. Jesse Norell

    Jesse Norell Active Member

    What version of ispconfig, guessing 3.1, or did you follow a postfix hardening guide for 3.0.5.4? Did you re-run the ISPConfig installer (ie. update.php) after updating postfix? Things seemed to be mixed up and missing in your config.

    Your immediate problem appears to be twofold, 1) the complete absence of smtpd_recipient_restrictions, including the necessary
    Code:
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
    which must be on both port 10025 and port 10027 entries in master.cf; and 2) get rid of the
    Code:
    content_filter = amavis:[127.0.0.1]:10024
    line in main.cf, the proper content filter will be specified by tag_as_originating.re and tag_as_foreign.re in smtpd_sender_restrictions.

    Less critical issues:

    Looks like you have an error in helo_access, what does it contain? It won't matter if you really did remove smtpd_helo_restrictions, but should be looked at if you restore that. It's also bypassed for sasl authenticated connections (which your example was), so again this is not your problem, but....

    is caused by this in main.cf:
    Code:
    sender_bcc_maps = mysql:/etc/postfix/mysql-virtual_outgoing_bcc.cf
    The ispconfig installer should create that file (mysql-virtual_outgoing_bcc.cf), so I'm guessing you just need to run the ispconfig update.php.
     

Share This Page