Can't send emails [edit: not related to Migration Tool]

Discussion in 'Plugins/Modules/Addons' started by axxies, Jun 12, 2016.

  1. axxies

    axxies Member

    Yes, I have tried to send to both Gmail and Live addresses, same results. Now it works to receive emails from outside.

    In order to avoid email harvester bots, I have altered the email addresses in the below log output :

    <snip>

    Jun 15 13:41:29 [my-host] postfix/smtpd[3968]: connect from localhost[127.0.0.1]
    Jun 15 13:41:29 [my-host] postfix/smtpd[3968]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 550 5.1.1 <[[email protected]]>: Recipient address rejected: [mylocaldomain]; from=<[[email protected]]> to=<[[email protected]]> proto=ESMTP helo=<[my-host].startdedicated.net>
    Jun 15 13:41:29 [my-host] postfix/smtpd[3968]: disconnect from localhost[127.0.0.1]
    Jun 15 13:41:38 [my-host] dovecot: imap-login: Login: user=<[[email protected]]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=4241, secured, session=<qPbjR1E1nAB/AAAB>
    Jun 15 13:41:38 [my-host] dovecot: imap([[email protected]]): Disconnected: Logged out in=173 out=3038

    </snip>
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. axxies

    axxies Member

    Pls see attached file.
     

    Attached Files:

  4. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    what's your main.cf ? and I may have missed it, but what version of ispconfig is this?
     
  5. axxies

    axxies Member

    It's ISPconfig 3 V3.0.5.4p9
     
  6. axxies

    axxies Member

    Phew! I have spent some time in exploring this issue even more and today I decided to start all over, so I reinstalled my new server (which is the one I am having these issues with) using the guide for the Jessie Perfect Server & ISPconfig3 installation. This server is running a LAMP setup.
    It simply doesn't work to send emails from this host. I tried to update the DNS so that the MX record pointed to the old server (LAMP, Debian Wheezy, ISPconfig3) and it worked perfectly both to send and receive emails (still the same domain as for the new server and I sent to the same email addresses as for the new server). Then I updated the DNS again to point the MX record pointed to the new server and nothing worked again.

    What is really strange with this error is that a lot of people seem to have it and for many years back. At some point I thought it was something that had turned up with Jessie, but since errors like this goes way back (2008 is the earliest I have found so far), this "can't" be it. Many seem to have been in a hopeless situation without a solution and just bumping their threads all the time, while some other guy just replied to his own thread saying that he didn't know why, but suddenly it started working again. It seem to lack a FAQ section/guide for this type of error.

    I hope that the rest of you who run into this problem find a solution and shares it with the world.

    I am definitely stuck and my only option seem to be to cancel the contract for the new server. No need to rent it when I can't use it.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Or you ask Florian to take a look at your server remotely, he is the developer of the Dkim plugin and mail server specialist. You can reach him here:

    http://www.ispconfig.org/get-support/?type=ispconfig

    Not being able to send emails can have many different reasons and it is not always easy to debug without system access, the reason can range from an issue on your server to firewalls and routing in the data center or other servers blocking your IP range, that's why you will find always threads about such a generall topic at all times.
     
  8. axxies

    axxies Member

    Thank you! I have cancelled the server contract already. I got p*ssed by the hosting company for their anti-customer approach (and yet I was willing to pay for their help, which was very clear). They seemed to have an idea on what the problem was.

    Now I am looking for a new hosting company for dedicated servers.

    I am very grateful for all the assistance I have got here!
     

Share This Page