Can't send and recieve email with dovecot

Discussion in 'Installation/Configuration' started by Gerjanw, Sep 23, 2019.

  1. Gerjanw

    Gerjanw New Member

    Hello all,

    I can't send and recieve email with dovecot. When i send a email it hangs on sending
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Dovecot is not used for email sending on your server, the mail server is postfix. Dovecot is the IMAP server.

    Have a look into the mail.log to find out why your mail server does not work. There are also many threads here in the forum which describe the steps to find email issues, please use the search function first and try to solve your problem with the steps outlined in other threads.
     
  3. Gerjanw

    Gerjanw New Member

    I have tried to find answers but i just can't find the solution.

    Sorry it's from roundcube i try to send mail

    /var/log/mail.log
    Code:
    Sep 23 18:55:32 scw-confident-merkle postfix/smtps/smtpd[8733]: connect from localhost[::1]
    Sep 23 18:56:02 scw-confident-merkle postfix/smtps/smtpd[8116]: SSL_accept error from localhost[::1]: Connection timed out
    Sep 23 18:56:02 scw-confident-merkle postfix/smtps/smtpd[8116]: lost connection after CONNECT from localhost[::1]
    Sep 23 18:56:02 scw-confident-merkle postfix/smtps/smtpd[8116]: disconnect from localhost[::1] commands=0/0
    
    /var/log/roundcube/errors
    Code:
    SMTP Error: Connection failed: Invalid response code received from server in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 1667 (POST /webmail/?_task=mail&_unlock=loading1569242332430&_lang=undefined&_framed=1&_action=send)
    
     
  4. Steini86

    Steini86 Member

    Use
    Code:
    openssl s_client -connect localhost:465
    Code:
    openssl s_client -starttls smtp -connect  localhost:25
    depending on your setup. If you don't find the error by yourself, post output here. Could be, that your "smtpd_tls_protocols" setting in postfix is too strict. Post output of:
    Code:
    postconf -n | grep smtpd_tls_protocols
     
  5. Jesse Norell

    Jesse Norell Well-Known Member

    It sounds like postfix is trying to talk ssl (port 465), you might make sure roundcube is set to use ssl as well (check roundcube config for default_host, smtp_server and smtp_port).
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the content of the /etc/postfix/master.cf file of your server.
     
  7. Gerjanw

    Gerjanw New Member

    I thank you very much for you assistants. I have been working on it throughout the night. I came to the conclusion that i should reinstall on a new server and do it by hand and by auto script. There where more problems.
     
  8. Gerjanw

    Gerjanw New Member

    I have one quick question i get the eror "unknown group 'syslog'". How to fix it?
    And i want to say that i realy like the work you are doing. Keep up the good work
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux distribution do you use now and which tutorial? And what kind of base image do you use, syslog is not ispconfig specific, so if its not working or that group is missing, then there might be an issue in the base install of the operating system.
     
  10. Gerjanw

    Gerjanw New Member

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    You get the error message when you run which command from the tutorial?
     
  12. Gerjanw

    Gerjanw New Member

    i got it as mail from cron
    /etc/cron.daily/logrotate:
    error: /etc/logrotate.conf:7 unknown group 'syslog'
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

  14. Gerjanw

    Gerjanw New Member

    Thank you
     

Share This Page