Can't see the website i've create

Discussion in 'Installation/Configuration' started by oepastor, Mar 25, 2011.

  1. oepastor

    oepastor New Member

    I had installed ISPConfig 3 in Centos 5.5 as the Perfect Server says.
    No problem with the installation, after that I open the Control Panel and it seems to work.
    I put the data of my server in the the Server Configuration.
    All the services seems to work fine.
    I restart the httpd service and it gives me this warning:

    "Starting httpd: [Fri Mar 25 12:08:11 2011] [warn] NameVirtualHost *:443 has no VirtualHosts"

    But if I go to ns1.dobryhost.net I saw the index of the panel and in :8080 I have the panel ok.

    I create a site named alternativapolitica.com.ar in the panel, I've follow the instructions found in this blog to do that and everythin seems to work but if I go to www.alternativapolitica.com.ar the browser cannot resolve the address.

    If I dig alternativapolitica.com.ar the answer is:

    [[email protected] ~]# dig alternativapolitica.com.ar

    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_5.3 <<>> alternativapolitica.com.ar
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    If I dig @localhost alternativapolitica.com.ar the answer is:

    [[email protected] ~]# dig @localhost alternativapolitica.com.ar

    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_5.3 <<>> @localhost alternativapolitica.com.ar
    ; (1 server found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 37828
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;alternativapolitica.com.ar. IN A

    ;; Query time: 3084 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Mar 25 12:36:48 2011
    ;; MSG SIZE rcvd: 44

    [[email protected] ~]#

    I try to correct something that someone says is an error and change the final line in /var/named/chroot/etc/named.conf but it doesn't works.
    At last I go to sleep without any progress.

    Today I try to go to my hosting server to go on looking what to do with the panel and it doesn't work, I cannot go to ns1.dobryhost.net:8080 but if I try to go to the IP address it works.
    I don't know what to do, I apreciate your help, thanks.
     
  2. otacon

    otacon New Member

    Go to Your control panel > Sites > Edit your website > Make sure Auto Subdomain "www." or "*." if you want wild card active.
     
  3. oepastor

    oepastor New Member

    The Auto Subdomain is "www." but nothing happens.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    It seems you didn't specify nameservers for your domain.

    This link might tell you more: http://www.intodns.com/alternativapolitica.com.ar
     
  5. oepastor

    oepastor New Member

    I configure the site and DNS in the Panel filling the requested data but nothing happens.
    Where the Panel says Web Domain / IP-Address there is an "*", is it correct?
    For the DNS I used the Wizard, I supposed is the best.
    May be a misconfiguration of the Panel?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Are ns1.dobryhost.net and ns2.dobryhost.net the nameservers that you configure through ISPConfig? If so, can you post the zone file for alternativapolitica.com.ar?
     
  7. oepastor

    oepastor New Member

    Falco
    I suppose I did all well but it doesn't work
    The zone for alternativapolitica.com.ar is the pri.alternativapolitica.com.ar file and is in /var/named/chroot/var/named/pri.alternativapolitica.com.ar:

    $TTL 86400
    @ IN SOA ns1.dobryhost.net. oepastor.gmail.com. (
    2011032202 ; serial, todays date + todays serial #
    28800 ; refresh, seconds
    7200 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;

    alternativapolitica.com.ar. A 190.7.31.42
    alternativapolitica.com.ar. MX 10 mail.alternativapolitica.com.ar.
    alternativapolitica.com.ar. NS ns1.dobryhost.net.
    alternativapolitica.com.ar. NS ns2.dobryhost.net.
    ftp A 190.7.31.42
    mail A 190.7.31.42
    www A 190.7.31.42


    The named.conf is this:

    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    //
    options {
    listen-on port 53 { 127.0.0.1; };
    listen-on-v6 port 53 { ::1; };
    directory "/var/named/chroot/var/named";
    dump-file "/var/named/chroot/var/named/data/cache_dump.db";
    statistics-file "/var/named/chroot/var/named/data/named_stats.txt";
    memstatistics-file "/var/named/chroot/var/named/data/named_mem_stats.tx$
    allow-query { localhost; };
    recursion yes;
    };
    logging {
    channel default_debug {
    file "data/named.run";
    severity dynamic;
    };
    };
    zone "." IN {
    type hint;
    file "named.root";
    };
    include "/var/named/chroot/etc/named.conf.local";

    If you can see what is wrong please tell me.
    Thanks
     
  8. falko

    falko Super Moderator ISPConfig Developer

    The zone file looks ok.

    Please remove/comment out the lines
    Code:
    listen-on port 53 { 127.0.0.1; };
    listen-on-v6 port 53 { ::1; };
    in your named.conf and restart named.
     
  9. oepastor

    oepastor New Member

    I've make the changes in named.conf but nothing happens.

    This is my Server config, please tell me if it is all right:
    [​IMG]

    I don't understand what may be happening, the server is Ok all the services works fine, it is crazy.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Can you post the outputs of
    Code:
    netstat -tap
    and
    Code:
    netstat -uap
    ?
     
  11. oepastor

    oepastor New Member

    These are the netstat:


    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 2760/dovecot
    tcp 0 0 *:833 *:* LISTEN 2347/rpc.statd
    tcp 0 0 *:pop3s *:* LISTEN 2760/dovecot
    tcp 0 0 localhost.localdomain:10025 *:* LISTEN 2863/master
    tcp 0 0 *:mysql *:* LISTEN 2731/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 2760/dovecot
    tcp 0 0 localhost.local:dyna-access *:* LISTEN 2643/clamd
    tcp 0 0 *:imap *:* LISTEN 2760/dovecot
    tcp 0 0 *:sunrpc *:* LISTEN 2311/portmap
    tcp 0 0 ns1.dobryhost.net:domain *:* LISTEN 11245/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 11245/named
    tcp 0 0 *:ftp *:* LISTEN 2914/pure-ftpd (SER
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2627/cupsd
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 11245/named
    tcp 0 0 *:smtp *:* LISTEN 2863/master
    tcp 0 0 localhost.localdomain:34060 localhost.localdomai:domain TIME_WAIT -
    tcp 0 0 localhost.localdomain:ftp localhost.localdomain:45527 TIME_WAIT -
    tcp 0 0 localhost.localdomain:35530 localhost.localdomain:http TIME_WAIT -
    tcp 0 0 *:imaps *:* LISTEN 2760/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 2760/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 2760/dovecot
    tcp 0 0 *:imap *:* LISTEN 2760/dovecot
    tcp 0 0 *:webcache *:* LISTEN 11287/httpd
    tcp 0 0 *:http *:* LISTEN 11287/httpd
    tcp 0 0 *:tproxy *:* LISTEN 11287/httpd
    tcp 0 0 *:ftp *:* LISTEN 2914/pure-ftpd (SER
    tcp 0 0 *:ssh *:* LISTEN 2614/sshd
    tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 11245/named
    tcp 0 2964 ns1.dobryhost.net:ssh ::ffff:186.141.163.16:49488 ESTABLISHED 15460/0
    [[email protected] ~]#



    [[email protected] ~]# netstat -uap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    udp 0 0 ns1.dobryhost.net:domain *:* 11245/named
    udp 0 0 localhost.locald:domain *:* 11245/named
    udp 0 0 *:52021 *:* 3034/avahi-daemon:
    udp 0 0 *:827 *:* 2347/rpc.statd
    udp 0 0 *:830 *:* 2347/rpc.statd
    udp 0 0 *:mdns *:* 3034/avahi-daemon:
    udp 0 0 *:sunrpc *:* 2311/portmap
    udp 0 0 *:ipp *:* 2627/cupsd
    udp 0 0 *:56532 *:* 3034/avahi-daemon:
    udp 0 0 *:mdns *:* 3034/avahi-daemon:
    [[email protected] ~]#


    The file /var/named/chroot/etc/named.conf.local is empty


    and the file /var/named/chroot/var/named/named.local

    zone "alternativapolitica.com.ar" {
    type master;
    allow-transfer {none;};
    file "/var/named/chroot/var/named//pri.alternativapolitica.com.ar";
    };
     
  12. falko

    falko Super Moderator ISPConfig Developer

    That looks ok. Please check if there's a firewall blocking port 53 (TCP and UDP).
     
  13. oepastor

    oepastor New Member

    Port 53 is open, the firewall is disabled.
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Is there any other firewall before your server (maybe on a router)?

    Is the server hosted in a data center, or do you host it at home/in your office? If the latter, maybe your ISP is blocking port 53.
     
  15. oepastor

    oepastor New Member

    There is nothing blocking port 53
    My server is in a Data Center and I've checked with people in the Data Center and I saw all open and closed ports. Port 53 is open.
    In one test from the NOC of the Data Center I can verify that the server refuse the connection for DNS but there is nothing abnormal in the configurations.
    If you cannot tell me what is happening I´ll try to install for the 4th time the panel.
    Can be any change or may be better if I use Debian?
    If I make a new installation I can try with Debian.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Can you post the output of
    Code:
    iptables -L
    ?

    Debian is the distribution we recommend as most of ISPConfig's development is done on Debian.
     
  17. oepastor

    oepastor New Member

    The iptables -L is:


    [[email protected] ~]# iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    If I have no solution I'll try using Debian 6. It's Ok?
    Thanks
     
  18. excalibur

    excalibur New Member

    /etc/resolv.conf is configured well?
     
  19. oepastor

    oepastor New Member

    Resolv.conf is Ok too.
     
  20. falko

    falko Super Moderator ISPConfig Developer

    Ok, no firewall... I'm running out of ideas...
     

Share This Page