Cant see https://lancom.co:81

Discussion in 'Installation/Configuration' started by weslkers, Jan 15, 2007.

  1. weslkers

    weslkers New Member

    i had refer the rest example posted in Howtoforge but still cant solve my problem~! so i decided to post my problem here. i cant see the https://lancom.co:81 in the web browser. This is my netstat -tap

    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdomain:2208 *:* LISTEN 1872/hpiod
    tcp 0 0 localhost.localdomain:57409 *:* LISTEN 1877/python
    tcp 0 0 *:sco-inetmgr *:* LISTEN 1705/rpc.statd
    tcp 0 0 *:mysql *:* LISTEN 1993/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1686/portmap
    tcp 0 0 *:hosts2-ns *:* LISTEN 3251/ispconfig_http
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 3389/named
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 1887/cupsd
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 3389/named
    tcp 0 0 *:smtp *:* LISTEN 3347/master
    tcp 0 0 localhost.localdomain:48005 localhost.localdomain:rndc TIME_WAIT -
    tcp 0 0 lancom.webserver.com:48191 mask.wsisiz.edu.pl:ftp ESTABLISHED 2208/python
    tcp 0 0 lancom.webserver.com:39883 mask.wsisiz.edu.pl:7844 ESTABLISHED 2208/python
    tcp 0 0 lancom.webserver.com:56804 mirror3-eth0.mirrors.t:http CLOSE_WAIT 2208/python
    tcp 0 0 lancom.webserver.com:50733 fpserv.fedoraproject.o:http CLOSE_WAIT 2208/python
    tcp 0 0 *:imaps *:* LISTEN 2021/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 2021/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 2021/dovecot
    tcp 0 0 *:imap *:* LISTEN 2021/dovecot
    tcp 0 0 *:http *:* LISTEN 3277/httpd
    tcp 0 0 *:ftp *:* LISTEN 3407/proftpd: (acce
    tcp 0 0 lancom.webserver.com:domain *:* LISTEN 3389/named
    tcp 0 0 *:ssh *:* LISTEN 1896/sshd
    tcp 0 0 lancom.webserver.com:ipp *:* LISTEN 1887/cupsd
    tcp 0 0 lancom.webserver.com:rndc *:* LISTEN 3389/named
    tcp 0 0 *:https *:* LISTEN 3277/httpd


    Some more this is my pc iptables -L and ifconfig ;

    [[email protected] ~]# iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    [[email protected] ~]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:11:09:80:5A:22
    inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::211:9ff:fe80:5a22/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:2856 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2896 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:3363482 (3.2 MiB) TX bytes:352097 (343.8 KiB)
    Interrupt:177 Base address:0x6e00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:3038 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3038 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:3276118 (3.1 MiB) TX bytes:3276118 (3.1 MiB)

    Pls tell me what should i do in order to read the https://www.lancom.co:81 thx
     
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    The site/domain https://www.lancom.co does not appear in the DNS and your using private IP space. Couple of options.

    1. Add www.lancom.co in you local (e.g. your workstation) hosts file. Iif your using Linux that would be /etc/hosts.
    2. Setup a DNS server and have lancom.co resolve to your IP
    3. Use the IP number of your server https://192.168.1.10:81

    I notice you probably do not own the domain lancom.co, so the best option is probably 3:
    Code:
    dig www.lancom.co
    
    ; <<>> DiG 9.3.2 <<>> www.lancom.co
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 26203
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.lancom.co.                 IN      A
    
    ;; AUTHORITY SECTION:
    co.                     10800   IN      SOA     cdcnet.uniandes.edu.co. nic.uniandes.edu.co. 2007011209 21600 3600 432000 43200
    
    ;; Query time: 178 msec
    ;; SERVER: 172.16.3.70#53(172.16.3.70)
    ;; WHEN: Mon Jan 15 08:13:50 2007
    ;; MSG SIZE  rcvd: 91
    
     
  3. weslkers

    weslkers New Member

    Thx to reply martin

    The problem stil cant solve~~ Just now i try https://192.168.1.10:81 and the result is this "Could not establish an encrypted connection because certificate presented by 192.168.1.10 is invalid or corrupted. Error Code: -8182

    PS: Pls tell me the full command how to solve it coz i newbie and using the fedora core 6~ THX ya~!
     
  4. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Not sure what this error code means, but at least your talking to your ISPConfig server.

    Did you have any problems / errors during the installation? Did you answer the Certificate questions (e.g. you did not just hit return)?
    Maybe you can clear the certificate in your browser cache. And restart your browser.
     
  5. weslkers

    weslkers New Member

    To Martin

    I had answer all the certificate question, do you think izzit is my hosts problem? This is my hosts;

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    192.168.1.10 lancom.webserver.com lancom


    ::1 lancom.webserver.com lancom localhost.localdomain localhost

    Any wrong setting? or port problem? my router run port 80 or should i change to 81? Pretty bad, till now i still cant experince the ispconfig services~~ so sad ;(
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. weslkers

    weslkers New Member

    To till

    Cant re create the certificate coz i got this error msg after key in the code:

    [[email protected] ~]# openssl genrsa -des3 -passout pass:redhat -out /root/ispconfig/httpd/conf/ssl.key/server/key2 1024
    /root/ispconfig/httpd/conf/ssl.key/server/key2: No such file or directory
    9314:error:02001002:system library:fopen:No such file or directory:bss_file.c:352:fopen('/root/ispconfig/httpd/conf/ssl.key/server/key2','w')
    9314:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:354:

    pretty bad~!!!
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You must enter the commands one ofter another, not all at once. Try to accept the defaults, if you enter anything that the openssl script does not understand, the certificates where not created.
     
  9. weslkers

    weslkers New Member

    The problem stil cant solve~

    Could any1 pls giv me a step by step instruction how to re-create the centificate bcoz i am beginner and not really understanding the coding~ By the way thx to "till" instruction but his instruction make me more confuse~! However, pls help me to solve my problem~@ thx~~
     
  10. dhonnoll78

    dhonnoll78 New Member

    Might be a dumb question but it worked for me

    It might be a dumb question but when you go to /etc/hosts do you have the ip and host name
    192.168.xxx.yyy example.www.example.com

    Do you have that line in your hosts file? Without it I couldnĀ“t get mine to work once I added it I have been up and running ever since
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Open a shell on your server.
    2) make sure that you are logged in as root user:

    sudo su

    3) Execute these commands:

    Code:
    openssl genrsa -des3 -passout pass:yourpassword -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
    
    openssl req -new -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
    
    openssl req -x509 -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -in /root/ispconfig/httpd/conf/ssl.csr/server.csr -out /root/ispconfig/httpd/conf/ssl.crt/server.crt -days 365
    
    openssl rsa -passin pass:yourpassword -in /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.key/server.key
    
    chmod 400 /root/ispconfig/httpd/conf/ssl.key/server.key
    I separated the commands by a white line.
     
  12. weslkers

    weslkers New Member

    Problem stil cant solve~!!!

    to till:

    i had renews my certificated regarding of your instruction but stil receive the same error: "Could not establish an encrypted connection because certificate presented by 192.168.1.10 is invalid or corrupted. Error Code: -8182. Any other solution?
     
  13. weslkers

    weslkers New Member

    to dhonnoll78

    dun hav line ni my etc/hosts/, this is my etc/hosts/

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    192.168.1.10 lancom.webserver.com lancom

    ::1 lancom.webserver.com lancom localhost.localdomain localhost


    could any1 can tell me what is the actual problem???? pls help me to solve it ~!!! thx~!!
     
  14. horus.solaris

    horus.solaris New Member

    You might have a different version of the certificate saved on the browser cache. Delete it from IE (tools/internet options/content) or from Firefox (tools/options/advanced/encryption) then restart your browser.

    HS
     
  15. weslkers

    weslkers New Member

    THX to ALL

    Finally read the page by https://192.168.1.10:81, however thx alot to martinfst, till, dhonnoll78 and horus.solaris is bcoz urs help, i can use the ispconfig~! Ur little help mean alot to me~! i really apperiate it~~ thx n thx alot again~~ :)
     

Share This Page