Can't retrieve email from client

Discussion in 'Installation/Configuration' started by cambo, Nov 21, 2006.

  1. cambo

    cambo New Member

    Hi Guys.
    I can't find a similar thread to this.
    Up until about 4 days ago my email was working fine.
    Then I couldn't retrieve email.
    I checked the mailboxes and there is recent mail in them, so it is receiving fine, and putting the mail in the correct boxes.
    When I try to retrieve the email with a client it logs in OK, but doesn't get any email.
    When I try https://mydomain:81/mailuser I get a "can't connect error" (same with webmail) however I am able to log in to ISPConfig as admin on port 81. :confused:
    I have run Postfix check and get no errors.
    Any suggestions?
    TIA
    Cambo
     
  2. till

    till Super Moderator

    Which errors do you get in your mail log?
     
  3. cambo

    cambo New Member

    Hi Till
    This is all the errors for the past month in /var/log/mail/errors:
    Nov 19 20:24:46 webserver postfix/postfix-script: fatal: the Postfix mail system is not running
    Nov 21 22:29:24 webserver postfix/postfix-script: fatal: the Postfix mail system is not running
    Nov 21 23:05:32 webserver postfix[6091]: fatal: usage: postfix [-c config_dir] [-Dv] command
    Nov 21 23:08:23 webserver postfix/postfix-script: fatal: the Postfix mail system is already running

    The last two were me trying to test Postfix.
    I checked /etc/postfix and all of my domains and users are there.
    The incoming email is in /home/www/web(No)/user/web(No)_(user)/Maildir/new
    the /cur and /tmp folders are empty.
    Thanks
    Cambo
     
  4. cambo

    cambo New Member

    Sorry, this might help as well.
    netstat -tap

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:32769 *:* LISTEN -
    tcp 0 0 *:nfs *:* LISTEN -
    tcp 0 0 *:imaps *:* LISTEN 3503/xinetd
    tcp 0 0 *:pop3s *:* LISTEN 3503/xinetd
    tcp 0 0 *:5801 *:* LISTEN 5108/Xvnc
    tcp 0 0 webserver.mydomain.com:10026 *:* LISTEN 7226/master
    tcp 0 0 *:mysql *:* LISTEN 2436/mysqld
    tcp 0 0 *:netbios-ssn *:* LISTEN 3876/smbd
    tcp 0 0 *:5901 *:* LISTEN 5108/Xvnc
    tcp 0 0 *:pop3 *:* LISTEN 3503/xinetd
    tcp 0 0 *:imap *:* LISTEN 3503/xinetd
    tcp 0 0 *:sunrpc *:* LISTEN 2480/portmap
    tcp 0 0 *:http *:* LISTEN 4742/httpd
    tcp 0 0 *:6001 *:* LISTEN 5108/Xvnc
    tcp 0 0 *:81 *:* LISTEN 4288/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN 7087/proftpd: (acce
    tcp 0 0 192.168.2.226:domain *:* LISTEN 4939/named
    tcp 0 0 192.168.2.225:domain *:* LISTEN 4939/named
    tcp 0 0 www.mydomain.com:domain *:* LISTEN 4939/named
    tcp 0 0 webserver.mydomain.com:domain *:* LISTEN 4939/named
    tcp 0 0 webserver.mydomain.com:5335 *:* LISTEN 3150/mDNSResponder
    tcp 0 0 *:ipp *:* LISTEN 2679/cupsd
    tcp 0 0 *:smtp *:* LISTEN 7226/master
    tcp 0 0 *:826 *:* LISTEN 3618/rpc.mountd
    tcp 0 0 *:https *:* LISTEN 4742/httpd
    tcp 0 0 *:764 *:* LISTEN 3552/rpc.rquotad
    tcp 0 0 *:700 *:* LISTEN 2638/rpc.statd
    tcp 0 0 *:microsoft-ds *:* LISTEN 3876/smbd
    tcp 0 0 www.mydomain.com:5901 192.168.2.60:1104 ESTABLISHED 5108/Xvnc
    tcp 0 0 *:ssh *:* LISTEN 3376/sshd
    tcp 0 0 www.mydomain.com:ssh ::ffff:192.168.2.60:1105 ESTABLISHED 22780/sshd: root@no
     
  5. till

    till Super Moderator

    Which pop3 and imap server do you have installed? If you dont have courier or dovecot installed, you can not use maildir.
     
  6. cambo

    cambo New Member

    Hi Till
    I have installed the whole system exactly as detailed in the Mandriva 2006 Perfect Install and the installation instructions of ISPConfig. I haven't modified anything as you guys know a lot more about it than me. What is the default? I did a "locate" for courier and dovecot and got no result (apart from courier font). If I "locate" pop I see /usr/sbin/ipop3 and ipop3s and ipop2.
    /usr/sbin/ipop3d results in:
    +OK POP3 webserver.mydomain.com 2004.89mdk server ready
    /usr/sbin/imapd results in:
    * OK [CAPABILITY IMAP4REV1 LITERAL+ SASL-IR LOGIN-REFERRALS AUTH=LOGIN] webserver.mydomain.com IMAP4rev1 2004.357mdk at ...

    The thing is that everthing was working fine and then just stopped.
    The only change I can remember making in the last week or so was adding a co-domain to one of my domains. That was mail.mydomain.com so that I could put that in my MX record in the DNS (Zoneedit, not local. I am not serving DNS to the Internet from this server.) The domain that I changed is not the main one that I use for email.
    Regards
    Cambo
     
  7. till

    till Super Moderator

    Then your server does not support maildir, but the emails where currently delivered to the maildirs and not to the mbox files.

    Please make sure that the Maildir checkbox in ISPConfig under Management > server > settings on the mail tab is not enabled.
     
  8. cambo

    cambo New Member

    Hi Till
    Now we are getting somewhere. It was ticked.
    I don't remember checking that box, but then again I don't remember what I had for dinner yesterday either. :)
    I have unchecked it and saved it. Do I have to restart anything?
    and where are the mail boxes now?
    Thanks
    Cambo
     
  9. till

    till Super Moderator

    No

    /var/spool/mail

    But you wont be able to retrieve the emails that has been send to your server in the meantime, because they are stored in a format that cn not be read by ipop3d.
     
  10. cambo

    cambo New Member

    OK, answered my own question about the restart by sending a test email and it came through.
    Still interested where the mail boxes are.

    Thanks Till, you and the other guys are legends.
     
  11. till

    till Super Moderator

    They are in the directory /var/spool/mail/ (see my post above ;)
     
  12. cambo

    cambo New Member

  13. falko

    falko Super Moderator

  14. cambo

    cambo New Member

    Thanks Falko
    (please excuse my inability to read and apply the documentation properly) :)
     

Share This Page