Can't Remote Access mysql 4.1

Discussion in 'Installation/Configuration' started by dedibox, Aug 23, 2006.

  1. dedibox

    dedibox New Member

    I'm using a stock installation of ISPConfig 2.2.1 upgraded to 2.2.6.

    I also upgraded mysql to 4.1 using apt-get.

    Even though I've check the "Remote Access" box for one of the mysql databases I've created, I can't access it from another IP.

    PHPMyAdmin and mysql command line work fine.

    I tried granting remote access to my IP from the mysql command line:

    Code:
    GRANT ALL PRIVILEGES ON *.* TO web6_u5@[IP] IDENTIFIED BY "PASSWORD";
    I still get "Can't connect to MySQL server".

    From the mysql server localhost, I get:

    Code:
    dz:/var/log/httpd# mysql -u web6_u5@remoteip -p         
    Enter password: 
    ERROR 1045 (28000): Access denied for user 'web6_u5@82.236.8'@'localhost' (using password: YES)
    
    I used netstat -tap which showed me that MySQL is listening only on 127.0.0.1 and not on all interfaces, so I commented out bind-address in my.cnf

    I checked the mysql hosts with phpMyAdmin, which says that web6_u5 has % and localhost as its hosts.

    Still can't connect.

    Worse, now that I've set a root password for mysql, I can no longer log into ISPConfig!

    Code:
    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: NO) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77
    
    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: NO) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60
    
     
    Last edited: Aug 23, 2006
  2. till

    till Super Moderator

    To repair the ISPConfig login problem, set your new root mysql password in the file /home/admispconfig/ispconfig/lib/config.inc.php

    Please post the output of "netstat -tap" and your /etc/my.cnf file.
    Did you restart mysql after you changed the my.cnf configuration?
     
  3. dedibox

    dedibox New Member

    mysql remote access and ispconfig password problems fixed

    Thanks for your reply. I had to manually edit the host in mysql, flush privileges, and restart mysql. After all that, both remote access and iSPConfig work. Whew.
     

Share This Page