Cant recieve mails

Discussion in 'Installation/Configuration' started by JoeJoe, Oct 3, 2006.

  1. JoeJoe

    JoeJoe New Member


    I can send emails from a newly aquired server,.. am running on mandriva, used the perfectsetup with ISPconfig. But i cant recieve any.. and i dont get any errors??
    Does anyone have a clue on what i should look for?
  2. edge

    edge Active Member Moderator

    Is your MX record in the DNS set correct for that domain?
  3. JoeJoe

    JoeJoe New Member

    i believe so,.. i had ispconfig do it.

    Winged off- create DNS & Create DNS-MX
    Am not sure.. what else to do!

    I checked With DNS report and everything checked out,.. except mail--

    ERROR: I could not complete a connection to any of your mailservers! Timed out [Last data sent: [Did not connect]]
    If this is a timeout problem, note that the DNS report only waits about 40 seconds for responses, so your mail *may* work fine in this case but you will need to use testing tools specifically designed for such situations to be certain.
    any ideas?
    Last edited: Oct 3, 2006
  4. edge

    edge Active Member Moderator

    Okay. The best thing to do is post your domainname, so that some of us can have a look at the DNS records.

    If you do not want to do this (understandable), than did you set the namservers at the place where you registered the domainname to the correct IP(s)?..

    An other way of seeing a lot of usable info for you is by using (make sure that you replace the
  5. JoeJoe

    JoeJoe New Member

    Last edited: Oct 4, 2006
  6. JoeJoe

    JoeJoe New Member

    I also got emails back that saying,.. emails sent were delayed,.. and no specific error ???

    also heres part of the mail log
    Oct  3 18:18:07 server1 ipop3d[16810]: pop3 service init from
    Oct  3 18:18:07 server1 ipop3d[16810]: Command stream end of file while reading 
    line user=??? host=UNKNOWN
    Oct  3 18:18:21 server1 ipop3d[16820]: pop3 service init from
    Oct  3 18:18:21 server1 ipop3d[16820]: Connection reset by peer while reading li
    ne user=??? host=UNKNOWN
    Anyone know what this means?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you follow one of the perfect setup guides? Make sure that the Maildir checkbox in the ISPConfig server settings is disabled.
  8. JoeJoe

    JoeJoe New Member

    Yes i followed the Mandriva 2006 10.1.
    I have just unchecked the maildir in ispconfig.

    Still no incoming mails ?
  9. edge

    edge Active Member Moderator

    I can see that your port 25 is open, but when I telnet to your system on that port, I do not get any responce back!

    Is postfix runing?
  10. JoeJoe

    JoeJoe New Member

    [root@server1 ~]#  /etc/init.d/postfix restart
    Shutting down postfix:                                          [  OK  ]
    Starting postfix:                                               [  OK  ]
    pretty sure it was,.. anyway i just restarted it to be sure.

    As far as i know,.. everything should be ok. Since only errors i get back say that the mails have been delayed. I have disabled anti virus & spam filters!!
    Whats missing ?:(
  11. JoeJoe

    JoeJoe New Member

    Alright so i went back to the howto.. and ran through the setup one more time.
    Now i am back to where i started... i am getting errors from dnsreports


    i am hoping someone has seen thise error before ?
    Last edited: Oct 4, 2006
  12. JoeJoe

    JoeJoe New Member

    Fixed it...

    went through the howto a couple of times again and again... am not sure how.. but it works now!!
  13. edge

    edge Active Member Moderator

    You can copy & paste from the howto's into putty.

    Problem with this is that sometimes you copy an extra "space" after the needed command, causing a return when pasted in putty. This could sometimes (specially with the mail part) cause errors!

    Anyway.. Good to hear that it's working now.

Share This Page