Cant recieve mails :(

Discussion in 'General' started by Shayne, May 28, 2007.

  1. Shayne

    Shayne New Member

    Need Urgent help guys....

    Since fridaye my box isnt getting any mails.. well at least it is recieving and staying in th mail queue!

    It shows undeliverable with the following error:

    <user@domain.co.za> (expanded from
    <user@domain.co.za>): Host or domain name not found. Name service
    error for name=domain type=AAAA: Host not found

    Heve no clue how to fix this and its getting urgent. I did check that my 2 resolv.conf file were identical. Pleeeease help.
     
  2. Shayne

    Shayne New Member

    And now my ispconfig doesnt work anymore :(

    I tired ispconfig_server start but says invalid command even thought he script is in the init.d folder!

    sigh this day is jus getting worse!
     
  3. edge

    edge HowtoForge Supporter

    Try: /etc/init.d/ispconfig_server start
     
  4. Shayne

    Shayne New Member

    Tried that it says invalid command. should I re-install ispconfig??

    If I do will I lose all my settings?

    Thanks for the reply!
     
  5. till

    till Super Moderator

    Please post the exact error message and what you typed on the shell. Make sure that you are logged in as root user on the shell before you execute the command.
     
  6. Shayne

    Shayne New Member

    okies I came right, just re-installd ispconfig and viola it worked.

    Only problem is with recieving mails still :(
     
  7. falko

    falko Super Moderator

    What's in your mail log when you send a mail to your server?
     
  8. Shayne

    Shayne New Member

    Hi Falko

    I came right sumhow, Im dtill not to sure what I did but I think Courier was faulty or not working so I deleted and insatalled another pop server and it works.

    poppy I think its called. Just out of curiosity will that impact the ispconfig setup or settings at all. I have noticed small things like the quotas for all my users I have setup I have to changes from -1(which used to be unlimited) to say 50 in order for it to work otherwise it gives inbox is full and bounces the mail.

    plus in my main.cf I have to physically put the destination for all my domains or it rejects it saying relay access denied or summin like that.

    Thanks for the help Falko and till I really appreciate it. At least the crises is over but I am still worried the original ispconfig setup is not 100% :(
     
  9. falko

    falko Super Moderator

    No.

    You mean for domains that are not on your server (like gmail.com or hotmail.com)?
     
  10. Shayne

    Shayne New Member

    Nope.. I have 3 domains setup on my box. previously all I had under destinations was localdomain and the server name and it was fine. since reloading I had to add the other domains I setup in ispconfig to the main.cf.
     
  11. falko

    falko Super Moderator

    What's in /etc/postfix/main.cf (please strip out the comments)?
     
  12. Shayne

    Shayne New Member

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    append_dot_mydomain = no

    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = localhost, localhost.localdomain (and the others, etc , etc)
    mynetworks = 10.0.0.0/8,127.0.0.0/8(plus external ip)
    mailbox_command = procmail -a "$EXTENSION"
    mailbox = /var/mail
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_maps = hash:/etc/postfix/virtusertable
     
    Last edited: May 31, 2007
  13. falko

    falko Super Moderator

    I guess you modified that file? Because the line mydestination = /etc/postfix/local-host-names is missing. Please run
    Code:
    postconf -e 'mydestination = /etc/postfix/local-host-names'
    /etc/init.d/postfix restart
     
  14. Shayne

    Shayne New Member

    Fantastic, Falko u a genius :)

    Thanks alot working again the way it was!!:rolleyes:
     

Share This Page