Cant recieve external emails on ultimate centos 5.2 install

Discussion in 'Server Operation' started by andyc, Sep 11, 2009.

  1. andyc

    andyc New Member

    hi guys,

    Got a problem with my postfix install.

    I used Falcos superb guide on my last centos 4 serer and it worked sweetly. But I am not having the same luck this time with a new server!!

    basically, I can recieve and send emails internally.
    i can send emails externally.
    but I cannot recieve any mails from outside to my email accounts on the server.

    I am scratching my head big time and seeking help or guidance before I go insane!

    The DNS mx record is set to
    Maillog is not showing errors for incoming mails, its just not showing anything!!

    I have attached some results from a few commands, the netstat -tap results have me a bit puzzled as there are a lot of things 'holiding'.. not sure if this is right!?

    Also, the results for my

    differ slightly as they are

    Virtual.db is all updated

    Also, I keep getting an email from root for a cron job saying


    All help appreciated.. :cool:

    Attached Files:

    Last edited: Sep 11, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    Please add to the mydestination line in /etc/postfix/ and restart Postfix.
  3. andyc

    andyc New Member

    Thanks Falko

    I have done this

    but it has not made any diference :(

    No errors showing in the maillog :/
    Last edited: Sep 11, 2009
  4. andyc

    andyc New Member

    One thing I have thought of...

    The server was allocated with 5 IP addresses.

    Only one of them is fine. (the main one listed in hosts file)

    The other two I have added in my DNS provider as (subdomain) records dont seem to be working as expected though.

    using nslookup the mail sub domain resolves correctly though :/

    This test on the mailserver

    Gives this

    i added the to hosts with the corresponding IP to see if it helped. it hasnt!

    and heres a snippet from the latest part of the maillog. I noticed that the cypher verification failed.....? the log is full of this,(the fail) and I only just noticed....

    Last edited: Sep 11, 2009
  5. falko

    falko Super Moderator ISPConfig Developer

    What did the mydestination line look like before you changed it?
  6. andyc

    andyc New Member

    I originally had it set to

    which is what worked perfectly on my last centos/postfix server.

  7. falko

    falko Super Moderator ISPConfig Developer

    Then add at the end of /etc/postfix/local-host-names and use mydestination = /etc/postfix/local-host-names in your
  8. andyc

    andyc New Member

    it is already Falco :/
    Im thinking of removing and re installing postfix...!!
  9. falko

    falko Super Moderator ISPConfig Developer

    Do you still get this error?
  10. andyc

    andyc New Member

    Thanks for your help falko :cool:

    It is now working. I wasnt getting that error and it seems it wasnt the postfix config that was the problem.....----->>>>> :eek:

    The problem I pinpointed was after doing an SMTP mailserver check online, which said the subdomain wasnt responding, it also wouldnt reply to a ping.

    The server provider gives 5 IP addresses with it, and I was using a seperate one for my main site (the first one allocated/main one), and another for the mail server.(as I had it on my last server)

    Even though the Ip is listed in hosts file (centos5) it is not working and when I changed the subdomain dns to point to the primary IP it is all working (email etc)

    Going to need some further digging I think :confused::)

Share This Page