Can't receive mail

Discussion in 'Installation/Configuration' started by mrtns, Jul 2, 2010.

  1. mrtns

    mrtns New Member

    ISPconfig 2 + postfix 2.5.1.

    I have problem: can't receive mail from senders.
    Mail log shows:
    Jul 2 13:15:09 ub postfix/cleanup[3624]: 13A9E6BE349: message-id=<[email protected]>
    Jul 2 13:15:09 ub postfix/qmgr[8265]: 13A9E6BE349: from=<[email protected]>, size=2428, nrcpt=2 (queue active)
    Jul 2 13:15:25 ub postfix/local[3479]: 13A9E6BE349: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=18, delays=1.8/0/0/16, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jul 2 13:15:25 ub postfix/qmgr[8265]: 13A9E6BE349: removed

    But I didn't get any mail to my mailbox.
    What's the problem?
     
  2. Mark_NL

    Mark_NL New Member

    add this line to your .procmailrc file:

    Code:
    LOGFILE=/var/log/procmail.log
    chmod it to ehm, say 666

    Code:
    chmod 666 /var/log/procmail.log
    now send another mail, and check the contents of the logfile.
     
  3. mrtns

    mrtns New Member

    The log file is empty. It's possible?
     
  4. Mark_NL

    Mark_NL New Member

    if you create a new email account in the same domain, can that one receive mail?
     
  5. mrtns

    mrtns New Member

    I didn't receive not all mail.
    Some mails arives, but some no...
    What's the problem?
     
  6. Mark_NL

    Mark_NL New Member

    check the logfil /var/log/mail.log and see what lines you get with a mail that you receive and the ones which you didn't receive it, see if there are differences .. also set a procmail log on both those mailboxes and see if the logfiles show you anything helpfull.
     
  7. mrtns

    mrtns New Member

    From mail.log.
    Received mail:
    Jul 28 13:54:40 ub postfix/smtpd[27420]: 7AD1C6BE1DA: client=unknown[192.168.1.115], sasl_method=PLAIN, sasl_username=web1.martynas
    Jul 28 13:54:40 ub postfix/cleanup[3186]: 7AD1C6BE1DA: message-id=<[email protected]>
    Jul 28 13:54:40 ub postfix/qmgr[27127]: 7AD1C6BE1DA: from=<[email protected]>, size=755, nrcpt=1 (queue active)
    Jul 28 13:54:56 ub postfix/local[2034]: 7AD1C6BE1DA: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=16, delays=0.03/0/0/16, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jul 28 13:54:56 ub postfix/qmgr[27127]: 7AD1C6BE1DA: removed


    Didn't received:
    Jul 19 16:36:16 ub postfix/smtpd[17508]: 7E0FB6BE1B2: client=unknown[79.98.28.17]
    Jul 19 16:36:16 ub postfix/cleanup[16126]: 7E0FB6BE1B2: message-id=<[email protected]@ccg.lt>
    Jul 19 16:36:16 ub postfix/qmgr[29266]: 7E0FB6BE1B2: from=<[email protected]>, size=109643, nrcpt=1 (queue active)
    Jul 19 16:36:32 ub postfix/local[17418]: 7E0FB6BE1B2: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=17, delays=1.2/0/0/16, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jul 19 16:36:32 ub postfix/qmgr[29266]: 7E0FB6BE1B2: removed
     
  8. Mark_NL

    Mark_NL New Member

    Received:
    to=<[email protected]>, orig_to=<[email protected]>,

    Didn't Receive:
    to=<[email protected]>, orig_to=<[email protected]>

    send a mail to the same address, but from different locations ..

    i'm thinking it has something to do with the used domain names, host file, aliases etc ..
     
  9. mrtns

    mrtns New Member

    I have parked some subdomains to one mail server.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    repquota -avug
    ?
     
  11. mrtns

    mrtns New Member

    [email protected]:~# repquota -avug
    [email protected]:~#
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? Which tutorial (URL) did you use to set up the system?

    What's the output of
    Code:
    netstat -tap
    ?
     
  13. mrtns

    mrtns New Member

    Attached Files:

  14. falko

    falko Super Moderator ISPConfig Developer

    You used the ISPConfig 3 tutorial and installed ISPConfig 2? That doesn't work because ISPConfig 2 is incompatible with an ISPConfig 3 setup.
     
  15. mrtns

    mrtns New Member

    Sorry, I've gave you wrong link. I installed ISPconfig 2 from turtorial.
    Since now I have problems with mails. Some mails didn't arive to email program but it's server logs everythink is OK.
    Where is the problem?

    ISPConfig Version: 2.2.29
     
    Last edited: Sep 3, 2010
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Uncheck the mailfilter checkbox in the mailbox settings. The mailfilter is a email content filetr (do not mix this up with the spamfilter) which may remove mails if the content contains html and javascript in wrong syntax.
     
  17. mrtns

    mrtns New Member

    Could you tell me how should i do it?
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    You do this by editing the settings of the mailbox that has the email receive problems. Please take a look at the ispconfig 2 manual, all mailbox settings are described there in detail.
     
  19. mrtns

    mrtns New Member

    I have problems not only with one mailbox. Same problems I have with all.
    Spamfilter: checked
    Antivirus: checked
    Spam strategy: discard
    Spam hits: 5.0
     
  20. falko

    falko Super Moderator ISPConfig Developer

    You mix this up with the Spamfilter settings. You must uncheck MailScan on the Advanced Settings tab.
     

Share This Page