Can't receive mail

Discussion in 'Installation/Configuration' started by Gem, Jan 29, 2006.

  1. Gem

    Gem New Member

    I am able to send mail, but can not receive it. The error I am getting in outlook is:

    I have checked the properties and it is all correct. I have no idea what I need to do to fix it. :confused:
     
  2. falko

    falko Super Moderator

    Make sure you use the correct username (something like web<id>_<username>).
    If you're sure this is ok, then try to send yourself an email - it is possible that the mailbox doesn't exist yet, and that Outlook is giving you the error therefore. When the first email arrives, the mailbox is created, and then everything should be fine.
     
  3. Gem

    Gem New Member

    I did use the correct name and I did email something to from that account to another. I received the email on the other address and I replied to it and it came back wth this error:

     
  4. falko

    falko Super Moderator

    This is what I found out:

    Code:
    ~# dig mx facetsofgem.com
    
    ; <<>> DiG 9.2.1 <<>> mx facetsofgem.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5991
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;facetsofgem.com.               IN      MX
    
    ;; ANSWER SECTION:
    facetsofgem.com.        10800   IN      MX      5 [B][COLOR="Red"]mail.facetsofgem.com[/COLOR][/B].
    
    ;; AUTHORITY SECTION:
    facetsofgem.com.        10800   IN      NS      remote2.easydns.com.
    facetsofgem.com.        10800   IN      NS      ns1.easydns.com.
    facetsofgem.com.        10800   IN      NS      ns2.easydns.com.
    facetsofgem.com.        10800   IN      NS      remote1.easydns.com.
    
    ;; ADDITIONAL SECTION:
    ns2.easydns.com.        2893    IN      A       209.200.151.4
    remote2.easydns.com.    2893    IN      A       205.210.42.20
    
    ;; Query time: 353 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Sun Jan 29 21:30:38 2006
    ;; MSG SIZE  rcvd: 174
    The mail server for facetsofgem.com is mail.facetsofgem.com.

    Code:
    ~# dig [B][COLOR="Red"]mail.facetsofgem.com
    [/COLOR][/B]
    ; <<>> DiG 9.2.1 <<>> mail.facetsofgem.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 20248
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.facetsofgem.com.          IN      A
    
    ;; AUTHORITY SECTION:
    facetsofgem.com.        10800   IN      SOA     ns0.easydns.com. admin.easydns.com. 1137874568 21600 7200 1209600 10800
    
    ;; Query time: 171 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Sun Jan 29 21:31:02 2006
    ;; MSG SIZE  rcvd: 92
    But mail.facetsofgem.com has no A record which means mail to facetsofgem.com can't be delivered because mail.facetsofgem.com doesn't exist!
     
  5. Gem

    Gem New Member

    hmmm....ok...that makes sence....how do I fix that? I see where it is pulling the mail.facetsofgem.com, that is what is on easydns...I just don't know where to go from here....
     
    Last edited: Jan 30, 2006
  6. falko

    falko Super Moderator

    You must create an A record for mail.facetsofgem.com pointing to your ISPConfig server's public IP address.
     
  7. Gem

    Gem New Member

    How do I do that? Or is there a link that I can go to??

    Thanks so much for your help. :)
     
  8. falko

    falko Super Moderator

    The authoritative name server is ns0.easydns.com so I guess you have a web frontend from easydns.con where you can configure this? Because somehow you must have created the MX record before (unless someone else did it).
     
  9. Gem

    Gem New Member

    I set it up with easydns to only handle the dns.....there is an option there for them to handle email or for me to handle it...I have it marked for me to handle the email...and that is where mail.facetsofgem.com is located....

    so since I followed the Fedora Core Perfect Set Up, I should be able to specify my own mail server correct? So how do I edit or look at the MX record?:confused:
     
  10. till

    till Super Moderator

    The MX record is on the easydns DNS server, you have to change the MX there to point to the domain of your server.
     
  11. Gem

    Gem New Member

    I went to easydns and I am showing the A record is set to facetsofgem.com. and then in the section for mx settings I have it pointing to my own mail server facetsofgem.com

    I changed it from mail.facetsofgem.com to facetsofgem.com this morning, but I am still not able to sent or reveive mail. Is there something else I need to be putting for the mx settings?
     
  12. till

    till Super Moderator

    You have to wait some time. Changes in DNS may take up to 48 hours to take effect.
     
  13. Gem

    Gem New Member

    It is still not working...any ideas?
     
  14. till

    till Super Moderator

    If 12.208.218.84 is your IP, the the DNS resoves to your Server. Which error do you get when you send an email to your server? Are there any errors in the mail.log?
     
  15. Gem

    Gem New Member

    I am still getting this error:

    for the maillog

    Code:
    Feb  2 23:59:04 localhost postfix/postfix-script: starting the Postfix mail system
    Feb  2 23:59:04 localhost postfix/master[17214]: daemon started -- version 2.2.2, configuration /etc/postfix
    Feb  3 02:03:09 localhost ipop3d[18262]: pop3 service init from 12.208.200.41
    Feb  3 02:03:17 localhost ipop3d[18262]: Command stream end of file while reading line user=web1_webmaster host=12-208-200-41.client.insightBB.com [12.208.200.41]
    Feb  3 04:02:17 localhost sendmail[19560]: k1392H1x019560: from=root, size=23651, class=0, nrcpts=1, msgid=<200602030902.k1392H1x019560@localhost.localdomain>, relay=root@localhost
    Feb  3 04:02:18 localhost postfix/smtpd[19561]: connect from localhost.localdomain[127.0.0.1]
    Feb  3 04:02:18 localhost postfix/smtpd[19561]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Feb  3 04:02:18 localhost sendmail[19560]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    Feb  3 04:02:18 localhost postfix/smtpd[19561]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Feb  3 04:02:18 localhost postfix/smtpd[19561]: 6CB7F1AF390: client=localhost.localdomain[127.0.0.1], sasl_sender=root@localhost.localdomain
    Feb  3 04:02:18 localhost postfix/cleanup[19565]: 6CB7F1AF390: message-id=<200602030902.k1392H1x019560@localhost.localdomain>
    Feb  3 04:02:18 localhost sendmail[19560]: k1392H1x019560: to=root, ctladdr=root (0/0), delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=53651, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 6CB7F1AF390)
    Feb  3 04:02:18 localhost postfix/qmgr[17218]: 6CB7F1AF390: from=<root@localhost.localdomain>, size=24746, nrcpt=1 (queue active)
    Feb  3 04:02:18 localhost postfix/smtpd[19561]: disconnect from localhost.localdomain[127.0.0.1]
    Feb  3 04:02:18 localhost postfix/local[19567]: 6CB7F1AF390: to=<root@localhost.localdomain>, relay=local, delay=0, status=sent (delivered to mailbox)
    Feb  3 04:02:18 localhost postfix/qmgr[17218]: 6CB7F1AF390: removed
    Feb  3 04:02:43 localhost sendmail[19566]: k1392ITu019566: from=root, size=386, class=0, nrcpts=1, msgid=<200602030902.k1392ITu019566@localhost.localdomain>, relay=root@localhost
    Feb  3 04:02:43 localhost postfix/smtpd[19561]: connect from localhost.localdomain[127.0.0.1]
    Feb  3 04:02:43 localhost postfix/smtpd[19561]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Feb  3 04:02:43 localhost postfix/smtpd[19561]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Feb  3 04:02:43 localhost sendmail[19566]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    Feb  3 04:02:43 localhost postfix/smtpd[19561]: 390641AF390: client=localhost.localdomain[127.0.0.1], sasl_sender=root@localhost.localdomain
    Feb  3 04:02:43 localhost postfix/cleanup[19565]: 390641AF390: message-id=<200602030902.k1392ITu019566@localhost.localdomain>
    Feb  3 04:02:43 localhost sendmail[19566]: k1392ITu019566: to=root, ctladdr=root (0/0), delay=00:00:25, xdelay=00:00:00, mailer=relay, pri=30386, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 390641AF390)
    Feb  3 04:02:43 localhost postfix/qmgr[17218]: 390641AF390: from=<root@localhost.localdomain>, size=990, nrcpt=1 (queue active)
    Feb  3 04:02:43 localhost postfix/local[19567]: 390641AF390: to=<root@localhost.localdomain>, relay=local, delay=0, status=sent (delivered to mailbox)
    Feb  3 04:02:43 localhost postfix/qmgr[17218]: 390641AF390: removed
    Feb  3 04:02:43 localhost postfix/smtpd[19561]: disconnect from localhost.localdomain[127.0.0.1]
    Feb  3 06:41:21 localhost ipop3d[21015]: pop3 service init from 12.208.200.41
    Feb  3 06:41:24 localhost ipop3d[21015]: Command stream end of file while reading line user=web1_webmaster host=12-208-200-41.client.insightBB.com [12.208.200.41]
    Feb  3 12:35:33 localhost ipop3d[23891]: pop3 service init from 12.208.200.41
    Feb  3 12:35:37 localhost ipop3d[23891]: Command stream end of file while reading line user=web1_webmaster host=12-208-200-41.client.insightBB.com [12.208.200.41]
    Feb  3 13:26:23 localhost ipop3d[24301]: pop3 service init from 12.208.200.41
    Feb  3 13:26:27 localhost ipop3d[24301]: Command stream end of file while reading line user=web1_webmaster host=12-208-200-41.client.insightBB.com [12.208.200.41]
    Feb  3 13:44:57 localhost ipop3d[24513]: pop3 service init from 12.208.200.41
    Feb  3 13:45:00 localhost ipop3d[24513]: Command stream end of file while reading line user=web1_webmaster host=12-208-200-41.client.insightBB.com [12.208.200.41]
    Feb  3 13:45:04 localhost ipop3d[24516]: pop3 service init from 12.208.200.41
    Feb  3 13:45:07 localhost ipop3d[24516]: Command stream end of file while reading line user=web1_webmaster host=12-208-200-41.client.insightBB.com [12.208.200.41]
    Feb  3 13:45:08 localhost ipop3d[24517]: pop3 service init from 12.208.200.41
    Feb  3 13:45:11 localhost ipop3d[24517]: Command stream end of file while reading line user=web1_webmaster host=12-208-200-41.client.insightBB.com [12.208.200.41]
    Feb  3 13:45:13 localhost ipop3d[24518]: pop3 service init from 12.208.200.41
    Feb  3 13:45:16 localhost ipop3d[24518]: Command stream end of file while reading line user=web1_webmaster host=12-208-200-41.client.insightBB.com [12.208.200.41]
    
     
    Last edited: Feb 3, 2006
  16. falko

    falko Super Moderator

    You're using ipop3d which means you must disable Maildir in ISPConfig under Management -> Server -> Settings -> Email.

    After that, I'd simply restart ipop3d and see if the error persists:
    Code:
    /etc/init.d/inetd restart
    Also, make sure you send an email first to that account before you try to fetch emails.
     
  17. Gem

    Gem New Member

    The box for Maildir is disabled, it is not checked anyway.

    I tried to restart ipop3d using

    Code:
    /etc/init.d/inetd restart
    Got an error saying there was no such file :cool:
     
  18. falko

    falko Super Moderator

    Then I guess you're using xinetd. Try
    Code:
    /etc/init.d/xinetd restart
    Which distribution do you use?
     

Share This Page