Can't receive email from external domains

Discussion in 'Installation/Configuration' started by DAC, Jul 11, 2013.

  1. DAC

    DAC New Member

    Hi,
    I can't receive email from external domains, i can send mails from my server using Outlook and Squirrel mail but i can't receive any .
    I use Debian 6 and Postfix on VPS.

    In Yahoo i get this message :

    Code:
    Sorry, we were unable to deliver your message to the following address.
    
    <info@mydomain.eu>:
    No MX or A records for mydomain.eu
    When i debug i get this:

    Code:
    Jul 10 16:03:55 s1 postfix/smtp[4832]: 6E19A324263C: to=<root@s1.mydomain.eu>, orig_to=<root>, relay=
    none, delay=1494, delays=1477/0.02/16/0, dsn=4.4.3, status=deferred (Host or domain name not fou
    nd. Name service error for name=s1.mydomain.eu type=MX: Host not found, try again)
    My DNS is like this:

    Code:
    $TTL    86400
    @       IN      SOA     ns.domain.eu. {dnsemail} (
                            {serial}     ; Serial, this is [url]www.ehcp.net[/url] dns zone template file.. 
                            10800   ; Refresh
                            1200     ; Retry
                            86400  ; Expire
                            86400 ) ; Minimum
    
    domain.eu.           IN NS   ns.domain.eu.
    ns.domain.eu.        IN A    {dnsip}
    ns1.domain.eu.       IN A    {dnsip}
    ns2.domain.eu.       IN A    {dnsip}
    dns.domain.eu.       IN A    {dnsip}
    dns1.domain.eu.       IN A    {dnsip}
    dns2.domain.eu.       IN A    {dnsip}
    domain.eu.           IN A    {webip}
    mail.domain.eu.      IN A    {mailip}
    smtp.domain.eu.   IN A    {webip}
    imap.domain.eu.   IN A    {webip}
    webmail.domain.eu.   IN A    {webip}
    ftp.domain.eu.       IN CNAME        domain.eu.
    [url]www.domain.eu[/url].       IN CNAME        domain.eu.
    domain.eu.           IN MX  10 mail.domain.eu.
    domain.eu.           IN TXT "v=spf1 a mx"
    
    {customdns}
    
    *                       IN A    {webip}
    Need to mention also , i changed default port 25 for SMTP to 587 by adding submission inet n - - - - smtpd in /etc/postfix/master.cf , port 25 was bloked by ISP.
    I appreciate any help in solving this .

    P.S. Sorry in advance if i ask stupid questions i'm just a beginner.
     
    Last edited: Jul 11, 2013
  2. DAC

    DAC New Member

    Solved the problem.
    Seems so..odd..but this is what i did:
    Instead of having submission inet n - - - - smtpd at the bottom of the file i changed in top right under smtp inet n - - - - smtpd

    # ==========================================================================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ==========================================================================
    smtp inet n - - - - smtpd
    submission inet n - - - - smtpd
     

Share This Page