Can't receive email for aliases

Discussion in 'Installation/Configuration' started by sbecker, Mar 28, 2006.

  1. sbecker

    sbecker New Member

    I have setup a website at www.xyz.com (not the real domain name) and I have created a user account for scott@xyz.com

    I can send and receive email for this account fine.

    I created an email alias in ISPConfig for smb@xyz.com (typed "smb" into the email alias field).

    I can't receive email for this alias, and when i attempt to send to smb@xyz.com, my email bounces back with:

    Code:
    This is an automatically generated Delivery Status Notification
    
    Delivery to the following recipient failed permanently:
    
        smb@www.xyz.com
    
    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 9): 550 <smb@www.xyz.com>: Recipient address rejected: User unknown in local recipient table
    
    I checked my /etc/postfix/virtusertable file and I don't see "smb" anywhere in it. I assume this is where its supposed to be?

    What i do see for xyz.com is:
    Code:
    scott@www.xyz.com    web6_scott
    web6_scott@www.xyz.com    web6_scott
    scott@xyz.com    web6_scott
    web6_scott@xyz.com    web6_scott
    
    but no mention of my aliases. When I edit the record in ISPConfig, it does show "smb" in the Email Aliases field. What gives? Is it in another file?
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Any errors in /home/admispconfig/ispconfig/ispconfig.log?
    Please post the output of
    Code:
    ls -la /root/ispconfig
     
  3. sbecker

    sbecker New Member

    Nope, no errors in /home/admispconfig/ispconfig/ispconfig.log

    The only thing I could see were some warnings about not being able to set quota for a user I deleted, but was still in the recycle bin. I have since emptied the recyle bin, so probably won't see this anymore:

    Code:
    27.03.2006 - 22:48:18 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 929: WARNING: could not setquota -u web10_ahh 0 0 0 0 -a &> /dev/null
    2
    
    I ran "tail -f /home/admispconfig/ispconfig/ispconfig.log" and watched what it output when I saved an email alias, which was:

    Code:
    28.03.2006 - 17:16:41 => INFO - Signalfile Set: update
    28.03.2006 - 17:17:00 => INFO - Signalfile Set: update
    28.03.2006 - 17:17:43 => INFO - Signalfile Set: update
    28.03.2006 - 17:17:52 => INFO - Signalfile Set: update
    
    Here is the output of "ls -la /root/ispconfig"

    Code:
    total 83
    drwxr-xr-x   9 root root  1024 Mar 27 22:41 .
    drwxr-xr-x   5 root root  1024 Mar 25 16:09 ..
    -rw-r--r--   1 root root     0 Mar 27 23:44 .ispconfig_lock
    -rw-r--r--   1 root root     8 Mar 27 22:40 .old_path_httpd_root
    -rwxr-xr-x   1 root root 54208 Mar 23 22:56 cronolog
    -rwxr-xr-x   1 root root  9673 Mar 23 22:56 cronosplit
    drwxr-xr-x  12 root root  1024 Mar 23 22:45 httpd
    drwxr-xr-x  12 root root  1024 Mar 23 22:56 isp
    drwxr-xr-x   6 root root  1024 Mar 23 22:43 openssl
    drwxr-xr-x   6 root root  1024 Mar 23 22:52 php
    drwxr-xr-x   4 root root  1024 Mar 23 22:56 scripts
    drwxr-xr-x   4 root root  1024 Mar 23 22:56 standard_cgis
    drwxr-xr-x   2 root root  1024 Mar 23 22:56 sv
    -rwx------   1 root root  9128 Mar 23 22:56 uninstall
    
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please execute:

    rm -f /root/ispconfig/.ispconfig_lock

    Then restart ISPConfig:

    /etc/init.d/ispconfig_server restart

    When you change a user in the ispconfig interface, do the aliases get written now?
     
  5. sbecker

    sbecker New Member

    No luck.

    Aliases do not get written. New users don't seem to get written to /etc/postfix/virtusertable either. That was working before. Something is definitely messed up.

    Should I reinstall? Can I reinstall without overwriting data?
     
  6. sbecker

    sbecker New Member

    Based on some other threads on this forum, I tried running:

    Code:
    rm -f /root/ispconfig/.ispconfig_lock
    /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php
    
    and of course I get:
    Code:
    start
    Segmentation fault
    
    I am running on a Xen VPS (Debian 3.1) with 128 megs of RAM (and 256 swap). Do you think it being a VPS could cause the Segmentation fault? I don't think I have a way of running memtest86 on it because I can't boot it from a floppy, I can only connect to it remotely and start/stop it from a web control panel.

    Is there any other options?
     
  7. sbecker

    sbecker New Member

    I ran it with strace:
    Code:
    strace /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php
    
    and the last few lines before it dies are:

    Code:
    fstat64(5, {st_mode=S_IFREG|0644, st_size=249582, ...}) = 0
    lseek(5, 0, SEEK_CUR)                   = 0
    lseek(5, 0, SEEK_CUR)                   = 0
    write(5, "29.03.2006 - 12:05:35 => WARN - "..., 150) = 150
    close(5)                                = 0
    getcwd("/etc/init.d", 4096)             = 12
    time(NULL)                              = 1143662735
    open("/etc/passwd", O_RDONLY)           = 5
    fstat64(5, {st_mode=S_IFREG|0644, st_size=3093, ...}) = 0
    lseek(5, 0, SEEK_CUR)                   = 0
    stat64("/etc/passwd", {st_mode=S_IFREG|0644, st_size=3093, ...}) = 0
    read(5, "root:x:0:0:root:/root:/bin/bash\n"..., 8192) = 3093
    close(5)                                = 0
    --- SIGSEGV (Segmentation fault) @ 0 (0) ---
    +++ killed by SIGSEGV +++
    
    every time. Seems to be dying when it reads the root password.
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which linux distribution do you use? 32 or 64 Bit?

    I guess the root password line in /etc/passwd contains nothing special?
     
  9. sbecker

    sbecker New Member

    32 bit.

    root password line in /etc/passwd:

    root:x:0:0:root:/root:/bin/bash
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Normally a segmentation fault is a hint for a hardware problem, but I don't know if this applies to virtual machines as well...
     
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which linux distribution do you use and which processor?
     

Share This Page