Can't receive any messages using Postfix

Discussion in 'Installation/Configuration' started by Philippe Gamache, Feb 22, 2006.

  1. Philippe Gamache

    Philippe Gamache New Member

    Can't receive any messages using Postfix
    here my main.cf
    There are no error in the log that I can find.

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    myhostname = hd-t1461cl.privatedns.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = server1.voxlib.com, hd-t1461cl.privatedns.com, localhost.privatedns.com, localhost
    relayhost = 
    mynetworks = 127.0.0.0/8
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    mailbox_command = 
    mydestination = /etc/postfix/local-host-names
    relay_domains = $mydestination
    virtual_maps = hash:/etc/postfix/virtusertable
    unknown_local_recipient_reject_code = 450
    
     
  2. till

    till Super Moderator

    If you use courier or dovecot as pop3 daemon, you have to check the "maildir" Checkbox in ISPConfig under management > server > settings on the mail tab.
     
  3. Philippe Gamache

    Philippe Gamache New Member

    Yes, I'm using Courier and Maildir is check!
     
  4. till

    till Super Moderator

    1) Did the emails get to your server at all. Did you get any new log entrys when you send an email to your server? If yes, please post them.

    2) If mails get to your server, did they arrive at the users maildir or maybe in /var/spool/mail?

    3) Please try to deactivate things like mailscan, antivirus etc. in this account and check if emails arrive then.
     
  5. Philippe Gamache

    Philippe Gamache New Member

    Hum, Yes it did, here what i did find in mail.log...


    Code:
    Feb 22 10:39:12 hd-t1461cl postfix/smtpd[17340]: connect from ws6-6.us4.outblaze.com[205.158.62.64]
    Feb 22 10:39:12 hd-t1461cl postfix/smtpd[17340]: 72F052023A: client=ws6-6.us4.outblaze.com[205.158.62.64]
    Feb 22 10:39:12 hd-t1461cl postfix/cleanup[17344]: 72F052023A: message-id=<20060222153927.45C01DA4C3@ws6-6.us4.outblaze.com>
    Feb 22 10:39:12 hd-t1461cl postfix/smtpd[17340]: disconnect from ws6-6.us4.outblaze.com[205.158.62.64]
    Feb 22 10:39:12 hd-t1461cl postfix/qmgr[17032]: 72F052023A: from=<philippe@gamache.com>, size=1202, nrcpt=1 (queue active)
    Feb 22 10:39:12 hd-t1461cl postfix/smtp[17345]: 72F052023A: to=<philippe.gamache@server1.voxlib.com>, orig_to=<philippe.gamache@voxlib.com>, relay=none, delay=0, status=bounced (Host or domain name not found. Name service error for name=server1.voxlib.com type=A: Host not found)
    Feb 22 10:39:12 hd-t1461cl postfix/cleanup[17344]: 9620E20267: message-id=<20060222153912.9620E20267@hd-t1461cl.privatedns.com>
    Feb 22 10:39:12 hd-t1461cl postfix/qmgr[17032]: 9620E20267: from=<>, size=3226, nrcpt=1 (queue active)
    Feb 22 10:39:12 hd-t1461cl postfix/qmgr[17032]: 72F052023A: removed
    Feb 22 10:39:24 hd-t1461cl postfix/smtp[17348]: 9620E20267: to=<philippe@gamache.com>, relay=neti-outblaze-com.mr.outblaze.com[205.158.62.230], delay=12, status=sent (250 Ok: queued as 506AF1AC562)
    Feb 22 10:39:24 hd-t1461cl postfix/qmgr[17032]: 9620E20267: removed
     
  6. till

    till Super Moderator

    Your server name server1.voxlib.com can not be resolved in DNS. Go to the primary nameserver of voxlib.com and add an A-Record for server1.voxlib.com pointing to your IP address.
     
  7. Philippe Gamache

    Philippe Gamache New Member

    Ok, thanx, but why it is using this name?
     
  8. till

    till Super Moderator

    I guess that this is the name you entered as you instaled your linux box? The name might be stored in /etc/hostname.
     
  9. Philippe Gamache

    Philippe Gamache New Member

    No, it not...

    Look like the default name when seting ISPConfig.
     
  10. till

    till Super Moderator

    No. ISPConfig has no default name and it does not configure your server name at all.

    You are sure you dont enter the name as you setup your linux box? Which Linux distribution do you use? Did you suse one of the perfect setup howtos?
     
  11. Philippe Gamache

    Philippe Gamache New Member

    I install with the perfect_setup_debian_sarge...

    I didn't make the initial setup, it was a bare installation, with SSH, so i could connect to it.

    Should my servername be the one in etc/hostname ???
     
  12. falko

    falko Super Moderator

    To set another hostname, do this:

    Code:
    echo server1.example.com > /etc/hostname
    /bin/hostname -F /etc/hostname
    Also check /etc/hosts.
     

Share This Page