can't reach public_adress:8080

Discussion in 'Installation/Configuration' started by djenojado, Apr 4, 2010.

  1. djenojado

    djenojado New Member


    I can now log in to my ISPconfig if I use a lan-adress :
    If I change the IP-adress to
    It still work.

    But when I changes my ip-adress to a public adress: 193.*.*.*:8080
    (I also changed my dns adress in /etc/resolv.conf)
    Now ISPconfig doesn't work.

    But my dns is correct because when i try my two domains, it points correctly to my server.

    Welcome to your website!
    This is the default index page of your website.

    This file may be deleted or overwritten without any difficulty. This is produced by the file index.html in the web directory.

    For questions or problems please contact support.

    Powered by ISPConfig

    I use centos 5.4 and ispconfig 3.

    Whats wrong?

    Thanks. :)

  2. zenny

    zenny Member

    Could be two reasons, imo

    1) Maybe your ISP blocked the 8080 port.

    Solution: In that case change it to a port that is open and enable ssl for security (Read Till's comprehensive post here:

    2) Maybe you are using a firewall like shorewall and you set a policy now allowing anything from net to your machine. Maybe some rules. And in case of shorewall, it is categorically warned by the developer of Shorewall (Tom Eastep) that one cannot access the machine from inside (loc) using the pulbic IP.

    Solution: Install tor and polipo in your machine ( and then install tor button in your firefox. Then point your public IP to your port and you can render the pages.

    Hope that helps. z
  3. BorderAmigos

    BorderAmigos New Member

    Also, if you have local and public addresses are you using a router? Is the router set to forward port 8080 to the correct local address?
  4. djenojado

    djenojado New Member

    thanks for your reply!

    If I try cmd: telnet public_ip 8080 it's work - that's really strange for me.

    Just in case, I tried this ->

    Nothing happen.

    I use iptables and I have turned port 8080 on. i have even turn iptable off.
    still not work (telnet public_adr 8080 - work). but webmail phpmyadmin and other sites work very well, but not ISPconfig.

    I go back to my ordinary lan ip-address, ispconfig work. hehe..

    I can't understand why ispconfig not work in my public_adress:8080
    I have even installed ispconfig to use port 80 and 443.
  5. djenojado

    djenojado New Member

    Hi. thanks for you reply. yes it is. :)
  6. djenojado

    djenojado New Member

    I think i found whats wrong.
    I used this commando -->
    apachectl -S

    printed -->
    VirtualHost configuration:
    wildcard NameVirtualHosts and _default_ servers:
    _default_:443 (/etc/httpd/conf.d/ssl.conf:86)
    *:8080 is a NameVirtualHost
    default server (/etc/httpd/conf/sites-enabled/000-ispconfig.vhost:10)
    port 8080 namevhost (/etc/httpd/conf/sites-enabled/000-ispconfig.vhost:10)
    *:80 is a NameVirtualHost
    default server (/etc/httpd/conf/sites-enabled/
    port 80 namevhost (/etc/httpd/conf/sites-enabled/
    Syntax OK


    Ip address should be my public address, right?
    How do i change it?
    When i try for example to cat 000-ispconfig.vhost:10, i got nothing out.
  7. djenojado

    djenojado New Member


    I forgot to change IP-address at: ServerName 193.*.*.*:80
    in /etc/httpd/conf/httpd.conf



Share This Page