Can't mount RAID5...

Discussion in 'Installation/Configuration' started by jdlvfr, Nov 1, 2006.

  1. jdlvfr

    jdlvfr New Member

    Hi all,

    just migrating from Mandriva to Debian and I can't mount my raid array no more.
    When I boot on Mandriva the raid is ok. I can mount it. Debian just doesn't want!
    I've run Fsck from mandriva, no problem found.

    Surely i've missed something but I can't figure what...

    Any clue???

    joel

    Dmesg gives:

    raid5: automatically using best checksumming function: generic_sse
    generic_sse: 5464.000 MB/sec
    raid5: using function: generic_sse (5464.000 MB/sec)
    md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
    md: bitmap version 4.39
    raid6: int64x1 1644 MB/s
    raid6: int64x2 2125 MB/s
    raid6: int64x4 2078 MB/s
    raid6: int64x8 1449 MB/s
    raid6: sse2x1 632 MB/s
    raid6: sse2x2 933 MB/s
    raid6: sse2x4 1371 MB/s
    raid6: using algorithm sse2x4 (1371 MB/s)
    md: raid6 personality registered for level 6
    md: raid5 personality registered for level 5
    md: raid4 personality registered for level 4
    md: md0 stopped.
    md: bind<hdf>
    md: bind<hdg>
    md: bind<hdh>
    md: bind<hde>
    raid5: device hde operational as raid disk 0
    raid5: device hdh operational as raid disk 3
    raid5: device hdg operational as raid disk 2
    raid5: device hdf operational as raid disk 1
    raid5: allocated 4276kB for md0
    raid5: raid level 5 set md0 active with 4 out of 4 devices, algorithm 2
    RAID5 conf printout:
    --- rd:4 wd:4 fd:0
    disk 0, o:1, dev:hde
    disk 1, o:1, dev:hdf
    disk 2, o:1, dev:hdg
    disk 3, o:1, dev:hdh


    # cat /proc/mdstat
    Personalities : [raid6] [raid5] [raid4]
    md0 : active raid5 hde[0] hdh[3] hdg[2] hdf[1]
    1172133888 blocks level 5, 64k chunk, algorithm 2 [4/4] [UUUU]

    unused devices: <none>


    And near the end :

    EXT3-fs error (device md0): ext3_check_descriptors: Block bitmap for group 880 not in group (block 67108864)!
    EXT3-fs: group descriptors corrupted!


    If I try to mount :

    #mount /dev/md0 /mnt/raid
    mount: wrong fs type, bad option, bad superblock on /dev/md0,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Is it software or hardware RAID? What kind of hard disks do you use (SATA, IDE,...)? Which Debian kernel?
     
  3. jdlvfr

    jdlvfr New Member

    Kernel is 2.6.17-2-amd6, RAID is software with 4 IDE disk and a PCI IDE controller:

    02:0a.0 Mass storage controller: Promise Technology, Inc. 20269 (rev 02) (prog-if 85)
    Subsystem: Promise Technology, Inc. Ultra133TX2

    Mandriva's kernel is 2.6.17 based.

    joel
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What file system do you use on the disks? Is it supported by your Debian kernel?
     
  5. jdlvfr

    jdlvfr New Member

    File system is ext3, and there's no problem with the two other non raid ext3fs hard disks.

    joel
     

Share This Page