Can't login with user account (ftp)

Discussion in 'General' started by linuxfast, Sep 15, 2005.

  1. linuxfast

    linuxfast New Member

    Another problem now, didn't know if I should make a new post or use my last one but here goes anyway.

    After creating a user for my newly created site, I cannot login with the user account (tested using ftp).

    I notice that the record in isp_isp_user for the user I created has a blank user_passwort field.
    Is this normal ?

    I have tried changing the password but no luck

    Please help !
     
  2. till

    till Super Moderator

    Yes. For security reasons the passwords are only stored in /etc/shadow.

    Have you checked the FTP checkbox for this website?

    If yes, check your /etc/passwd file if the user has been created there by ISPConfig.
     
    Last edited: Sep 15, 2005
  3. linuxfast

    linuxfast New Member

    Thanks for the quick reply.

    Yes FTP is enabled for the site (via the checkbox)

    test:x:10007:10008:Test:/home/www/web8/user/test:/bin/false
    another:x:10005:10008:Another Test:/home/www/web8:/bin/false

    appear in the passwd file.

    Passwords appear for both in the shadow file too.
     
  4. falko

    falko Super Moderator

    Can you send emails with these users? Maybe you have a problem with FTP as already some others had in this forum (with Fedora Core 4).
     
  5. linuxfast

    linuxfast New Member

    I cannot login to UebiMiau with either account :confused:
     
  6. falko

    falko Super Moderator

    In Uebimiau you have to use the email address as username. Did you do that?
     
  7. linuxfast

    linuxfast New Member

    Yes I used the email addresses

    Even more strange, I CAN login using web-ftp

    Tried restarting ftp, tried rebooting, tried another ftp client.
     
    Last edited: Sep 15, 2005
  8. till

    till Super Moderator

    can you post the output from the command:

    netstat -tap

    Maybe your FTP Daemon listens only on localhost. Have you installed an additional firewall?
     
  9. falko

    falko Super Moderator

  10. linuxfast

    linuxfast New Member

    tcp 0 0 *:ftp *:* LISTEN 25663/proftpd: (acc


    I guess that means listen on all interfaces ?
    FTP client tries to connect but gets invalid username or password

    Firewall, I am using Ispconfig firewall and definitely no others.
     
  11. linuxfast

    linuxfast New Member

    Falko, your /etc/pam.d/ftp file fixed it !
    Perfect, thanks.

    Also the webmail appears to be working now, I am guessing that I typed the password incorrectly earlier.

    Thanks Falko/till
    :D
     

Share This Page