Can't login with FTP users

Discussion in 'General' started by Gyrfalcon, Jul 10, 2013.

  1. Gyrfalcon

    Gyrfalcon New Member

    Hello,

    We're trying to build a VPS on Debian 6, Apache2 with ISPConfig 3. Until yesterday we can login with our ftp user on our server with FTP clients. But I don't know how we can't login right now. FTP client gives 530 Login incorrect error.

    Yesterday we set up Webmin on our server. We identified our domains on Apache and edited Suhosin configuration because of our forum software IPB wanted that.

    After these configuration we can't log into FTP. We try to make a new user in Ispconfig 3, tried different FTP clients but it didn't work.

    SSH working fine but FTP isn't working. What should we do right now? How can we solve that problem? Could you help please.
     
  2. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Could it be that webmin altered the ftp server configuration?
    In my opinion it is not a good idea to use webmin on an ispconfig server as it alters some configs that it shouldn't.
    Have you checked the ftp server error logs?
     
  3. Gyrfalcon

    Gyrfalcon New Member

    We're using ProFTPD and we've checked the logs, they contains those errors. Here they are, I censored sensetive informations.

    It continues like that. I tried to restart ProFTPD, didn't work. We checked "Denied Users" section, our user isn't in there.
     
  4. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    ISPConfig does not support proftp yet. ISPConfig uses pure-ftp.
    Have you altered your ISPConfig installation to use proftp?
    Maybe you have overwritten the pure-ftp with proftp so it cannot find any of the client's ftp accounts set up in ISPConfig.

    First I'd try just to stop proftp and start pure-ftp (if it is installed, too).
     
  5. Gyrfalcon

    Gyrfalcon New Member

    I hope it is like that. Here is the story.

    ProFTPD is running right now and there isn't Pure-FTP module. I think you are right, it had overwritten because of I see Pure-FTP's folder on etc/pure-ftp.

    What should I do know? How can I install Pure-FTP or how can I active ProFTPD on Ispconfig 3? I'm a starter on these works. Could you help a little more?

    EDIT: I checked ISPConfig 3 panel right now and it says: FTP server isn't working.
     
    Last edited: Jul 10, 2013
  6. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Ok, what I'd do is this:

    Stop proftpd service.
    Install pure-ftpd (maybe this removes proftpd automatically)
    Start pure-ftpd service and check if everything works again.
    If not - make an ISPConfig update (/usr/local/ispconfig/server/scripts/update_from_tgz.sh) and choose "YES" when it asks if it shall reconfigure services.
     
  7. Gyrfalcon

    Gyrfalcon New Member

    FTP server is active right now. But everything isn't working properly. We still can't login to FTP, same error.

    One more thing, we can't do "/usr/local/ispconfig/server/scripts/update_from_tgz.sh" command. It said that there was no update.
     
  8. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Hm, are you sure that you used the update_from_tgz.sh and not the ispconfig_update.sh? The second checks for updates, the first installs the current stable even if it is the same version.
     
  9. Gyrfalcon

    Gyrfalcon New Member

    Thank you so much Croydon. We fixed it. It is working properly right now. At least next error. :)
     
  10. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You're welcome. Just make sure you do not overwrite pure-ftp with proftp again ;D
     

Share This Page