Can't login to webmail

Discussion in 'Installation/Configuration' started by OnTheRun, Nov 30, 2005.

  1. OnTheRun

    OnTheRun New Member

    Hello all,
    thanks for developping such a great system. I just love it!
    I set up ispconfig on debian 3.1. Most of the things went without problems, not so the email.
    I thought I'd test it first with an account on some domain. So I created a user (web7_user i.E.) and gave him a password. I then tried to login into ftp, which went without any problem. But when I try to log onto webmail (using UebiMiau) I always get the message: You cannot login with the username and password entered.
    I used exactly the same logins as for the ftp (web7_user, 123456). In /var/log/mail.log I get:

    Nov 30 21:18:53 myserver courierpop3login: Connection, ip=[::ffff:127.0.0.1]

    What could be the problem here?
    Everything else is working just fine :)
    Is it possible to have a system running with virutal users and domains with postfix, courier and mysql (like explained on http://howtoforge.com/virtual_postfix_mysql_quota_courier) but to generate the accounts in ispconfig (like i'm now doing it at the users&email-tab)?

    Thank you and with kind regards
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    http://www.howtoforge.com/forums/showthread.php?t=1187

    No, that doesn't work. ISPConfig 2 uses real system users for the email accounts. It will be possible in ISPConfig 3 which is currently developed.
     
  3. OnTheRun

    OnTheRun New Member

    Hello,
    thank you very much for your (quick :)) answer.
    I followed the example you make in the thread and added the user john.doe:

    Name: John Doe
    Email-Adresse: john.doe@domain.ch
    Username: web7_john
    Passwort: john

    I then sent this user an email via sendmail from the shell and got the following in /var/log/mail.log:

    Code:
    Nov 30 22:34:33 myserver postfix/pickup[11326]: 0569E300B0: uid=0 from=<root>
    Nov 30 22:34:33 myserver postfix/cleanup[11482]: 0569E300B0: message-id=<20051130213433.0569E300B0@myserver.mydomain.local.mydomain.local>
    Nov 30 22:34:33 myserver postfix/qmgr[11327]: 0569E300B0: from=<root@myserver.mydomain.local>, size=389, nrcpt=1 (queue active)
    Nov 30 22:34:33 myserver postfix/pickup[11326]: 0F495300B1: uid=10006 from=<web7_john>
    Nov 30 22:34:33 myserver postfix/cleanup[11482]: 0F495300B1: message-id=<20051130213433.0F495300B1@myserver.mydomain.local.mydomain.local>
    Nov 30 22:34:33 myserver postfix/qmgr[11327]: 0F495300B1: from=<web7_john@myserver.mydomain.local>, size=462, nrcpt=1 (queue active)
    Nov 30 22:34:33 myserver postfix/local[11504]: 0F495300B1: to=<admispconfig@localhost>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 30 22:34:33 myserver postfix/qmgr[11327]: 0F495300B1: removed
    Nov 30 22:34:34 myserver postfix/local[11483]: 0569E300B0: to=<web7_john@mydomain.local>, orig_to=<john.doe@domain.ch>, relay=local, delay=1, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 30 22:34:34 myserver postfix/qmgr[11327]: 0569E300B0: removed
    
    As far as I can see from the log evertyhing works fine: the mail gets delivered. So I tried to login with "john.doe@domain.ch" and "john" as passwort. But unfortunately I get the same message ("
    You cannot login with the username and password entered.") :(
    Do you have a clue, what this could be?

    Is it with the current mail-system allthough possible to use amavis and a av-program, which scans the mailboxes of the users?

    Thank you and with kind regards
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You're using Courier, right? Did you activate Maildir under Management -> Server -> Settings -> Email?

    In principle yes, but it will break the SpamAssassin and ClamAV that come with ISPConfig.
     
  5. OnTheRun

    OnTheRun New Member

    Thank you very much for your help!
    The problem was, that Maildir wasn't checked :)
    Now it works just fine.
    Something i couldn't find in the manual: How does the av works? Do I can control it manually? Or do I have any possibility to check the functionality of the av?

    Thank you very much and with kind regards
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You can find the SpamAssassin and ClamAV under "User & Email", on the tab "Spamfilter & Antivirus".
     
  7. OnTheRun

    OnTheRun New Member

    Hello,
    thank you for your answer :)
    Sorry for asking so much. What I meant was more on the server-side (console): does the av use virus-definition files? If so, do they need to get updated? Is there a commandline scanner?

    Thanks and with kind regards
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The antivirus package is clamav. It uses the "freshclam" program to update the virus definition files automatically. You can use clamav also for commandline scanning.
     

Share This Page