Can't Login to /stats - Yes the stats have run, Yes, I'm using correct user/pass

Discussion in 'Installation/Configuration' started by bpmee, Mar 10, 2007.

  1. bpmee

    bpmee New Member

    Hi All,

    I've searched all over the forum for a reply to my problem, but most posts only address about 1/2 the problem...So here goes:

    When I try to login to: www.mysite.com/stats WITH the correct user: web5_username and correct password I get a 401 "Authorisation" error...:confused:

    Yes - more than 24 hours have passed and the webalizer script has run. There is log data, so this is not the issue.

    Yes - the crontab contains the correct calls for the log processing script and the webalizer script.

    I'm on Fedora Core 5, ISPConfig 2.2.10

    Note:

    When I delete all .htaccess files in the /var/www/web5/web/stats folders, the problem goes away and I am not prompted for login credentials.

    But, this means my stats are unprotected!

    Also, I tried looking at ownership of my sites using the ls -l command, here is a sample, note I name my sites: web5_domain[com|net|us|biz etc]

    Code:
    
    
    drwxr-xr-x 9 web227_gocom                web227 4096 Mar  6 11:21 web227
    drwxr-xr-x 8 web238_mynet             web238 4096 Mar  6 04:00 web238
    drwxr-xr-x 9 web246_879com       web246 4096 Mar  6 04:00 web246
    drwxr-xr-x 9 web254_afesnet             web254 4096 Mar 10 10:19 web254
    drwxr-xr-x 8 apache                          web255 4096 Mar  8 11:19 web255
    drwxr-xr-x 8 apache                          web256 4096 Mar  8 11:16 web256
    drwxr-xr-x 8 apache                          web257 4096 Mar  8 11:20 web257
    drwxr-xr-x 8 apache                          web258 4096 Mar  6 04:00 web258
    
    
    Despite different ownerships, I still can't login so this may not be the problem!

    Thanks...
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look at the error log of the website, which error is logged there when you try to authenticate to the stats directory?
     
  3. bpmee

    bpmee New Member

    Found the error being created

    Hi Till/Falko/others:

    Here is the error that is being sent to my log:

    Code:
    [Mon Mar 12 10:28:55 2007] [error] [client 200.6.60.31] user web301_blogsnet: authentication failure for "/stats": Password Mismatch
    [Mon Mar 12 10:29:01 2007] [error] [client 200.6.60.31] user web301_blogsnet: authentication failure for "/stats": Password Mismatch
    
    
    Not sure what Password Mismatch means????:confused:
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You didn't use the correct password. You can try to set a new one in ISPConfig. But keep in mind that the .htpasswd file for the stats folder is updated only at 04.00h, so you won't be able to log in immediately.
     
  5. bpmee

    bpmee New Member

    Thanks - will wait until tomorrow to test again

    Hi Falko,

    Thanks - I've changed some passwords, and will wait until tomorrow to see if they updated correctly.
     
  6. tom

    tom Member

    If got the same situation. I've tried to run the script an 04.00h but still I cant log in the stats directory. This script I used:
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Is there anything in the stats directory? You can check with
    Code:
    ls -la /path/to/stats
    Also, stats are generated only if that web site has been accessed. If it hasn't been accessed, its access log is empty, and therefore no statistics are created.
     

Share This Page