Can't login to mail client

Discussion in 'Installation/Configuration' started by bswinnerton, Dec 16, 2007.

  1. bswinnerton

    bswinnerton New Member

    Hi there,

    I have what I hope is a quick question..

    I've just moved all of my mail, etc from my old server to my new one. However now none of my users can login except with the [domain]_username. They used to be able to login with just their email address. My virtusertable looks like this:

    emailaddress [domain]_username

    thanks!
     
  2. bswinnerton

    bswinnerton New Member

    I'm very confused. I'm moving over my server to a new one. They both are running ubuntu and ispconfig. For some reason none of the new email addresses that I make can login (They're actually just the usernames from the old server). But I can login to the ones I made before I started editing the virtusertable. On those I can only login on my [domain]_username not just the email account.

    Can anyone help?
     
  3. bswinnerton

    bswinnerton New Member

    Could it have anything to do with the fact that I haven't implemented the server yet? For example I haven't actually changed its ip address to what DNS is pointing to...

    P.S. I'm not sure if it will make any difference but i'm using RoundCube. Could it have something to do with the SQL database? Or would it be a virtusertable thing?
     
    Last edited: Dec 17, 2007
  4. bswinnerton

    bswinnerton New Member

    This is a very weird problem. It works for certain names. Now this is the exact process that I got some of them to work (Could have nothing to do with it).

    Went to ISPConfig, copied the username into my clipboard, changed the password and then went to my roundcube login page. Pasted the username and then put in the password that I reset. After that I login, and then logout again and try logging in as the email address instead of the username and it works. However that only works with some of the accounts, not others.

    Please help.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
    Please make sure that all user names are listed in /etc/passwd and /etc/shadow.
     
  6. bswinnerton

    bswinnerton New Member

    Yes all of the usernames are there, and in the correct form as well. If it helps any, I am going from just username to [domain]_username now, and in /etc/passwd and /etc/shadow they are listed as the correct form ([domain]_username)

    Here is my /var/mail.log when I try to login:

    Code:
    Dec 17 11:10:24 CW-Webserv imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 17 11:10:24 CW-Webserv imapd: LOGIN FAILED, user=bswinnerton, ip=[::ffff:127.0.0.1]
    Dec 17 11:10:29 CW-Webserv imapd: Disconnected, ip=[::ffff:127.0.0.1], time=5
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Which distribution are you using?
     
  8. bswinnerton

    bswinnerton New Member

    Gusty Gibbon for Ubuntu
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Not sure what the problem is...
    What's the output of
    Code:
    ls -l /bin/sh
    ?
     
  10. bswinnerton

    bswinnerton New Member

    Code:
    lrwxrwxrwx 1 root root 9 2007-07-28 13:50 /bin/sh -> /bin/bash
    Just for my own reference, what does that do?
     
  11. falko

    falko Super Moderator ISPConfig Developer

    /bin/sh -> /bin/bash is how it should be. It means that /bin/sh is a symlink to /bin/bash. The Ubuntu default is a symlink from /bin/sh to /bin/dash instead which can cause problems.
     
  12. bswinnerton

    bswinnerton New Member

    Hmm, so that means that everything is correct. Any other ideas?
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Unfortunately no... :(
     
  14. bswinnerton

    bswinnerton New Member

    For future reference for anyone else that seems to have this problem.. I realized what my problem was after re-doing my entire server.

    I didn't have the maildir checkbox enabled under Management > Server > Settings > E-Mail

    Hope no one else ever has this problem!
     

Share This Page