cant login to ispconfig 3

Discussion in 'General' started by epicuniversal, Jun 6, 2009.

  1. epicuniversal

    epicuniversal New Member

    I am having a weird problem when I try to login, I keep getting an ERROR on the admin account aswell as the client account. I did not change any of the passwords, and I dont believe to have changed somthing that could have caused this error. Is there a way to reset the admin password so that I can get back in? It says this over a red background:



    Password lost?"
    Last edited: Jun 6, 2009
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    If you have access to the ispc database you can simply set a new password entry in table sys_user.
    Just put a crypt-md5 or md5 encoded password there.
  3. epicuniversal

    epicuniversal New Member

    Thanks, that worked:).
  4. sergio.morales

    sergio.morales New Member

    Explain it to me like I'm a newbie

    Hi. I appreciate the response, especially the quickness, but I am not sure how to do what was explained.

    Can you please explain how to put the password into the database, especially the MD5 part?

    Thanks in advance!

  5. sergio.morales

    sergio.morales New Member

    OK, now I feel silly

    So after I posted my first response, I decided to see if I could do the password change. I went to the MD5 website, and got my password. I then went to the phpmyadmin tool on my computer and found that I could edit the password that way!!

    Thanks so much for all the help!!

  6. epicuniversal

    epicuniversal New Member

    login to phpmyadmin, and click on the database for ISPconfig. Then find sys_usr and click browse. Click edit on the admin row, and you can just paste your md5 password into that "passwort" field. Then you should be able to get back in with the new password. Now what I did is after I got in, I changed my password in the tools tab again just for the heck of it because I noticed differences between the characters that ISPconfig generated and the one that tool I showed you. for example:

    ispconfig: $1$Z{`QRpjG$OHaDcHf0KWqeMqQjSk3ou/ 922277dbfdd1b246c58ee8d1a297a6c4

    You dont have to do this, I just did it cuz it looked strange:).
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig uses crypt-md5 with salt for passwords by default as this is more secure then plain md5, but it has md5 as a fallback option. So the passwords look different as they are encoded with two different encryption methods.
  8. epicuniversal

    epicuniversal New Member

    Thanks Till for clearing that up.
  9. sergio.morales

    sergio.morales New Member

    Thank you all

    Thank you all for the help, and a special thanks to Till . . . he's saved my biscuits in the past and I didn't thank you then . . . So thanks to all and a posthumous thanks to Till . . .


Share This Page