Can't login after update to 3.0.4

Discussion in 'Installation/Configuration' started by dbvadmin, Nov 12, 2011.

  1. dbvadmin

    dbvadmin New Member

    [SOLVED] Can't login after update to 3.0.4

    Hi there.

    Started an update in the hosting control panel with Do ISPConfig-Update...
    After that the WebInterface was no longer reachable.

    Searched around a little bit and found that the update created an empty config.inc.php.

    copied back the config.inc.php from backup and run the ispconfig_update.sh from commandline.

    After all steps run successfully no login is possible. Logging in to mysql with root is ok, logging in with ispconfig withe the password from config.inc.php returns: ERROR 1045 (28000): Access denied for user 'ispconfig'@'localhost' (using password: YES)

    Logging in tho other services like IMAP or ftp is no longer working.

    Defined WebSites are running, other Databases are reachable...

    Fount nothing really helpful in any logs...

    My anyone can give me hints to search the Problem...

    Thnx and best regards.

    dbvadmin
     
    Last edited: Nov 12, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    From which version did you update? Which distribution do you use? How exactly did you run the update? From which directory? Did you do this as root?
     
  3. dbvadmin

    dbvadmin New Member

    Hi thx for reply.

    Forgot those things....

    Update from 3.0.3 on a debian 6 squeeze logged in as root.

    Startet the update from /opt/ispconfgi_install/install using the command php -q update.php

    Already tried to reset the admin-pw, but nothing changed.

    Think it's somewhere a problem accessing databases... but found nothing in logs. May you give me a hint, where to look after db-access-problems ?

    Thx for helping :)

    dbvadmin
     
  4. stone1555

    stone1555 New Member HowtoForge Supporter

    I'm new at this but check this file:

    /usr/local/ispconfig/server/lib/mysql_clientdb.conf

    and make sure your info is correct there.
     
  5. dbvadmin

    dbvadmin New Member

    Thx for your advice, but it's the correct value from the actual mysql-root account.

    Is there any chance to set debug values to any config file to get more information about what's going wrong ?

    dbvadmin
     
  6. dbvadmin

    dbvadmin New Member

    I've now activated the general.log option in my.cnf to check out what db-connections are wrong.

    Will update this thread when I found something.

    dbvadmin
     
  7. dbvadmin

    dbvadmin New Member

    partly successful...

    FOund wrong db-password in interface/config.inc.php

    Now I can log in to the Interface, but at the Moment no ftp or Mail-Login possible...

    Where are the passwords for those services stored ?

    dbvadmin
     
  8. stone1555

    stone1555 New Member HowtoForge Supporter

    Try starting the services manually and see what you get. When you try to ftp or connect to webmail, whats the error your getting? All the ftp and mail passords / logins should be stored in mysql table. you may also want to login to phpmyadmin as root and double check your data exists.
     
  9. dbvadmin

    dbvadmin New Member

    GEtting further and further....

    It seems the configs of the services had the wrong passwort. e.g. /etc/courier/authmysqlrc

    Set the correct pw and restarted courier-authdaemon and can access squirrel.

    Will check all other services, but will give a summary at the end :)

    Best regards.

    dbvadmin
     
  10. dbvadmin

    dbvadmin New Member

    OK, got it all running...

    Copied the complete etc-dir to a local drive and searched for the wrong passwort. Replaced it in every file, where it's been found and rebootet the machine.

    Now everything is well running again.

    Thx for any hint :)

    Best regards,

    dbvadmin
     

Share This Page