Cant log into webmail

Discussion in 'Installation/Configuration' started by Check, Mar 4, 2007.

Thread Status:
Not open for further replies.
  1. Check

    Check New Member

    I have the site set up and when i go to www.mysite.com it takes me there fine. However, when i got to https://www.mysite.com:80/webmail it prompts my about the certificate and then takes me to a page cannot be found. Also, when im signed in under the admin account into ispconfig, and then go to tools, and then webmail, the page does get disaplyed. But its at https://192.168.1.70:80/webmail. once the page is done i try to log in and it says You cannot login with the username and password entered.

    Please check your username and password and try again.


    but i know they are right. Any ideas.

    Thanks

    EDIT: The services are all say online, if that means anything.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please try https://www.mysite.com:80/webmail/ instead.

    You must send an email to that user first before you can log in for the first time.
     
  3. Check

    Check New Member

    The slash at the end was definately the problem. I am now able to get to the sign on page fine.

    However, Ive sent a test message and it still is giving me the same error message.

    I've tried logging in as test and as [email protected] (the email address is test, the username is web1_test)

    Thanks for the help with the first thing...any ideas on this?

    One other thing, I cannot get to the webmail from outside of my network. I am forwarding port 81 to the server just as i am email and web. Web is working from the outside.
     
    Last edited: Mar 5, 2007
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    netstat -tap
     
  5. Check

    Check New Member

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State                                                                                    PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN     3                                                                             407/mysqld
    tcp        0      0 *:81                    *:*                     LISTEN     1                                                                             2972/ispconfig_htt
    tcp        0      0 server1.mydomain:domain *:*                     LISTEN     2                                                                             178/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN     2                                                                             178/named
    tcp        0      0 *:smtp                  *:*                     LISTEN     6                                                                             392/master
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     2                                                                             178/named
    tcp        0      0 localhost.localdo:37086 localhost.localdoma:www TIME_WAIT  -                                                                             
    tcp6       0      0 *:imaps                 *:*                     LISTEN     3                                                                             532/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     3                                                                             576/couriertcpd
    tcp6       0      0 *:pop3                  *:*                     LISTEN     3                                                                             552/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     3                                                                             501/couriertcpd
    tcp6       0      0 *:www                   *:*                     LISTEN     5                                                                             372/apache2
    tcp6       0      0 *:ftp                   *:*                     LISTEN     6                                                                             289/proftpd: (acce
    tcp6       0      0 *:ssh                   *:*                     LISTEN     3                                                                             678/sshd
    tcp6       0      0 *:smtp                  *:*                     LISTEN     6                                                                             392/master
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     2                                                                             178/named
    tcp6       0      0 *:https                 *:*                     LISTEN     5                                                                             372/apache2
    tcp6       0   1036 server1.mydomain.co:ssh ::ffff:192.168.1.1:3810 ESTABLISHED1                                                                             2017/sshd: adminis
     
  6. Hans

    Hans Moderator ISPConfig Developer

    Try to login with the loginname/password NOT an alias/password.
     
  7. Check

    Check New Member

    I've tried all three test, web1_test, and [email protected]. There is one other admin account. It is not a catch all. It does have a forward. the test account has no aliases or forwards and is not an admin account. I cannot sign in on the admin account either but i wasnt sure if it would let me because of the forwarder being set up. This test email should let me sign in. The admin doesnt forward emails either. I think something isnt started or setup properly, i just dont know enough about linux to know what to look at or fix.

    Thanks
     
  8. falko

    falko Super Moderator ISPConfig Developer

  9. Check

    Check New Member

    Sorry but, Can you tell me how to get to that log?
     
  10. falko

    falko Super Moderator ISPConfig Developer

    The mail log is in /var/log. Depending on your distribution it's /var/log/mail.log, /var/log/maillog, /var/log/mail, etc.
     
  11. Check

    Check New Member

    im running ubuntu 6.10- it was called mail.log
    Code:
    Mar  6 23:59:03 server1 postfix/master[25211]: daemon started -- version 2.3.3, configuration /etc/postfix
    Mar  7 04:41:01 server1 postfix/smtpd[32490]: cannot load Certificate Authority data
    Mar  7 04:41:01 server1 postfix/smtpd[32490]: warning: TLS library problem: 32490:error:02001002:system library:fopen:No such file or directory:bss_file.c:122:fopen('/etc/postfix/ssl/cacert.pem','r'):
    Mar  7 04:41:01 server1 postfix/smtpd[32490]: warning: TLS library problem: 32490:error:2006D080:BIO routines:BIO_new_file:no such file:bss_file.c:125:
    Mar  7 04:41:01 server1 postfix/smtpd[32490]: warning: TLS library problem: 32490:error:0B084002:x509 certificate routines:X509_load_cert_crl_file:system lib:by_file.c:274:
    Mar  7 04:41:06 server1 postfix/smtpd[32490]: connect from unknown[146.82.219.7]
    Mar  7 04:41:06 server1 postfix/smtpd[32490]: lost connection after CONNECT from unknown[146.82.219.7]
    Mar  7 04:41:06 server1 postfix/smtpd[32490]: disconnect from unknown[146.82.219.7]
    Mar  7 04:44:26 server1 postfix/anvil[32497]: statistics: max connection rate 1/60s for (smtp:146.82.219.7) at Mar  7 04:41:06
    Mar  7 04:44:26 server1 postfix/anvil[32497]: statistics: max connection count 1 for (smtp:146.82.219.7) at Mar  7 04:41:06
    Mar  7 04:44:26 server1 postfix/anvil[32497]: statistics: max cache size 1 at Mar  7 04:41:06
    Mar  7 12:26:42 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:42 server1 last message repeated 2 times
    Mar  7 12:26:42 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:42 server1 courierpop3login: Disconnected, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:42 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:42 server1 courierpop3login: LOGIN FAILED, user=!#, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:42 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:43 server1 courierpop3login: LOGIN FAILED, user=!$, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:43 server1 courierpop3login: LOGIN FAILED, user=!@, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:52 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:52 server1 courierpop3login: Disconnected, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:52 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:52 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:52 server1 courierpop3login: Disconnected, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:52 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:53 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:53 server1 courierpop3login: Disconnected, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:53 server1 courierpop3login: LOGIN FAILED, user=1qw23e, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:53 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:53 server1 courierpop3login: LOGIN FAILED, user=1x2y3z, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:53 server1 courierpop3login: LOGIN FAILED, user=2, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: Disconnected, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: Disconnected, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: Disconnected, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: LOGIN FAILED, user=5252, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: LOGIN FAILED, user=54321, ip=[::ffff:63.196.95.26]
    Mar  7 12:26:58 server1 courierpop3login: LOGIN FAILED, user=55, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:03 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:03 server1 courierpop3login: Disconnected, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:03 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:03 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:03 server1 courierpop3login: Disconnected, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:03 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:03 server1 courierpop3login: Disconnected, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:03 server1 courierpop3login: LOGIN FAILED, user=911turbo, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:03 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:04 server1 courierpop3login: Connection, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:04 server1 courierpop3login: LOGIN FAILED, user=987654321, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:04 server1 courierpop3login: LOGIN FAILED, user=99, ip=[::ffff:63.196.95.26]
    Mar  7 12:27:09 server1 courierpop3login: LOGOUT, ip=[::ffff:63.196.95.26]
    
     
  12. Check

    Check New Member

    Just another tib bit. i followed the perfect setup on this site for 6.10. I didnt think i had any errors but aparently i did. Im assuming from the log that my certificate is bad. Any ideas on how to recreate it? Ill keep looking and trying ill let you know if i figure it out. Any ideas would be appriciated though

    Thanks

    Edit: One thing i did realize just now, the domain that i have entered in for the local host is actaully my main domain that i had hoped to have on my server. Currently it is being hosted somewhere else. Until i got everything working i was just testing other domains that i own. Cuuld this affect the mail. This is a little confusing so let me give the example
    server1.mysite1.com-this is the host name/ mysite1.com is hosted somewhere else
    www.mysite2.com and www.mysite3.com are hosted on this box which i am trying to set up. These are the emails im trying to test and are not working. I can however ftp and view the webpages both internally and externally. So im not sure if that makes any difference or if something is jsut screwey. Perhaps ill reinstall....each time i do, more things seem to work.

    let me know
     
    Last edited: Mar 8, 2007
  13. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Yes, this has impact. You can use your main domain name, but the system name needs to have a separate IP address to distinguish it from your current server. Also, for testing emails to [email protected], this will not work, as the MX record probably points to your current server. I won't go in to the details of setting up a secondary MX and how to use that.

    Perhaps you can setup a new domain (domain names are not that expensive), or use tools from DynDNS, or tweak. Tweak means, setup a local 'hosts' file (on your sending system) which contains the information of your new system. The last options quickly leads to mistakes if you're not careful.
     
  14. Check

    Check New Member

    setting up a new domain is really what i already have done. My local host is named something similar to the real website being hosted elsewhere. www.mysite1.com and the server is server`.mysite1.com.

    This is really where that ends, I havent tested web or email with that domain since it is already running and like you said the mx and a records and all that are already associated with the other server where they are being hosted.

    So to test my box i had some spare domains laying around that i set up. these are mysite2.com and mysite3.com. I have those webusites being hosted by this server and http and ftp are both working fine.

    I think you misunderstood me and thought i was saying that im trying to get the first domian working. Is this correct? Im only trying to get the 2nd two to work because if they work then obviously i could get the initial setup.

    Was that any better explained? Sorry if im making this more complicated.
     
  15. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Much better explanation. :D

    /me now puzzled what's your question (if any)?
     
  16. Check

    Check New Member

    Well the email still isnt letting me log into the webmail. Ive gotten to the site correctly but when i log in it says the username and password wont be accepted. I know the passwords right and ive tried "test", "[email protected]" and "web1_test" those are the email, the email with domain and the username. Yes ive actually named it test lol. Anyway you can see my first post or two to get the whole story but basically i just want to email. If i should use an email client to test i can. Well i tried to use outlook but the settings wouldnt pass and it could not connect.

    It has to be something like its not installed or running or soemthing. In the services page it says they are all running but i didnt know how accurate that was.

    Anyway, I just want email :( .
     
  17. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    I assume web1_test is an email user. Have you sent an initial email to this user? Which webmail client do you use?
    For Outlook client, use web1_test, your password and make sure you have set login with authentication. What's the output of
    Code:
    netstat -tap
     
  18. Check

    Check New Member

    On post 5 i have the results for netstat -tap

    I have tried to send messages with server different accounts that i know are working.

    Im using outlook 2003.


    When i use the username and password in outlook and set it to use authentication on the advanced menu i get this error when i hit the test button.
    Code:
    Log onto incoming mail server (pop3): Outlook could not log onto incoming mail server (pop3). Please verify username, password and email.  
    So in the username i have "web1_test", in the password i have that type correctly and for email i have "[email protected]"
     
  19. falko

    falko Super Moderator ISPConfig Developer

    What's the exact error message from the mail log? What's the output of
    Code:
    iptables -L
    ?
     
  20. Check

    Check New Member

    Code:
    Chain INPUT (policy DROP)
    target     prot opt source               destination
    DROP       tcp  --  anywhere             127.0.0.0/8
    ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTAB                                                                             LISHED
    ACCEPT     all  --  anywhere             anywhere
    DROP       all  --  BASE-ADDRESS.MCAST.NET/4  anywhere
    PUB_IN     all  --  anywhere             anywhere
    PUB_IN     all  --  anywhere             anywhere
    PUB_IN     all  --  anywhere             anywhere
    PUB_IN     all  --  anywhere             anywhere
    DROP       all  --  anywhere             anywhere
    
    Chain FORWARD (policy DROP)
    target     prot opt source               destination
    ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTAB                                                                             LISHED
    DROP       all  --  anywhere             anywhere
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    PUB_OUT    all  --  anywhere             anywhere
    PUB_OUT    all  --  anywhere             anywhere
    PUB_OUT    all  --  anywhere             anywhere
    PUB_OUT    all  --  anywhere             anywhere
    
    Chain INT_IN (0 references)
    target     prot opt source               destination
    ACCEPT     icmp --  anywhere             anywhere
    DROP       all  --  anywhere             anywhere
    
    Chain INT_OUT (0 references)
    target     prot opt source               destination
    ACCEPT     icmp --  anywhere             anywhere
    ACCEPT     all  --  anywhere             anywhere
    
    Chain PAROLE (8 references)
    target     prot opt source               destination
    ACCEPT     all  --  anywhere             anywhere
    
    Chain PUB_IN (4 references)
    target     prot opt source               destination
    ACCEPT     icmp --  anywhere             anywhere            icmp destination-un                                                                             reachable
    ACCEPT     icmp --  anywhere             anywhere            icmp echo-reply
    ACCEPT     icmp --  anywhere             anywhere            icmp time-exceeded
    ACCEPT     icmp --  anywhere             anywhere            icmp echo-request
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:ftp
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:ssh
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:smtp
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:domain
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:www
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:81
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:pop3
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:https
    ACCEPT     udp  --  anywhere             anywhere            udp dpt:domain
    DROP       icmp --  anywhere             anywhere
    DROP       all  --  anywhere             anywhere
    
    Chain PUB_OUT (4 references)
    target     prot opt source               destination
    ACCEPT     all  --  anywhere             anywhere
    
     
Thread Status:
Not open for further replies.

Share This Page