Can't log in to SquirrelMail on your server?

Discussion in 'Server Operation' started by oilyflutesalad, Dec 30, 2009.

  1. oilyflutesalad

    oilyflutesalad ISPConfig Developer

    I've had a problem with SquirrelMail since I got my server set up yesterday. If you tried logging in with an incorrect user or password it would tell you it's wrong, as you'd expect. But if you logged in with a CORRECT email address and password, it would tell you that you needed to be logged in!

    If anyone else has this problem, you've probably got session.auto_start switch On in your php.ini. Change the setting in php.ini, restart the Apache service, then try again and it should work.

    On Ubuntu Server, php.ini is located in
    Code:
    /etc/php5/apache2/php.ini
    If you're on a different distro and don't know where to find php.ini, create a script on your server with the following code:
    Code:
    <?php phpinfo(); ?>
    Save it and when you load it in a browser, look for the "Loaded configuration file" setting.



    Note: Google told me to chown and chgrp the session directory to "nobody" but I didn't fancy it, hence finding a proper solution. If your session auto-start is already off or my solution doesn't work for you then you may want to try this instead.
     

Share This Page