Can't log in anymore to IspConfig

Discussion in 'General' started by tsmaudio, Jan 19, 2007.

  1. tsmaudio

    tsmaudio Member

    Hi Guys
    Happy New Year.

    System:perfect set up Fedora core 6 & IspConfig

    I have been usinfg this server set up with no problems for a few weeks now and then all of a sudden i can't login to ISPConfig any more.

    I have checked to make sure all the services are running on the server and everything is ok. I get to the log in page but it will not accept my user and password anymore!

    Any help without having to re-install would be very much appreciated.

    Cheers
    Tony.
     
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Any sign of an error, errorcode or message in a log file?

    You could check /var/log/httpd/error.log (or access.log) to see if you find something unusual. This is the log file of the ISPConfig webserver.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you changed the root password of mysql root user?
     
  4. tsmaudio

    tsmaudio Member

    Hi Guys

    I have been checking the log files for any signs of an error message and there doesn't seem to be anything relevent. I haven't changed anything at all, all i did was power down the server and start it back up again at about this time yesterday.

    This was in the ispconfig_access_log

    [Thu Jan 18 19:06:24 2007] [notice] caught SIGTERM, shutting down n 18 19:06:24 2007] [notice] caught SIGTERM, shutting down
    [Thu Jan 18 19:06:25 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Jan 18 19:06:25 2007] [notice] mod_security/1.9.4 configured - Apache/2.2.3 (Fedora)
    [Thu Jan 18 19:06:25 2007] [notice] Digest: generating secret for digest authentication ...
    [Thu Jan 18 19:06:25 2007] [notice] Digest: done
    [Thu Jan 18 19:06:25 2007] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Thu Jan 18 19:06:25 2007] [notice] configured -- resuming normal operations
    [Thu Jan 18 19:09:13 2007] [notice] caught SIGTERM, shutting down
    [Thu Jan 18 19:09:14 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Jan 18 19:09:14 2007] [notice] mod_security/1.9.4 configured - Apache/2.2.3 (Fedora)
    [Thu Jan 18 19:09:14 2007] [notice] Digest: generating secret for digest authentication ...
    [Thu Jan 18 19:09:14 2007] [notice] Digest: done
    [Thu Jan 18 19:09:14 2007] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Thu Jan 18 19:09:15 2007] [notice] configured -- resuming normal operations
    [Thu Jan 18 19:06:25 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Jan 18 19:06:25 2007] [notice] mod_security/1.9.4 configured - Apache/2.2.3 (Fedora)
    [Thu Jan 18 19:06:25 2007] [notice] Digest: generating secret for digest authentication ...
    [Thu Jan 18 19:06:25 2007] [notice] Digest: done
    [Thu Jan 18 19:06:25 2007] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Thu Jan 18 19:06:25 2007] [notice] configured -- resuming normal operations
    [Thu Jan 18 19:09:13 2007] [notice] caught SIGTERM, shutting down
    [Thu Jan 18 19:09:14 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Jan 18 19:09:14 2007] [notice] mod_security/1.9.4 configured - Apache/2.2.3 (Fedora)
    [Thu Jan 18 19:09:14 2007] [notice] Digest: generating secret for digest authentication ...
    [Thu Jan 18 19:09:14 2007] [notice] Digest: done
    [Thu Jan 18 19:09:14 2007] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Thu Jan 18 19:09:15 2007] [notice] configured -- resuming normal operations

    cheers
    Tony
     
  5. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Whoops, sorry, directed you to the wrong log files. I should have said
    Code:
    /root/ispconfig/httpd/logs/error_log
    . Apologies.
     
  6. tsmaudio

    tsmaudio Member

    I did change something before this started...I just remembered
    I was trying to set the php.ini to be able to upload files between 1Gb-2Gb in size. I modified the file /root/ispconfig/php/php.ini accordingly and I now get this error in the log and i can't log in etc..

    [error] PHP Warning: Unknown: POST Content-Length of 50 bytes exceeds the limit of -1673527296 bytes in Unknown on line 0

    I have tried putting the values back to 500M which is what they were, I can then log in again to ispconfig and everythings ok.

    When i change the values to higher setting say for 1000M, and restart, the phpinfo file is not showing the values changed in the "local value column" and i can't upload files any larger than 500M.

    when i change values in /etc/php.ini.... it does show the new updated values in the "master value column" of the phpinfo.php and it doesn't seem to affect anything.

    I realise this might be a new topic now

    any ideas on whats happening?

    Tony.
     
  7. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    You're mixing the two apache servers.

    The one in /root/ispconfig is the Apache webserver for ISPConfig. That's a Apache 1.3.

    Depending how you installed your system, you probably have apache2 for your regular websites. At least you have a different server. That different server uses the default locations, which (as you could have guessed by now) in /etc. But wait, there might be other locations where Apache2 looks for a php.ini.

    To find all php.ini files, try
    Code:
    find / -name php.ini -print
    on the command line. You could also try to find which php.ini is used, by making a small testscript that shows the output of phpinfo(). Examples are in this forum.

    Change the php.ini that is mentioned in the phpinfo() output and you should be experiencing the improvements you intended.
     
  8. tsmaudio

    tsmaudio Member

    Thanks for your help, I have sorted it.

    cheers
    Tony
     

Share This Page