Cant load sites

Discussion in 'Installation/Configuration' started by Wisdown, Aug 23, 2012.

  1. Wisdown

    Wisdown Member

    After an fresh install, i`m stuck after follow previous guide.

    http://www.howtoforge.com/multiserv...servers-on-debian-squeeze-with-ispconfig-3-p6

    I set the IP server wrong on System / Server IP.
    Then i deleted the wrong input and add an new input with right IP to webserver...

    Now apache keep giving this error:

    [warn] NameVirtualHost xxx.xxx.xxx.xxx:443 has no VirtualHosts
    [warn] NameVirtualHost xxx.xxx.xxx.xxx:80 has no VirtualHosts
    [warn] NameVirtualHost xxx.xxx.xxx.xxx:443 has no VirtualHosts

    But there no website add, no dns, no mail account, nothing...
    Just a fresh install

    If i try add any website they all enter in https mode and i receive an warn about:

    Potential DNS Rebind attack detected, see http://em.wikipedia.org/wiki/DNS rebinding

    I already have add an dns forwarder to local ip on firewall and the issue persists...

    Any hint where i`m missing set something?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats fine and not a error.The message means that the IP'slisted there are available for websites. Ensure that you added the internal IP addresses there if your server is behind a nat router and not the external IP addresses.

    Thats a issue in your router or local network, its not related to the ispconfig server.
     
  3. Wisdown

    Wisdown Member

    I dindt have that message before format, and sites was working fine, i just did an format because webmin did an mess on ISPConfig

    Now on an fresh install i got this message and when i added new domains for example:

    www.somewhere.com
    www.anotherplace.com

    They all enter in https mode trying open the ispconfig admin, example:

    https://192.168.0.5:8080

    This after i set the correct dns and say to bind on 192.168.0.5 without check ssl.

    How can i reset my apache without lose the setting of ISPConfig?
    Like remove all vhost , and related stuff to apache remake.

    Another thing:

    If i try access the server by IP: 192.168.0.5 i dont see anymore the top header and footpad logo from IPConfig.

    Just the Apache Message:

    It works...
     
    Last edited: Aug 23, 2012
  4. Wisdown

    Wisdown Member

    I still unable to load websites in local mode

    After update the hosts i get this:

    Error code: ssl_error_rx_record_too_long

    If i remember right, while i was installing, the script get a wierd behavior, one time the ISPConfig set an certificate using 4096 (webserver), another time he did with 2048.

    Dunno if is it what broken the install...

    And when i click to see the certificate, the data i typed when the certficate was made is missing...
     
  5. falko

    falko Super Moderator ISPConfig Developer

    I suggest you recreate the certificates.
     
  6. Wisdown

    Wisdown Member

    Thanks for the answer.
    I give up from use the multiserver dedicated, since always there an issue to be fixed, almost 2 months trying get this up with all things working...

    Now i will focus on all setup in only one VMWare.

    Once more time thanks.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The above error indicates that your ssl cert is broken, so this issue was neither related to ispconfig nor the use of a multiserver setup.
     

Share This Page