Can't launch firefox

Discussion in 'Desktop Operation' started by Wraithfire, Apr 18, 2006.

  1. Wraithfire

    Wraithfire New Member

    well i just tried to update to firefox 1.5.0.2 with disatrous results it seems. the install wouldn't work, so i removed it and re installed mozilla-firefox, but now that won't work if i try to launch firefox i get:
    Xlib: connection to ":0.0" refused by server
    Xlib: XDM authorization key matches an existing client!

    and if i try to launch mozilla-firefox:
    Xlib: connection to ":0.0" refused by server
    Xlib: XDM authorization key matches an existing client!

    (firefox-bin:3957): Gtk-WARNING **: cannot open display:

    any idea what's going here? :confused:
     
  2. Wraithfire

    Wraithfire New Member

    ok now when i run mozilla-firefox from terminal i get this:
    Extension System Warning: Failed to set up default extensions files probably because you do not have write privileges to this location. While you can run Firefox like this, it is recommended that you run it at least once with privileges that allow it to generate these initial files to improve start performance. Running from a disk image on MacOS X is not recommended.

    But the screen is blank, and i can't seem to run it as root or sudo; when i try i get:

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified


    (firefox-bin:4058): Gtk-WARNING **: cannot open display:
     
  3. falko

    falko Super Moderator

    Which distribution do you use? What exactly did you do to install Firefox and then remove it?
     
  4. Wraithfire

    Wraithfire New Member

    I'm running Debian sarge, i tried to install firefox 1.5 using backports:
    apt-get -t Sarge-backports install firefox
    immediately after this, firefox stopped working. I realize i didn't remove the mozilla firefox first, so i tried that:
    apt-get remove mozilla-firefox
    but firefox1.5 still wouldn't work, so i tried manually removing the 1.5 install by deleting:
    /usr/lib/firefox
    following a post i read online somewhere (lost the page)
    I've reinstalled mozilla-firefox:
    apt-get install mozilla-firefox
    which was not working at first, but now gives the extension system warning i posted last time and is EXTREMELY slow.
     
  5. Wraithfire

    Wraithfire New Member

    I ran this and thought i'd post it just in case it helps:

    /usr/lib/firefox$ ldd firefox-bin
    libmozjs.so => /usr/lib/libmozjs.so (0x00002af58bf44000)
    libxpcom.so => /usr/lib/libxpcom.so (0x00002af58c0da000)
    libxpcom_core.so => not found
    libplds4.so => /usr/lib/libplds4.so (0x00002af58c2c1000)
    libplc4.so => /usr/lib/libplc4.so (0x00002af58c3c5000)
    libnspr4.so => /usr/lib/libnspr4.so (0x00002af58c4ca000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x00002af58c606000)
    libdl.so.2 => /lib/libdl.so.2 (0x00002af58c71b000)
    libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00002af58c81e000) libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00002af58cc23000) libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00002af58cdb4000)
    libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00002af58ced8000)
    libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x00002af58cfee000)
    libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x00002af58d0f6000)
    libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00002af58d202000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00002af58d345000) libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00002af58d47e000) libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00002af58d581000)
    libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x00002af58d707000)
    libm.so.6 => /lib/libm.so.6 (0x00002af58d8e3000)
    libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00002af58da69000)
    libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x00002af58db90000)
    libsmime3.so => /usr/lib/libsmime3.so (0x00002af58dcb2000)
    libssl3.so => /usr/lib/libssl3.so (0x00002af58dddc000)
    libnss3.so => /usr/lib/libnss3.so (0x00002af58df01000)
    libsoftokn3.so => /usr/lib/libsoftokn3.so (0x00002af58e084000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00002af58e209000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00002af58e312000)
    libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x00002af58e4a1000)
    libXp.so.6 => /usr/X11R6/lib/libXp.so.6 (0x00002af58e602000)
    libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x00002af58e70a000)
    libxpcom_compat.so => /usr/lib/libxpcom_compat.so (0x00002af58e81c000)
    libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x00002af58e93e000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00002af58eb1b000)
    libc.so.6 => /lib/libc.so.6 (0x00002af58ec27000)
    libXft.so.2 => /usr/lib/libXft.so.2 (0x00002af58ee66000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00002af58ef7a000)
    libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x00002af58f0ba000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00002af58f1e4000)
    /lib64/ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2 (0x00002af58be2e000)
    libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x00002af58f3d5000)
    libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x00002af58f4d8000)
    libz.so.1 => /usr/lib/libz.so.1 (0x00002af58f5e0000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00002af58f6f5000)
    libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x00002af58f800000)
    libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x00002af58f90a000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00002af58fa24000)
     
  6. Wraithfire

    Wraithfire New Member

    Well i managed to get firefox 1.0 working again, so i this time i downloaded the firefox1.5 files from http://www.backports.org and i installed them, but it still won't work. i get these messages when i run from terminal :
    wraithfire@Hellfury:~$ firefox
    Segmentation fault
    and :
    Hellfury:/home/wraithfire# firefox
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified


    (firefox-bin:3860): Gtk-WARNING **: cannot open display:
    no i decided to ldd firefox-bin again, and so i [CODE} locate firefox-bin [/CODE] and it pointed me to the wrong directory, /usr/lib/mozilla-firefox/firefox-bin. after some searching i found that the correct path was /usr/lib/firefox/firefox-bin and i ldd it

    libmozjs.so => /usr/lib/libmozjs.so (0x00002ac589610000)
    libxpcom.so => /usr/lib/libxpcom.so (0x00002ac5897a6000)
    libxpcom_core.so => not found
    libplds4.so => /usr/lib/libplds4.so (0x00002ac58998d000)
    libplc4.so => /usr/lib/libplc4.so (0x00002ac589a91000)
    libnspr4.so => /usr/lib/libnspr4.so (0x00002ac589b96000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x00002ac589cd2000)
    libdl.so.2 => /lib/libdl.so.2 (0x00002ac589de7000)
    libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00002ac589eea000) libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00002ac58a2ef000) libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00002ac58a480000)
    libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00002ac58a5a4000)
    libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x00002ac58a6ba000)
    libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x00002ac58a7c2000)
    libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00002ac58a8ce000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00002ac58aa11000) libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00002ac58ab4a000) libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00002ac58ac4d000)
    libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x00002ac58add3000)
    libm.so.6 => /lib/libm.so.6 (0x00002ac58afaf000)
    libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00002ac58b135000)
    libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x00002ac58b25c000)
    libsmime3.so => /usr/lib/libsmime3.so (0x00002ac58b37e000)
    libssl3.so => /usr/lib/libssl3.so (0x00002ac58b4a8000)
    libnss3.so => /usr/lib/libnss3.so (0x00002ac58b5cd000)
    libsoftokn3.so => /usr/lib/libsoftokn3.so (0x00002ac58b750000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00002ac58b8d5000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00002ac58b9de000)
    libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x00002ac58bb6d000)
    libXp.so.6 => /usr/X11R6/lib/libXp.so.6 (0x00002ac58bcce000)
    libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x00002ac58bdd6000)
    libxpcom_compat.so => /usr/lib/libxpcom_compat.so (0x00002ac58bee8000)
    libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x00002ac58c00a000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00002ac58c1e7000)
    libc.so.6 => /lib/libc.so.6 (0x00002ac58c2f3000)
    libXft.so.2 => /usr/lib/libXft.so.2 (0x00002ac58c532000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00002ac58c646000)
    libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x00002ac58c786000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00002ac58c8b0000)
    /lib64/ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2 (0x00002ac5894fa000)
    libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x00002ac58caa1000)
    libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x00002ac58cba4000)
    libz.so.1 => /usr/lib/libz.so.1 (0x00002ac58ccac000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00002ac58cdc1000)
    libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x00002ac58cecc000)
    libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x00002ac58cfd6000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00002ac58d0f0000)

    libxpcom_core.so => not found

    after some more searching i found libxpcom_core.so in /usr/lib/firefox :
    chrome icons libsoftokn3.so searchplugins
    components libmozjs.so libssl3.so xpcshell
    defaults libnspr4.so libxpcom_compat.so xpicleanup
    extensions libnss3.so libxpcom_core.so xpidl
    firefox libnssckbi.so libxpcom.so xpt_dump
    firefox-bin libplc4.so libxpistub.so xpt_link
    firefox.cfg libplds4.so plugins
    firefox-xremote-client libsmime3.so regxpcom
    greprefs libsoftokn3.chk res

    so it's there, do i need to make a link to this or something like that, and if i do, how do i do that?
     
  7. falko

    falko Super Moderator

    You can do it like this:
    Code:
    ln -s /usr/lib/firefox/libxpcom_core.so /usr/lib/firefox/firefox-bin
     
  8. Wraithfire

    Wraithfire New Member

    Well i made the link with this result:
    wraithfire@Hellfury:~$ sudo ln -s /usr/lib/firefox/libxpcom_core.so /usr/lib/firefox/firefox-bin
    Password:
    ln: `/usr/lib/firefox/firefox-bin': File exists

    and firefox still won't launch
     
  9. falko

    falko Super Moderator

    Then try this:
    Code:
    ln -s /usr/lib/firefox/libxpcom_core.so /usr/lib/firefox/firefox-bin/libxpcom_core.so
     
  10. Wraithfire

    Wraithfire New Member

    Code:
     ln -s /usr/lib/firefox/libxpcom_core.so /usr/lib/firefox/firefox-bin/libxpcom_core.so 
    Done, and i get back:

    ln: accessing `/usr/lib/firefox/firefox-bin/libxpcom_core.so': Not a directory

    symlinks are kinda tricky it seems :confused:
     
  11. Wraithfire

    Wraithfire New Member

    wraithfire@Hellfury:/usr/lib/firefox$ ln -s libxpcom_core.so ./firefox-bin
    ln: `./firefox-bin': File exists
    wraithfire@Hellfury:/usr/lib/firefox$ ln -s ./firefox-bin libxpcom_core.so
    ln: `libxpcom_core.so': File exists
    wraithfire@Hellfury:/usr/lib/firefox$ ln -s ./firefox-bin .
    ln: `./firefox-bin': File exists

    hmm, i think i'm doing something wrong here... :confused:
     
  12. Wraithfire

    Wraithfire New Member

    i tried to run start firefox like this :
    Code:
     /usr/lib/firefox/firefox-bin 
    returns:
    usr/lib/firefox/firefox-bin: error while loading shared libraries: libxpcom_core.so: cannot open shared object file: No such file or directory

    as i said earlier i found libxpcom_core.so in /usr/lib/firefox , so i did as root:
    Code:
     cp /usr/lib/firefox/libxpcom_core.so /usr/lib 
    and now
    Code:
     ldd /usr/lib/firefox/firefox-bin 
    returns:
    libmozjs.so => /usr/lib/libmozjs.so (0x00002ab1c861c000)
    libxpcom.so => /usr/lib/libxpcom.so (0x00002ab1c87b2000)
    libxpcom_core.so => /usr/lib/libxpcom_core.so (0x00002ab1c8999000)
    libplds4.so => /usr/lib/libplds4.so (0x00002ab1c8b81000)
    libplc4.so => /usr/lib/libplc4.so (0x00002ab1c8c85000)
    libnspr4.so => /usr/lib/libnspr4.so (0x00002ab1c8d8a000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x00002ab1c8ec6000)
    libdl.so.2 => /lib/libdl.so.2 (0x00002ab1c8fdb000)
    libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00002ab1c90de000) libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00002ab1c94e3000) libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00002ab1c9674000)
    libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00002ab1c9798000)
    libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x00002ab1c98ae000)
    libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x00002ab1c99b6000)
    libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00002ab1c9ac2000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00002ab1c9c05000) libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00002ab1c9d3e000) libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00002ab1c9e41000)
    libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x00002ab1c9fc7000)
    libm.so.6 => /lib/libm.so.6 (0x00002ab1ca1a3000)
    libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00002ab1ca329000)
    libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x00002ab1ca450000)
    libsmime3.so => /usr/lib/libsmime3.so (0x00002ab1ca572000)
    libssl3.so => /usr/lib/libssl3.so (0x00002ab1ca69c000)
    libnss3.so => /usr/lib/libnss3.so (0x00002ab1ca7c1000)
    libsoftokn3.so => /usr/lib/libsoftokn3.so (0x00002ab1ca944000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00002ab1caac9000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00002ab1cabd2000)
    libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x00002ab1cad61000)
    libXp.so.6 => /usr/X11R6/lib/libXp.so.6 (0x00002ab1caec2000)
    libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x00002ab1cafca000)
    libxpcom_compat.so => /usr/lib/libxpcom_compat.so (0x00002ab1cb0dc000)
    libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x00002ab1cb1fe000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00002ab1cb3db000)
    libc.so.6 => /lib/libc.so.6 (0x00002ab1cb4e7000)
    libXft.so.2 => /usr/lib/libXft.so.2 (0x00002ab1cb726000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00002ab1cb83a000)
    libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x00002ab1cb97a000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00002ab1cbaa4000)
    /lib64/ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2 (0x00002ab1c8506000)
    libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x00002ab1cbc95000)
    libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x00002ab1cbd98000)
    libz.so.1 => /usr/lib/libz.so.1 (0x00002ab1cbea0000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00002ab1cbfb5000)
    libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x00002ab1cc0c0000)
    libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x00002ab1cc1ca000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00002ab1cc2e4000)

    seems like it detects the file, but it still doesn't work. when i run this:
    Code:
     /usr/lib/firefox/firefox-bin 
    the cursor just hangs with blank return and ^c doesn't return the prompt. all other attempts to start it return the same errors as before, segmentation fault as normal user or
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified


    (firefox-bin:3856): Gtk-WARNING **: cannot open display:
    as root or sudo

    anyone have any ideas on this?
     
  13. falko

    falko Super Moderator

    Maybe you should try to compile Firefox from the sources. I think it's easier than fiddling around with the broken package.
     
  14. Wraithfire

    Wraithfire New Member

    Wow this is WAY to much work, at this point i downgraded the package back tostable release 1.0 and I'll just use that :D
    thanks for trying to help me anyways
     

Share This Page