Can't issue LE certificate "Solved"

Discussion in 'ISPConfig 3 Priority Support' started by ganewbie, Oct 29, 2019.

  1. ganewbie

    ganewbie Member HowtoForge Supporter

    Installed exactly like the tutorial.

    [QUOTE="That's not needed. Its the part which automatically modifies apache config files and that's exactly what should not happen as certbot duplicates existing config which then causes issues, so you don't need that package. It does not hurt when you installed it though unless you would actually use it.[/QUOTE]
    So we will not install it then.
  2. ganewbie

    ganewbie Member HowtoForge Supporter

    Thanks you, will try it.
  3. ganewbie

    ganewbie Member HowtoForge Supporter

    Good news, it is working now. Thanks to all that helps.
    Here is what I have done:
    mv /etc/letsencrypt letsencrypt_old
    mv /usr/local/bin/certbot-auto certbot-auto_old
    mv /opt/ eff.org_old
    cd /usr/local/bin
    chmod a+x certbot-auto
    ./certbot-auto --install-only
    After that issuing the LE SSL was working for the one subdomain, but we lost access to the ISPconfig control panel as apache did not restart.
    Had to do the following.
    cd /etc/apache2/sites-enabled/
    You need to unlink all of the sites that you see there. We did a mistake that we deleted ispconfig vhost, in our opinion that should have been left there but run:
    to re-issue a certificate to gain access to the panel.
    In any case, once we gained access to the control panel, we start issuing SSL and back to normal.
    Thanks to Till, Croydon and elmacus
    till likes this.

Share This Page