Cant install Plugins for squirrelmail

Discussion in 'Installation/Configuration' started by morten44, Apr 26, 2012.

  1. morten44

    morten44 New Member

    Have setup ispconfig using this manual:

    I have an issue installing a plugin for squirrelmail called "change_sqlpass" so each user can change the password for their own account

    I have installed it using the following instructions:

    When I go in and try to change password i get error:

    So I read out from this that my include_path="."
    It should be /usr/share/php: /usr/share/php/PEAR

    So I upload a phpinfo.php file and contact the squirrelmail comunity as it looks ok:

    They asked me to run the phpinfo.php from squirrel library and so I did
    (using https as cant get domain/webmail to work)
    and to my suprise it now shows include_path="."

    I have updated php.ini in /etc/php5/apache2/php.ini and the php.ini in the cgi folder

    I then tried to add a line to .httaccess file:
    php_value include_path ".:/usr/share/php: /usr/share/php/PEAR"
    no joy

    Then they say that my system is setup to not read the .htaccess file and they mention several steps I should take. As a newbee i dont understand mutch of it and I am affraid it will affect how ipsconfig works so thats why I contact you guys to see if you have any idea

    You can see the thread here:

    Do you have any idea why its not working?
    Why cant I get the include_path ot show in the library where squirrelmail runs from (usr/share/squirrelmail i guess)

    Kind Regards
  2. falko

    falko Super Moderator ISPConfig Developer

    Where is DB.php located?

    locate DB.php
  3. morten44

    morten44 New Member

    Thanks for comming back to me

    I ran the command and this is the output:


    Kind Regards
  4. falko

    falko Super Moderator ISPConfig Developer

    I think you need to add /usr/share/php to the open_basedir setting.
  5. morten44

    morten44 New Member

    Thanks for reply
    I did that and still no Joy
    I added them to open_basedir in Ispconfig under the customer
    In the php.ini file its commended out.
    Is that correct?

    anything else I can check?

    Regards Morten
  6. morten44

    morten44 New Member

Share This Page