Can't install libapache2-mod-fastcgi

Discussion in 'Installation/Configuration' started by Hbod, Feb 20, 2017.

  1. Hbod

    Hbod New Member

    Hi,

    following the perfect server setup, I was able to fully install ISPConfig on my Raspberry PI 3 Model B. It's running very smoothly and everything works fine, except for PHP-FPM. I added all the deb-sources into it (double checking it was the "non-free"). Whatever I do, I receive

    > apt-get install libapache2-mod-fastcgi php5-fpm

    E: Package 'libapache2-mod-fastcgi' has no installation candidate

    or

    Package libapache2-mod-fastcgi is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

    I am stuck to Fast-CGI currently, as FPM needs this package. Can anybody help me please? (Also tried to generate the .deb myself, also this was not possible). Thanks in advance! Even my self-compiled PHP 7 FPM does not work, only the Fast-CGI one.
     
    Last edited: Feb 20, 2017
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ou can try to install and use the mod_proxy_fcgi package instead, ispconfig has a fallback config to use that when mod_fastcgi is missing.
     
  3. Hbod

    Hbod New Member

    Do you have a guide for me? Please keep in mind, that Raspberry PI is 32 Bit
    Edit:
    a2enmod proxy proxy_http

    And after that, Apache restart and I also set the Webseite to PHP-FPM, but the PHP-File will be still shown as code inside the browser. I do not have any problems with FPM on my live server, but can't to get it work on the Raspberry.. :(
     
  4. Hbod

    Hbod New Member

    till likes this.

Share This Page