can't help ispconfig to install please help

Discussion in 'Installation/Configuration' started by steve51184, Feb 12, 2009.

  1. steve51184

    steve51184 New Member

    been trying to ispconfig to install but just can't get it to work.. i have a ubuntu 8.04 system with all required software but i get this error after it "installs"

     
  2. till

    till Super Moderator

    There must be errors on the screen before the part you posted. Please post the first error message. The best way to prevent these problems is to follow exactly the ispconfig installation instructions for ubuntu 8.04
     
  3. steve51184

    steve51184 New Member

    i followed it exactly.. here's all that i can copy before it got cut of in putty:

     
  4. Allen15

    Allen15 New Member

    I am running 8.10 (now), but that has nothing to do with your errors. I have gotten those same errors before, and they were apparently the result of a typo during the setup on one of the steps or some package that didn't install (or install correctly).

    It will be much faster (especially if this is a clean installation on a new system) to delete your ispconfig install folder, delete /root/ispconfig (-R), and format/reinstall from scratch.

    I found that I not only got better results by doing a bare installation with only OpenSSH server, and then switching over to a remote PuTTY session thereafter, but I was also able to copy and paste all of the commands into a plain text file, edit anything that was supposed to be specific to my install, and then paste the commands into PuTTY much faster and more accurately than by typing and/or retyping them by hand. It will probably take you less time to scrape and reload than to chase your demons.

    The ISPConfig installation will automatically delete most of itself if it errors out during install, and that is what the tail end of your errors is showing from your first posting.

    HTH
     
  5. steve51184

    steve51184 New Member

    but i can't format my server it's a new server and i've just got it and i have it half setup.. don't you have any idea what is causing it?
     
  6. till

    till Super Moderator

  7. Allen15

    Allen15 New Member

    I hope you don't already have sites and/or users setup on it, as that was specifically warned against in the ISPConfig documentation, but no matter what, you will have to at the very least, delete your installation folder, delete the /root/ispconfig/* tree, and delete/drop any mysql database created by this installation.

    If the installation had completed normally, there would be an uninstall script in /root/ispconfig, but you may not have gotten that far before it bombed out. If not, you have to manually do the 3 things mentioned first. After that, you can go back through your instruction set and copy/paste all of the commands to install and configure software for the server setup, just to be sure, since the worst that can happen is that apt-get install [whatever] will give you and error message that package xyz is already installed, and at best, will install something that you didn't successfully get installed the previous time.

    Hopefully you only have a missing package issue, not a configuration problem, since not knowing what you have or where it is kept will keep you from being able to go back to original (clean install) configuration and at my level of inexperience, the only way I know how to reset the configuration files is to wipe and reload.

    If you do get your packages all installed, try to ftp in and upload the ISPConfig install file, which will verify that your ftp server is working too. Copy or move it to /var/tmp, re-extract, and re-install. Keep an eye on the PuTTY window for errors (You *are* doing this from a remote shell, right?), and keep in mind that if it installs correctly, this process will end up taking MUCH longer than before when it erred out and stopped prematurely. YMMV depending on the speed of your server, but I found that it took almost a hour to completely run through the installation script when it was working correctly vs. something like less than 6 minutes when it gave me your original errors.

    Remember that copy and paste are your best friends, and you might even consider pasting onto a very boring plain text editor that you can change fonts on, just in case you have some visual confusion over what some character is in your web browser font vs, what the actual ascii character really is. If you have any doubts over whether something is a one or the lower-case letter "L", change the font and look at it again for a 2nd opinion, if it may make a difference.

    Good luck
     
  8. Allen15

    Allen15 New Member

    That step also doesn't give any visual feedback on whether or not it was successfully completed, so it is really one to copy and paste, and it wouldn't hurt to copy and paste it twice.

    How can one check to see if that step was successful?? If there is some way to check, it would be nice to update the How-To description of that step to include verification of completion? Just a thought...
     
    Last edited: Feb 13, 2009
  9. steve51184

    steve51184 New Member

    that seems to get me a little further but i still get errors:

     
  10. Allen15

    Allen15 New Member

    I would have to guess that you either are missing some installation package or had an error during the perfect-server-setup installation that you missed while installing something, OR you have the wrong version of something installed.

    I know this all sounds like a royal PITA, but did you try re-installing all of the packages listed in the perfect server setup guide, and did you do a copy and paste of ALL of those lines directly from the web page to a remote shell?

    When I went back through determined to make this work or catch the error in the installation, I did each step, and then tried to look for ways to verify that each step actually completed properly. The first step of installing OpenSSH server is pretty easy to verify, because you can't get a remote PuTTY session to work if that step wasn't properly done at the console, but each step thereafter gives an opportunity to test to see if it worked or will be what is tripping you up.

    I don't know if there is an official way to verify step 9, but what I did was to type gibberish at the prompt, and upon pressing enter, I got a response from the command shell that what junk I'd typed was an unknown command, and looked something like this: "bash: tgarihgo: unreconized command or filename."

    I don't know if that is worth anything, but nearly every other step produced results that were readily verified. Anything you install with apt-get install will either return a result that it is already installed, or go through the process of installing, sometimes prompting you to approve the additional hard drive space/usage.

    There was also a thread I found somewhere in this forum where the discussion suggested that some of the packages had changed contents over the life of the tutorial, and didn't (no longer?) automatically install all of the needed libraries and/or modules, but I didn't mark it, and don't remember it. You could have some modules or libraries that may have been removed because they were thought to be orphaned but turned out to be needed later on. Try re-installing EVERYTHING that you installed with apt-get and watch the outputs to see if anything actually installs, and then do the triple dump of dropping/deleting the mysql database, deleting the /root/ispconfig directory recursively, and also the install directory too. Re-extract ISPConfig from the tar.gz file, and try it again?

    Good luck.
     
  11. steve51184

    steve51184 New Member

    i've done everything again in that guide and also after the failed install thee is no mysql database, /root/ispconfig directory or install directory nothing...

    also the errors seem to start with... "cd: error retrieving current directory: getcwd"

    i'm starting to think this is a messed up image my new host uses and have made changes as i'm getting errors for other things
     
    Last edited: Feb 13, 2009
  12. Allen15

    Allen15 New Member

    Chances are, by the time you got that error, the damage was already done, and the installation script had already started deleting itself and its files, and what you are actually seeing is the result of that, not the cause.
     
  13. steve51184

    steve51184 New Member

    reinstalling ubuntu now and will follow "The Perfect Server" line for line
     
  14. steve51184

    steve51184 New Member

    well it worked hehe thank for the help guys!!!

    also can i setup my name servers in ispconfig if so how as i normally do this in webmin
     
  15. steve51184

    steve51184 New Member

    ok i've run into a problem i have ispconfig setup fine and wanted to setup my names servers in ispconfig which i did i then setup dns and i then added a site to the server again all with ispconfig but i noticed bind isn't running and won't start...

    i've also looked in /var/log/syslog and found this:

    here's the contents of my named.conf file:

    also please not i only have 1 server and have setup both ns1, ns2 on the same server
     
    Last edited: Feb 13, 2009
  16. till

    till Super Moderator

    Please remove all secondary dns records that you created and empty the recycle bin afterwards. When ns1 and ns2 are on the same server, there are no secondary records needed.
     
  17. steve51184

    steve51184 New Member

    there we go all sorted also thank you very much for the quick reply
     
    Last edited: Feb 13, 2009
  18. jhon

    jhon New Member

    ./setup2: line 1090: mysql_config: No such file or directory

    i have same problem to you bro i just recheck my setup here http://www.howtoforge.com/perfect-server-ubuntu8.04-lts-p6 then my setup complete without error:)
     

Share This Page